Linux Mint 18.3 Installer doesn't recognize EFI partition

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Tue Mar 06, 2018 6:16 pm

Linux Mint 18.3 Installer doesn't recognize EFI partition

Post by bobochko » Tue Mar 06, 2018 6:38 pm


I have played with various Linux distros on my PC in dual boot mode.
I'm using Windows 10 as my primary OS and had LMDE working for a while. I like the Cinnamon but I've encountered many small issues with LMDE that take time to solve so I would like to switch to something little bit more refined and just use my computer as usual.

The problem with Mint is that I cannot make it boot from EFI partition that was created by Windows. Installer doesn't recognize it as EFI while it has all required boot flags. Please see pictures attached.


I've tried to set it as FAT32 partition with /boot/efi mountpoint, tried setting bootloader to the root of the drive and to EFI partition, nothing seems to work. It boots into Grub resque.

There was no problem booting LMDE on this machine. Installer automatically recognized my EFI partition.

I think I might need to delete EFI partition and create it from scratch but I don't want to loose Windows.
Can you help me do it the right way?


mint@mint ~ $ inxi -Fxz
System: Host: mint Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: Mobo: ASUSTeK model: PRIME Z370-A v: Rev X.0x
Bios: American Megatrends v: 0607 date: 01/08/2018
CPU: Hexa core Intel Core i5-8600K (-MCP-) cache: 9216 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 43200
clock speeds: max: 5000 MHz 1: 799 MHz 2: 4247 MHz 3: 800 MHz
4: 799 MHz 5: 799 MHz 6: 4958 MHz
Graphics: Card: NVIDIA GM204 [GeForce GTX 970] bus-ID: 01:00.0
Display Server: X.Org 1.18.4 driver: vesa
Resolution: 1024x768@61.00hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 256 bits)
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio: Card-1 Intel Device a2f0 driver: snd_hda_intel bus-ID: 00:1f.3
Card-2 NVIDIA GM204 High Definition Audio Controller
driver: snd_hda_intel bus-ID: 01:00.1
Card-3 C-Media CMI8788 [Oxygen HD Audio]
driver: snd_virtuoso port: d000 bus-ID: 06:04.0
Card-4 Logitech Webcam C270 driver: USB Audio usb-ID: 001-005
Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network: Card-1: Intel Ethernet Connection (2) I219-V
driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
IF: enp0s31f6 state: down mac: <filter>
Card-2: Intel Wireless 7260 driver: iwlwifi bus-ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
Drives: HDD Total Size: NA (-) ID-1: /dev/nvme0n1 model: N/A size: 250.1GB
ID-2: /dev/sda model: Samsung_SSD_850 size: 250.1GB temp: 0C
ID-3: /dev/sdb model: WDC_WD40EZRZ size: 4000.8GB temp: 22C
ID-4: /dev/sdc model: WDC_WD20EFRX size: 2000.4GB temp: 21C
ID-5: /dev/sdd model: WDC_WD20EFRX size: 2000.4GB temp: 24C
ID-6: USB /dev/sdf model: UDisk size: 16.1GB temp: 0C
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
Fan Speeds (in rpm): cpu: 0
Info: Processes: 254 Uptime: 2:23 Memory: 1243.5/15981.3MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

User avatar
Level 4
Level 4
Posts: 471
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Linux Mint 18.3 Installer doesn't recognize EFI partition

Post by pbear » Wed Mar 07, 2018 12:27 pm

First, don't even consider deleting the existing EFI partition unless you know how to restore it in Windows.

Second, your images don't seem to have uploaded correctly. At least, I can't see them. Please edit the OP and either upload them again or, better if you have an image hosting account somewhere, upload them there and link here with rimg tags.

Third, it will be in the images but for clarity, which is the EFI partition?
Time flies like an arrow. Fruit flies like a banana.
Running Mate 18.3 64 bit (by upgrade from 18.1-2)

Level 6
Level 6
Posts: 1174
Joined: Tue Mar 11, 2014 4:30 pm

Re: Linux Mint 18.3 Installer doesn't recognize EFI partition

Post by fabien85 » Wed Mar 07, 2018 2:59 pm

And consider installing refind from windows, using the windows manual instructions. That's a simple workaround.

Level 3
Level 3
Posts: 117
Joined: Wed Jun 01, 2011 2:12 pm

Re: Linux Mint 18.3 Installer doesn't recognize EFI partition

Post by Reddog1 » Fri Mar 09, 2018 4:56 pm

1. Did you turn off UEFI "Secure Boot" in Bios?

2. Did you choose "Install Alongside Windows" or "Something Else" for installation"

3. Did you choose to use the "Windows Boot Manager" to boot Mint?

I'm unclear if Mint recognizes the location of the Windows Boot Manager during installation--or not. I usually choose to use the Windows Boot Manager instead of installing Grub to the Linux partition and 18.3 has always found it successfully.

Post Reply

Return to “Installation & Boot”