Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode [Solved]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Locked
TheVillagerGamer28
Level 1
Level 1
Posts: 5
Joined: Sat Apr 14, 2018 9:09 pm
Location: Earth

Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode [Solved]

Post by TheVillagerGamer28 » Sat Apr 14, 2018 10:01 pm

Just yesterday, I decided to install Linux Mint to see how it compares with Windows. So, I created the live USB, plugged the USB into my computer, and tried to boot. It was fine until I left the grub. On it, I chose the first option. After a few seconds, it showed me a black screen, and it wouldn't boot. So then, I looked up how to bypass that black screen. Some website told me to type in "nomodeset" into the grub thing (I have no idea what it is called). Fortunately, it did boot up, so I was able to install Linux Mint. I booted the OS the same way (with nomodeset), logged in, and in the top-right corner of the screen, there was a message that stated that I was in software rendering mode. It made the OS slow. Later, I did more research, and something said that the message meant that Hardware Acceleration was off. I checked in my BIOS settings, and it said that it was enabled. If anyone could help me get this working, that would be great.

PC specs (That might be useful):

Code: Select all

Computer: Dell Inspiron 11 3162
CPU: Intel Celeron N3050 / 1.6 GHz
GPU: Intel HD Integrated Graphics
P.S. I'm kinda new to Linux.

EDIT: I've just decided to go back to Windows 10, and install Linux Mint on my other computer. In fact, I've just installed it about an hour ago. Thank you for the help that you sent me!
Last edited by TheVillagerGamer28 on Sun Apr 22, 2018 4:10 pm, edited 2 times in total.
hai i is a signitur

User avatar
jimallyn
Level 18
Level 18
Posts: 8532
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by jimallyn » Sat Apr 14, 2018 11:40 pm

I'm going to guess that you installed the Cinnamon version, which requires hardware graphics acceleration, and that your computer doesn't have hardware acceleration. But let's find out for sure: open a terminal, maximize the window to avoid cut off lines, type in inxi -Fxz and press Enter. Copy/paste whatever that spits out into your next post here. If indeed your computer does not have hardware acceleration, you will want to install a different Mint version. I would recommend XFCE or MATE, but not Cinnamon or KDE.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

TheVillagerGamer28
Level 1
Level 1
Posts: 5
Joined: Sat Apr 14, 2018 9:09 pm
Location: Earth

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by TheVillagerGamer28 » Sun Apr 15, 2018 2:02 pm

Code: Select all

System:    Host: tvg28-Inspiron-11-3162 Kernel: 4.13.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Unity 7.4.5 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Inspiron 11-3162 v: 2.4.0
           Mobo: Dell model: 0TJ2Y4 v: A00
           Bios: Dell v: 2.4.0 date: 01/31/2018
CPU:       Dual core Intel Celeron N3060 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6400
           clock speeds: max: 2480 MHz 1: 655 MHz 2: 736 MHz
Graphics:  Card: Intel Device 22b1 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa) FAILED: intel
           Resolution: 1366x768@76.00hz
           GLX Renderer: llvmpipe (LLVM 5.0, 128 bits)
           GLX Version: 3.0 Mesa 18.0.0-rc4 Direct Rendering: Yes
Audio:     Card Intel Device 2284 driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-38-generic
Network:   Card: Intel Wireless 3160 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk0 model: N/A size: 31.3GB
Partition: ID-1: / size: 28G used: 7.8G (30%) fs: ext4 dev: /dev/mmcblk0p3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 36.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 174 Uptime: 2 min Memory: 998.1/3844.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Last edited by WharfRat on Mon Apr 16, 2018 5:33 pm, edited 1 time in total.
Reason: Added code tag
hai i is a signitur

TheVillagerGamer28
Level 1
Level 1
Posts: 5
Joined: Sat Apr 14, 2018 9:09 pm
Location: Earth

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by TheVillagerGamer28 » Mon Apr 16, 2018 5:01 pm

Wait... Is Virtualization the same as Hardware Acceleration?
hai i is a signitur

User avatar
jimallyn
Level 18
Level 18
Posts: 8532
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by jimallyn » Mon Apr 16, 2018 7:15 pm

TheVillagerGamer28 wrote:
Mon Apr 16, 2018 5:01 pm
Wait... Is Virtualization the same as Hardware Acceleration?
No. Virtulization is when hardware is emulated in software. An example would be using VirtualBox to run other operating systems inside Mint. It doesn't truly give the guest OS access to the actual hardware, it presents it with virtualized hardware.

Hardware acceleration is when a task, usually graphics/video processing, is handed off to a separate piece of hardware (a chip) that specializes in that task, rather than being done in the main processor.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

jglen490
Level 4
Level 4
Posts: 255
Joined: Sat Jul 15, 2017 9:57 pm

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by jglen490 » Mon Apr 16, 2018 7:56 pm

Looks like a great candidate for the Mate desktop. That's what I use on my Toshiba laptop. Mate has a decent look to it and runs very well on my light weight machine.
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

User avatar
MrEen
Level 7
Level 7
Posts: 1964
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by MrEen » Mon Apr 16, 2018 8:40 pm

I think this might be your problem: Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa) FAILED: intel

I don't know why the intel driver failed, but have you checked what's available in the Driver Manager?

Also haven't seen Unity desktop here before. Which DE did you install originally?

User avatar
administrollaattori
Level 15
Level 15
Posts: 5646
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by administrollaattori » Tue Apr 17, 2018 3:40 am

MrEen wrote:
Mon Apr 16, 2018 8:40 pm
I think this might be your problem: Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa) FAILED: intel

I don't know why the intel driver failed, but have you checked what's available in the Driver Manager?

Also haven't seen Unity desktop here before. Which DE did you install originally?
+1
Even Canonical has realized that Unity is unworkable desktop (never ready).
vesa driver could be better driver than fbdev

How to use vesa graphic driver -> viewtopic.php?f=42&t=266554&p=1449844#p1449844

TheVillagerGamer28
Level 1
Level 1
Posts: 5
Joined: Sat Apr 14, 2018 9:09 pm
Location: Earth

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by TheVillagerGamer28 » Tue Apr 17, 2018 7:45 pm

administrollaattori wrote:
Tue Apr 17, 2018 3:40 am
MrEen wrote:
Mon Apr 16, 2018 8:40 pm
I think this might be your problem: Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa) FAILED: intel

I don't know why the intel driver failed, but have you checked what's available in the Driver Manager?

Also haven't seen Unity desktop here before. Which DE did you install originally?
+1
Even Canonical has realized that Unity is unworkable desktop (never ready).
vesa driver could be better driver than fbdev

How to use vesa graphic driver -> viewtopic.php?f=42&t=266554&p=1449844#p1449844
When I tried to do "sudo Xorg :1 -configure," it failed and gave me this:

Code: Select all

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-97-generic x86_64 Ubuntu
Current Operating System: Linux tvg28-Inspiron-11-3162 4.13.0-38-generic #43~16.04.1-Ubuntu SMP Wed Mar 14 17:48:43 UTC 2018 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.13.0-38-generic root=UUID=1db2450f-04c9-4ff0-8261-d4f346a91b51 ro quiet splash nomodeset vt.handoff=7
Build Date: 13 October 2017  01:57:05PM
xorg-server 2:1.18.4-0ubuntu0.7 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.33.6
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Apr 17 19:41:15 2018
List of video drivers:
	amdgpu
	ati
	intel
	nouveau
	qxl
	radeon
	vesa
	fbdev
	modesetting
	vmware
(++) Using config file: "/home/tvg28/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.
  Configuration failed.
(EE) Server terminated with error (2). Closing log file.
hai i is a signitur

TheVillagerGamer28
Level 1
Level 1
Posts: 5
Joined: Sat Apr 14, 2018 9:09 pm
Location: Earth

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by TheVillagerGamer28 » Tue Apr 17, 2018 7:55 pm

MrEen wrote:
Mon Apr 16, 2018 8:40 pm
I think this might be your problem: Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa) FAILED: intel

I don't know why the intel driver failed, but have you checked what's available in the Driver Manager?

Also haven't seen Unity desktop here before. Which DE did you install originally?
Firstly, in the Driver Manager, it only has "intel-microcode."
Secondly, Cinnamon was originally installed. I also got MATE before I posted because I found that it was lightweight, and Unity, because I wanted to see what it was. I deleted Unity though, for some reason.
hai i is a signitur

User avatar
MrEen
Level 7
Level 7
Posts: 1964
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by MrEen » Tue Apr 17, 2018 8:03 pm

Well, it looks like you might've created a frankendesktop as your inxi report still shows Unity.

Personally, as you've just installed days ago, I'd suggest starting from scratch reformating/reinstalling the partition(s) so there shouldn't be any weird conflicts.

User avatar
administrollaattori
Level 15
Level 15
Posts: 5646
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by administrollaattori » Wed Apr 18, 2018 2:26 am

TheVillagerGamer28 wrote:
Tue Apr 17, 2018 7:45 pm
When I tried to do "sudo Xorg :1 -configure," it failed and gave me this:

Code: Select all

(++) Using config file: "/home/tvg28/xorg.conf.new"
It made xorg.conf.new file. :wink:

Code: Select all

sudo cp xorg.conf.new /etc/X11/xorg.conf
gksu xdg-open /etc/X11/xorg.conf

jto52
Level 1
Level 1
Posts: 1
Joined: Wed Apr 18, 2018 10:49 pm

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by jto52 » Wed Apr 18, 2018 11:02 pm

Please forgive a noob for chiming in but I have a similar problem and I am wondering if this is another instance of a problem that seems to be common on Linux forums. Is the video driver trying to run the monitor at a resolution it isn't capable of using? My cheap Dell laptop computer runs Linux Mint Cinnamon OK from the USB stick but fails with the black screen when booting from the hd install. However, it will start using the compatibility mode and then runs in low res. At this point I am trying to figure out my next step, which will likely be the nomodeset path the original poster used and then see if I can figure out the next step.

Is the original poster facing this same issue?

User avatar
administrollaattori
Level 15
Level 15
Posts: 5646
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode

Post by administrollaattori » Thu Apr 19, 2018 1:57 am

jto52 wrote:
Wed Apr 18, 2018 11:02 pm
My cheap Dell laptop computer runs Linux Mint Cinnamon OK from the USB stick but fails with the black screen when booting from the hd install.
No one but you knows that computer, so you should make a new topic. :wink:

harimurtie
Level 1
Level 1
Posts: 1
Joined: Thu Aug 16, 2018 11:58 am

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode [Solved]

Post by harimurtie » Thu Aug 16, 2018 12:14 pm

i have same inspiron 11-3162. 2GB and hdd variant (change into ssd now). I need to tweak the bios. UEFI, disable load legacy option rom. i manage to install linux, eos,ubuntu,lubuntu,and use mint mate sylvia now, iso is 64bit and made live usb with yumi uefi. i have same problem as you,when i use legacy live usb. need to put nomodeset and without graphic acceleration, and after i install it legacy mode, i managed to get into desktop, only in recovery mode. so i think the problem with this laptop is its bios. if you choose legacy one, the load legacy option rom is enabled and greyed.
Linux Mint Mate 18.3 sylvia 64-bit | Manjaro 17.1.11
i3wm
Dell Inspiron 11-3162
2GB RAM
128GB SSD

Neoespartano
Level 1
Level 1
Posts: 1
Joined: Mon Aug 20, 2018 7:27 pm

Re: Linux Mint Has To Be Booted With nomodeset + Software Rendering Mode [Solved]

Post by Neoespartano » Mon Aug 20, 2018 8:16 pm

System: Host: Neoespartano Kernel: 4.15.0-32-generic x86_64 bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
CPU: 8 core AMD FX-8320 Eight-Core (-MCP-) arch: Bulldozer rev.0 cache: 16384 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 56004
clock speeds: max: 3500 MHz 1: 1424 MHz 2: 1438 MHz 3: 1398 MHz 4: 1398 MHz 5: 1434 MHz
6: 1404 MHz 7: 1400 MHz 8: 1402 MHz
MOBO: MSI 990XA-GD55
Graphics: Card-1: NVIDIA GP107 [GeForce GTX 1050 Ti] bus-ID: 01:00.0
Card-2: Advanced Micro Devices [AMD/ATI] RV730 PRO [Radeon HD 4650] bus-ID: 02:00.0
Display Server: x11 (X.Org 1.19.6 )
drivers: nvidia,ati,radeon (unloaded: modesetting,fbdev,vesa,nouveau)
Resolution: 1680x1050@59.95hz, 1280x1024@75.02hz
OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2
version: 4.6.0 NVIDIA 390.48 Direct Render: Yes

Just Changed a Gtx-460 for a gtx-1050 TI and decided to format everything... The systems has crashing random mostly when was on firefox o chromiun but noticed some graphic gliches than pointed me to this post, so I logged out and enter in software render mode and magic.. System was stable at last... But was not happy.. I wanna pull out juice to my gtx-1050ti so at last noticed the real problem (at least in my case).
Mint 19 don't installed 2 packages: cinnamon-core and cinnamon-desktop-data

Now I have hardware acceleration and a stable system..... And happy at last (was a hard week).

Locked

Return to “Installation & Boot”