blank screen after suspend

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
mr.bjerre
Level 1
Level 1
Posts: 22
Joined: Sun Mar 01, 2009 2:05 pm

blank screen after suspend

Postby mr.bjerre » Mon Jun 01, 2009 9:17 am

Hi,


I've mint 6 and vista installed on my laptop. I recently upgraded to vista and after that I didn't get the chance to boot into mint anymore. I reinstalled grub and it works just fine now. BUT now I can't get my laptop running after it a suspend, which worked before my vista upgrade.

Any ideas?

exploder
Level 16
Level 16
Posts: 6967
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA
Contact:

Re: blank screen after suspend

Postby exploder » Mon Jun 01, 2009 3:22 pm

Mint 7 is supposed to have better support for that type of thing. You might give the new release a try.

mr.bjerre
Level 1
Level 1
Posts: 22
Joined: Sun Mar 01, 2009 2:05 pm

Re: blank screen after suspend

Postby mr.bjerre » Mon Jun 01, 2009 4:03 pm

but won't I lose all my data then? I mean, is it possible just to upgrade from mint6 to mint7 without losing data and settings?

exploder
Level 16
Level 16
Posts: 6967
Joined: Tue Feb 13, 2007 10:50 am
Location: HartfordCity, Indiana USA
Contact:

Re: blank screen after suspend

Postby exploder » Mon Jun 01, 2009 4:06 pm

I wouldn't try the upgrade, too risky....

Edit: Might be something useful here.

https://bugs.launchpad.net/ubuntu/+sour ... bug/293242

mr.bjerre
Level 1
Level 1
Posts: 22
Joined: Sun Mar 01, 2009 2:05 pm

Re: blank screen after suspend

Postby mr.bjerre » Tue Jun 02, 2009 5:28 pm

Okay I've tried to look up the possibilities to fix it by editing different settings, but the further I dig into the problem, the more comlicated it gets. It gets TOO complicated. Is there any suggestions to fix it by a walktrough guide? Debugging suspend is just too complicated.

Like is it possible to upgrade mint 6 to mint 7 without data loss?

Marc
Level 1
Level 1
Posts: 1
Joined: Fri Jun 05, 2009 5:28 am

Re: blank screen after suspend

Postby Marc » Fri Jun 05, 2009 5:34 am

+1

I have a laptop with a completely new fresh install : suspend fails, hibernate works perfectly.

This laptop worked fine with Ubuntu 9.04.

Mint 7 Gloria

Marc

mr.bjerre
Level 1
Level 1
Posts: 22
Joined: Sun Mar 01, 2009 2:05 pm

Re: blank screen after suspend

Postby mr.bjerre » Sun Jun 21, 2009 6:51 am

So there is not really anyone with an answer? It kinda sucks to miss out the suspend option. I used to use it a lot when it worked

mr.bjerre
Level 1
Level 1
Posts: 22
Joined: Sun Mar 01, 2009 2:05 pm

Re: blank screen after suspend

Postby mr.bjerre » Sun Jul 12, 2009 4:57 pm

come on please. There must be someone who is able to help?

owend
Level 2
Level 2
Posts: 68
Joined: Fri Jul 10, 2009 11:51 am

Re: blank screen after suspend

Postby owend » Sun Jul 19, 2009 4:46 pm

I had Ubuntu 9.04 where suspend didn't work: I've gone to Mint 7 and it worked out-of-the-box.

The fix I used to get suspend to work in 9.04 was: Open a terminal and enter sudo gedit; in Gedit open /usr/lib/hal/scripts/linux/hal-system-power-suspend-linux; find the line QUIRKS=" "; change it to QUIRKS="--quirk-s3-bios --quirk-s3-mode --quirk-dpms-suspend –-quirk-dpms-on --quirk-vbestate-restore --quirk-vbemode-restore --quirk-vga-mode3 –-quirk-vbe-post –-quirk-reset-brightness" – not all may be necessary, but I enabled them all anyway and nothing adverse happened - you can try one at a time, if you wanted to! Save and exit. Set Power Management for lid closed = suspend.

Try it: I don't use hibernate, but the same routine in /usr/lib/hal/scripts/linux/hal-system-power-hibernate-linux should work


Return to “Installation & Boot”

Who is online

Users browsing this forum: No registered users and 6 guests