Having to enter bios to boot linuxmint

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
b_hayles
Level 2
Level 2
Posts: 56
Joined: Sat May 19, 2018 6:17 pm

Having to enter bios to boot linuxmint

Post by b_hayles » Tue May 22, 2018 11:40 pm

I'm TOTAL newbie and not technically oriented. Be gentle.

I did a dual boot installation of mint 5 days ago and so far just sorta good. One problem is booting to linuxmint. I have two HDDs with 1TB each. I have 250GB of D: drive partitioned for linuxmint. I managed to get linuxmint installed and was under the impression that on computer start up part way thru the boot process I would get a screen that gave me a choice between linux and Windows. That screen never happens. If I allow boot to finish I am in Windows normally. Not even the partition for linux in D: drive shows up in Windows Explorer.

If I interrupt the bios with "Del" I can not change where I boot from permanently. I CAN choose the drive that has linuxmint on it and the computer will boot into linuxmint just fine...but will revert back to its old ways on the next start up.

Ideas?

deepakdeshp
Level 11
Level 11
Posts: 3858
Joined: Sun Aug 09, 2015 10:00 am

Re: Having to enter bios to boot linuxmint

Post by deepakdeshp » Wed May 23, 2018 12:37 am

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

fabien85
Level 6
Level 6
Posts: 1391
Joined: Tue Mar 11, 2014 4:30 pm

Re: Having to enter bios to boot linuxmint

Post by fabien85 » Wed May 23, 2018 4:29 am

Hi,
the linux bootloader is not first in the boot order and/or Linux and Windows are not installed in the same boot mode (Legacy vs UEFI).

Let's first check your boot mode for both systems.
- for windows, use these instructions to find out
- for linux, copy and paste the following in a terminal (Menu > Administration > Terminal), press enter and report the result :

Code: Select all

[ -d /sys/firmware/efi ] && echo "Currently in EFI mode" || echo "Currently in Legacy mode"

b_hayles
Level 2
Level 2
Posts: 56
Joined: Sat May 19, 2018 6:17 pm

Re: Having to enter bios to boot linuxmint

Post by b_hayles » Wed May 23, 2018 9:48 am

"Currently in Legacy mode".

fabien85
Level 6
Level 6
Posts: 1391
Joined: Tue Mar 11, 2014 4:30 pm

Re: Having to enter bios to boot linuxmint

Post by fabien85 » Thu May 24, 2018 10:10 am

And for windows ?

b_hayles
Level 2
Level 2
Posts: 56
Joined: Sat May 19, 2018 6:17 pm

Re: Having to enter bios to boot linuxmint

Post by b_hayles » Thu May 24, 2018 12:05 pm

The info in that link has 2 ways to check...One is for Win 8 and newer...mine is Win 7, and the other is inaccurate for systems with multiple hard drives...I have 2. Is there another way to check, perhaps from looking at something in bios?

b_hayles
Level 2
Level 2
Posts: 56
Joined: Sat May 19, 2018 6:17 pm

Re: Having to enter bios to boot linuxmint

Post by b_hayles » Thu May 24, 2018 1:24 pm

Alternatively, I went into system info. Under system summary I expected either uefi or legacy. Instead, I see two lines referring to bios. One says BIOS version/date........American Megatrends Inc 1604, 10/16/2012 and the nest line says SMBIOS Version...2.7.

Does this help?

fabien85
Level 6
Level 6
Posts: 1391
Joined: Tue Mar 11, 2014 4:30 pm

Re: Having to enter bios to boot linuxmint

Post by fabien85 » Fri May 25, 2018 3:59 am

So probably your windows is also in Legacy mode.
Let's check : boot Linux, open a terminal and post here the output of

Code: Select all

sudo parted --list
If I understand correctly, you installed Linux on the second hard drive. So you must put that hard drive first in the boot order, and make the BIOS remember that setting.
If you cannot do that, then the solution would be to install grub in the MBR of the first drive. Note this will overwrite what windows put in the MBR. You will still be able to boot windows, because grub can boot it.

b_hayles
Level 2
Level 2
Posts: 56
Joined: Sat May 19, 2018 6:17 pm

Re: Having to enter bios to boot linuxmint

Post by b_hayles » Fri May 25, 2018 6:54 am

Code: Select all

b_hayles@b ~ $ sudo parted --list
[sudo] password for b_hayles: 
Model: ATA ST1000DL002-9TT1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start  End     Size    Type     File system  Flags
 1      106MB  1000GB  1000GB  primary  ntfs         boot


Model: ATA ST1000DL002-9TT1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 1      1049kB  843GB   843GB  primary  ntfs
 2      843GB   1000GB  157GB  primary  ext2         boot


b_hayles@b ~ $ 
Yes, Linux is on a 250GB partition of D:. Windows is on C:. Question...Even if I figure out how to boot from D: (where Linux is), won't that just reverse my problem, making the computer boot Linux instead of Windows (which it does now) and making me have to interrupt bootup to choose C: during boot to access Windows? From what I had read before installing Linux, with a dual OS system on start-up I would be presented with a choice of which OS to boot during the start-up process. Is this incorrect?

fabien85
Level 6
Level 6
Posts: 1391
Joined: Tue Mar 11, 2014 4:30 pm

Re: Having to enter bios to boot linuxmint

Post by fabien85 » Fri May 25, 2018 10:49 am

Ok, from your parted output, both Linux and Windows are installed in Legacy mode, so all goes well on that front.
From what I had read before installing Linux, with a dual OS system on start-up I would be presented with a choice of which OS to boot during the start-up process.
Yes this is correct, you should be presented with a grub menu which should give you the choice of booting either Linux or windows.
If that is not the case, boot linux and run the following command :

Code: Select all

sudo update-grub
Now try again, you should have see the grub menu with an option to boot windows.

User avatar
Spearmint2
Level 15
Level 15
Posts: 5734
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Having to enter bios to boot linuxmint

Post by Spearmint2 » Fri May 25, 2018 11:37 am

Yes, Linux is on a 250GB partition of D:. Windows is on C:. Question...Even if I figure out how to boot from D: (where Linux is), won't that just reverse my problem, making the computer boot Linux instead of Windows (which it does now) and making me have to interrupt bootup to choose C: during boot to access Windows? From what I had read before installing Linux, with a dual OS system on start-up I would be presented with a choice of which OS to boot during the start-up process. Is this incorrect?
In linux your C drive is sda, and the D drive is sdb. It's possible if you switch boot drive in BIOS that Mint will boot up first, but you can during the boot process check to see if there's an option to boot Windows also. If not, then boot into Mint, open terminal, and run this command.

Code: Select all

sudo update-grub
and next time the choice between Mint or Windows should be there.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

b_hayles
Level 2
Level 2
Posts: 56
Joined: Sat May 19, 2018 6:17 pm

Re: Having to enter bios to boot linuxmint

Post by b_hayles » Fri May 25, 2018 11:54 am

This is the result. Is this correct?

Code: Select all

b_hayles@b ~ $ sudo update-grub
[sudo] password for b_hayles: 
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.10.0-38-generic
Found initrd image: /boot/initrd.img-4.10.0-38-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
done
b_hayles@b ~ $ 
EDITED: After the above I rebooted...the computer still boots straight to Windows with no options. I still have to interrupt the boot with the Del key, and still have to go into "Boot setup", but there I do have the choices between Win and Linux. Another difference...at this point the two options were Linux/Mint and Advanced Linux/Mint. I now have four choices: Linux Mint, Advanced Linux Mint, Windows, and mem test.

Next?

User avatar
Spearmint2
Level 15
Level 15
Posts: 5734
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Having to enter bios to boot linuxmint

Post by Spearmint2 » Fri May 25, 2018 1:36 pm

Two ways to do it. Manually, or with Grub Customizer. Also Startup Manager.

https://www.itsupportguides.com/knowled ... ot-loader/

The manual way is to open the grub.cfg file and move the entire menuentry for the linux boot section above the menuentry section for Windows and save.

For instance, on mine I'd take this section from the word menuentry to the } and move it just above the menuentry windows section.

Code: Select all

menuentry 'Linux Mint 17.3 MATE 32-bit, 3.13.0-149-generic (/dev/sdb2)' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	gfxmode $linux_gfx_mode
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2  14f23016-8f05-4bdc-be9f-a2110bfea2da
	else
	  search --no-floppy --fs-uuid --set=root 14f23016-8f05-4bdc-be9f-a2110bfea2da
	fi
	linux	/boot/vmlinuz-3.13.0-149-generic root=UUID=14f23016-8f05-4bdc-be9f-a2110bfea2da ro resume=/dev/sdb2  usbhid.quirks=0x04D9:0xA0CD:0x20000408 quiet splash $vt_handoff
	initrd	/boot/initrd.img-3.13.0-149-generic
}
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

fabien85
Level 6
Level 6
Posts: 1391
Joined: Tue Mar 11, 2014 4:30 pm

Re: Having to enter bios to boot linuxmint

Post by fabien85 » Fri May 25, 2018 5:10 pm

b_hayles wrote:
Fri May 25, 2018 11:54 am
This is the result. Is this correct?

Code: Select all

b_hayles@b ~ $ sudo update-grub
[sudo] password for b_hayles: 
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.10.0-38-generic
Found initrd image: /boot/initrd.img-4.10.0-38-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
done
b_hayles@b ~ $ 
EDITED: After the above I rebooted...the computer still boots straight to Windows with no options. I still have to interrupt the boot with the Del key, and still have to go into "Boot setup", but there I do have the choices between Win and Linux. Another difference...at this point the two options were Linux/Mint and Advanced Linux/Mint. I now have four choices: Linux Mint, Advanced Linux Mint, Windows, and mem test.

Next?
Looks very good. Check you can indeed boot windows from that grub menu. If you can, perfect.
Now you need to put Mint's hard drive first in the boot order. That's the step which depends on your BIOS, so I cant tell you how to do it.

Post Reply

Return to “Installation & Boot”