Solved: Trouble installing 18.3 on R7-1700

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
bfromcolo
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2013 12:50 am

Solved: Trouble installing 18.3 on R7-1700

Post by bfromcolo » Wed May 30, 2018 12:11 pm

It loads the 18.3 installation menu, but once I try to launch a live session I am getting:

end - Kernel panic - not syncing: VFS: Unable to mount root fs on unknown block (2,0)

Happens with compatibility mode install as well.

Also fails with Ubuntu 18.04

System is a Gigabyte B350 Gaming 3, R7-1700, 16G memory, 128G SSD, RX-480.

I updated the BIOS to F21 to see if that would help, no go.

Runs Windows 10 fine, and it was previously running an older version of Mint (17 maybe) with updated kernel for the R7. I remember having issues with that install as well, needed nomodeset in the boot parameters, and then some issue later in the install about a missing DVD but I am not getting that far this time.

Any ideas on how to proceed?
Last edited by bfromcolo on Wed Jun 20, 2018 8:57 am, edited 1 time in total.

deepakdeshp
Level 11
Level 11
Posts: 3853
Joined: Sun Aug 09, 2015 10:00 am

Re: Trouble installing 18.3 on R7-1700

Post by deepakdeshp » Wed May 30, 2018 2:33 pm

Please try changing the USB port, and USB media.

Also check the correct download of iso image https://linuxmint.com/verify.php
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

bfromcolo
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2013 12:50 am

Re: Trouble installing 18.3 on R7-1700

Post by bfromcolo » Wed May 30, 2018 3:29 pm

I tried multiple ports on the front and back, as well as changing to a different USB stick and doing again. Same kernel panic message.

The checksum of the download matches.

Thanks for responding.

bfromcolo
Level 1
Level 1
Posts: 8
Joined: Fri Aug 30, 2013 12:50 am

Re: Solved: Trouble installing 18.3 on R7-1700

Post by bfromcolo » Wed Jun 20, 2018 9:00 am

Turns out there is a known issue with iommu in dual GPU configurations with the AB350 chipset on some boards and Linux, I was able to install with a single GPU just fine. Disabling iommu allows both GPUs to be installed.

Post Reply

Return to “Installation & Boot”