Black screen after installing Radeon r9 280x crimson driver on LM18

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Jackfi5h
Level 1
Level 1
Posts: 13
Joined: Mon Jun 18, 2018 1:03 pm

Black screen after installing Radeon r9 280x crimson driver on LM18

Post by Jackfi5h » Mon Jun 18, 2018 1:21 pm

Sorry in advance if this isn't the correct location for this question.

Specs:
Processor: i5 2500 3.3ghz
GPU: AMD Radeon r9 280x
Version of LM: 18 cinnamon (previously working fine until I installed the driver)
Driver I attempted to install: AMD Ubuntu 15.04 x64 version of the radeon-crimson-15.12-15.302-151217a-297685e for the R9 280x
Driver Link: https://support.amd.com/en-us/download/ ... nux+x86_64

The issue:

The issue I'm having is that I am greeted with a black screen with a blinking white underscore (_) in the top left of my screen after attempting to install a Ubuntu 15.04 version of the 280x AMD graphics card driver, I have looked up this issue on the forums and have attempted variousb solutions all to which haven't solved my issue and I am left clueless as to how I can restore my LM back to it's original state.

Solutions I've tried:
  • Using shell on recovery mode and inserting

    Code: Select all

    mount -o remount,re /
    followed by

    Code: Select all

    aticonfig --uninstall
    which gives me the error "one or more files have been altered since installation.

    Booting into recovery mode, booting from the recovery section onto LM and uninstalling the driver in the programs section

    Using a command similar to sudo apt-get purge fglrx* can't remember it exactly but it was similar to that
EDIT:
I have since tried to fix the issue by booting using recovery and attempting to use the update manager to install new packages. When i attempt to update all the packages it prompts me saying they need updating, it returns with this error

Code: Select all

Please insert the disc labelled:
Linux Mint 18.3 _Sylvia_ - Release amd64 20171124
in drive /cdrom/
Then when attempting to access the driver manager, it prompts me saying that the cache needs to be updated which then causes it to start downloading a bunch of repository packages then returns an error saying Failed to download repository information, Check your internet connection followed by this error

Code: Select all

W:The repository 'cdrom://Linux Mint 18.3 _Sylvia_ - Release amd64 20171124 xenial Release' does not have a Release file., W:Data from such a repository can't be authenticated and is therefore potentially dangerous to use., W:See apt-secure(8) manpage for repository creation and user configuration details., W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_contrib_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_contrib_binary-amd64_Packages.xz failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_main_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_main_binary-amd64_Packages.xz failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_non-free_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_non-free_binary-amd64_Packages.xz failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_contrib_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_contrib_binary-amd64_Packages.bz2 failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_main_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_main_binary-amd64_Packages.bz2 failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_non-free_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_non-free_binary-amd64_Packages.bz2 failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_contrib_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_contrib_binary-amd64_Packages.lzma failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_main_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_main_binary-amd64_Packages.lzma failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_non-free_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_non-free_binary-amd64_Packages.lzma failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_contrib_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_contrib_binary-amd64_Packages.gz failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_main_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_main_binary-amd64_Packages.gz failed - pkgAcqIndex::StageDownloadDone (17: File exists), W:Symlinking final file /var/lib/apt/lists/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_non-free_binary-amd64_Packages back to /var/lib/apt/lists/partial/Linux%%20Mint%%2018.3%%20%%5fSylvia%%5f%%20-%%20Release%%20amd64%%2020171124_dists_xenial_non-free_binary-amd64_Packages.gz failed - pkgAcqIndex::StageDownloadDone (17: File exists), E:Failed to fetch cdrom://Linux Mint 18.3 _Sylvia_ - Release amd64 20171124/dists/xenial/contrib/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs, E:Some index files failed to download. They have been ignored, or old ones used instead.
which at a glance seems to be caused by the absence of 'amd64 20171124' and it not having a 'release file'

Any help would be greatly appreciated as I am unable to solve this issue with the current threads on this forum.

User avatar
trytip
Level 7
Level 7
Posts: 1626
Joined: Tue Jul 05, 2016 1:20 pm

Re: Black screen after installing Radeon r9 280x crimson driver on LM18

Post by trytip » Mon Jun 18, 2018 2:28 pm

do you have any drivers to install in Driver Manager?
Image

Jackfi5h
Level 1
Level 1
Posts: 13
Joined: Mon Jun 18, 2018 1:03 pm

Re: Black screen after installing Radeon r9 280x crimson driver on LM18

Post by Jackfi5h » Mon Jun 18, 2018 4:58 pm

I have intel microcode for my cpu but it wont let me install, its just stuck at 'applying changes'

User avatar
trytip
Level 7
Level 7
Posts: 1626
Joined: Tue Jul 05, 2016 1:20 pm

Re: Black screen after installing Radeon r9 280x crimson driver on LM18

Post by trytip » Mon Jun 18, 2018 5:41 pm

when you uninstall something that you built, you need to open terminal in the same directory where the source is so it can read what files to remove. you may have a broken system now because of corrupt driver install. do you have a timeshift snapshot and restore your system to earlier working state?
errors will be in var/log/Xorg.0.log at the bottom you can post it here if it's not long enough.
Image

Jackfi5h
Level 1
Level 1
Posts: 13
Joined: Mon Jun 18, 2018 1:03 pm

Re: Black screen after installing Radeon r9 280x crimson driver on LM18

Post by Jackfi5h » Tue Jun 19, 2018 8:38 am

Nah I sadly don't so I just reinstalled it now, now I just want to know how can i install an AMD driver without corrupting LM

User avatar
thx-1138
Level 5
Level 5
Posts: 935
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Black screen after installing Radeon r9 280x crimson driver on LM18

Post by thx-1138 » Tue Jun 19, 2018 8:49 am

Version of LM: 18 cinnamon (previously working fine until I installed the driver)
Driver I attempted to install: AMD Ubuntu 15.04 x64 version
...doesn't that speak for itself? LM 18 ≠ Ubuntu 15.04

...have you checked this thread here? viewtopic.php?t=248059

Nomechuter
Level 1
Level 1
Posts: 1
Joined: Tue Jun 19, 2018 10:21 am
Location: Portland
Contact:

Re: Black screen after installing Radeon r9 280x crimson driver on LM18

Post by Nomechuter » Tue Jun 19, 2018 10:25 am

thx-1138 wrote:
Tue Jun 19, 2018 8:49 am
Version of LM: 18 cinnamon (previously working fine until I installed the driver)
Driver I attempted to install: AMD Ubuntu 15.04 x64 version
...doesn't that speak for itself? LM 18 ≠ Ubuntu 15.04

...have you checked this thread here? viewtopic.php?t=248059
Just wanted to say thanks for the link.

Had a similar issue to OP with a different Radeon and it lead me to the right place to fix it.

Post Reply

Return to “Installation & Boot”