Mint doesn't function after Win10 update, dual boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Taildragger
Level 1
Level 1
Posts: 41
Joined: Thu May 16, 2013 9:23 pm

Mint doesn't function after Win10 update, dual boot

Post by Taildragger » Mon Jun 18, 2018 4:02 pm

<t>I have Linux Mint 17.2 (or 17.3) dual booted with Win10. After the Win10 update about Nov 17, Mint is basically useless. I think it's a boot problem, but not sure. Will post pictures. I think the computer is not uefi, but not sure (at work).</t>

Check out how the icons have a red circle and slash on them

http://imgur.com/opTnmxv
http://imgur.com/Xcui3V4
http://imgur.com/IAnuGiJ
http://imgur.com/C8ZmrWI

Thanks in advance

User avatar
michael louwe
Level 8
Level 8
Posts: 2318
Joined: Sun Sep 11, 2016 11:18 pm

Re: Mint doesn't function after Win10 update, dual boot

Post by michael louwe » Mon Jun 18, 2018 4:36 pm

Taildragger wrote:.
.
You likely need to reinstall LM 17.x.

To prevent this from happening again, install LM on an external USB hard-drive or as a virtual machine. If you have a desktop, install LM on a separate internal hard-drive.

Yes, it's non-UEFI or Legacy BIOS = simpler to install LM.

Taildragger
Level 1
Level 1
Posts: 41
Joined: Thu May 16, 2013 9:23 pm

Re: Mint doesn't function after Win10 update, dual boot

Post by Taildragger » Mon Jun 18, 2018 10:13 pm

Thanks so much. Will give it a shot. By the way, i had a problem trying to move up from 17.3 to 18 when 18 first came out, so just stayed with 17.x. Any suggestions for more recent versions? I think I saw that 19 is out. Thanks again.

User avatar
Sgthawker
Level 3
Level 3
Posts: 186
Joined: Sun Apr 27, 2014 2:23 am

Re: Mint doesn't function after Win10 update, dual boot

Post by Sgthawker » Mon Jun 18, 2018 10:51 pm

LM 19 is in Beta likely til the end of the month. If you can wait that long it has some nice new features you can partake of, with the caveat that it might have glitches to be worked out. If you want something more stable, then install LM 18.3.
LM 18.3 Cinnamon/MATE/KDE/Xfce UEFI on Sabertooth Z170 S, i6700K, 2 x Echelon GTX950, Samsung 950 Pro M.2 NVMe
LM 18.3 Cinnamon/MATE/KDE/Xfce UEFI on Asus ROG STRIX laptop, i7700 HQ, GTX 1060, Samsung 960 Pro M.2 NVMe

User avatar
Pierre
Level 16
Level 16
Posts: 6922
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Mint doesn't function after Win10 update, dual boot

Post by Pierre » Mon Jun 18, 2018 11:37 pm

if you still have a copy of LM18x then do try to install that over the existing SDa5 & 7 partitions,
to see if that will now work okay.

in the early part of July you will be able to get a copy of LM19 Final,
and you could also try that out as well.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Taildragger
Level 1
Level 1
Posts: 41
Joined: Thu May 16, 2013 9:23 pm

Re: [Solved] Mint doesn't function after Win10 update, dual boot

Post by Taildragger » Wed Jun 20, 2018 6:19 pm

I solved the problem after finding the term "broken packages". I had to use the terminal commands to get into "update manager", and used the command
sudo apt-get update. When it was running, it found something wrong, and said something was wrong and to run ".....dpkg...... -a". (sorry, I didn't write it down).

Pierre, I do have a copy of 18.3 64 bit. I know it's a new topic, but I got to the install screen that looks like gparted, and am not sure how to install over the existing SDa5 & 7 partitions. Could you please point me in the right direction? I've always done fresh installs, but never over existing partitions. Thanks

Taildragger
Level 1
Level 1
Posts: 41
Joined: Thu May 16, 2013 9:23 pm

Re: Mint doesn't function after Win10 update, dual boot

Post by Taildragger » Wed Jun 20, 2018 6:42 pm

Here's a picture of where I am

http://imgur.com/cBygMRU

Also, is the "device for boot loader installation" correct. I've always had problems with that in the past. It worked before, and I am assuming that it will again, but just wanted to check. Thanks

Taildragger
Level 1
Level 1
Posts: 41
Joined: Thu May 16, 2013 9:23 pm

Re: Mint doesn't function after Win10 update, dual boot

Post by Taildragger » Wed Jun 20, 2018 7:48 pm

NEVER MIND, I remembered that the larger partition was for the system, > change > ext4 > /
and the smaller was for ext4 > /home, tried it, WORKS GREAT, Thanks again

User avatar
Pierre
Level 16
Level 16
Posts: 6922
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Mint doesn't function after Win10 update, dual boot

Post by Pierre » Wed Jun 20, 2018 11:41 pm

that should be the other way around:
- smaller partition for / root
- larger partition for /home
or you will run the risk of running out of disk space.
:arrow:
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Taildragger
Level 1
Level 1
Posts: 41
Joined: Thu May 16, 2013 9:23 pm

Re: Mint doesn't function after Win10 update, dual boot

Post by Taildragger » Thu Jun 21, 2018 7:05 pm

Changed it, thanks so much

Post Reply

Return to “Installation & Boot”