[SOLVED] Linux Mint 19 very slow boot times of ten minutes or so.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
User avatar
trytip
Level 10
Level 10
Posts: 3350
Joined: Tue Jul 05, 2016 1:20 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by trytip » Wed Jul 04, 2018 5:04 pm

you need to show inxi -F at least
Image

gort2000
Level 1
Level 1
Posts: 10
Joined: Wed Jul 04, 2018 4:49 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by gort2000 » Wed Jul 04, 2018 5:37 pm

First post so hope it's ok with you guys.

I have just installed LM19 Cinnamon on two laptops both about 10 years old and experienced the very slow boot times. In order to speed up the boot times I installed xenial kernel 4.4 by adding "deb http://security.ubuntu.com/ubuntu xenial-security main" to the Software Sources Additional Repository. Unfortunately the laptops kept trying to boot to kernel 4.15 because I had enabled the auto update option mainly because the laptop was for a non techie person. I therefore installed Grub Customizer to make 4.4 the default kernel. This brought the boot times back to normal on the old laptops.

One other issue with this setup. When one of the laptops was booting into the 4.4 kernel the wifi would not automatically switch on. This was sorted by adding custom command "nmcli r wifi on" to the Startup Applications.

JeremyB
Level 20
Level 20
Posts: 10586
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by JeremyB » Wed Jul 04, 2018 5:42 pm

gort2000 wrote:
Wed Jul 04, 2018 5:37 pm
First post so hope it's ok with you guys.

I have just installed LM19 Cinnamon on two laptops both about 10 years old and experienced the very slow boot times. In order to speed up the boot times I installed xenial kernel 4.4 by adding "deb http://security.ubuntu.com/ubuntu xenial-security main" to the Software Sources Additional Repository. Unfortunately the laptops kept trying to boot to kernel 4.15 because I had enabled the auto update option mainly because the laptop was for a non techie person. I therefore installed Grub Customizer to make 4.4 the default kernel. This brought the boot times back to normal on the old laptops.

One other issue with this setup. When one of the laptops was booting into the 4.4 kernel the wifi would not automatically switch on. This was sorted by adding custom command "nmcli r wifi on" to the Startup Applications.
I can't be sure this is a good idea for many users. For now I would advise to install without updates and then update everything but the kernel. I haven't experienced any slow boot times because of 4.15.0-24 on my Ubuntu or Linux Mint laptops but there are far too many posts to ignore here or on ubuntuforums.org

bhoth
Level 1
Level 1
Posts: 16
Joined: Fri Nov 04, 2011 9:17 am

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by bhoth » Wed Jul 04, 2018 10:41 pm

I have a pretty current desktop with an 8 core AMD processor and 16 GB of RAM, SSD drives and experienced this exact issue. Back revved to 4.15.0-23 and the boot is back to normal.

Stay away from 4.15.0-24!

User avatar
catweazel
Level 18
Level 18
Posts: 8881
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by catweazel » Wed Jul 04, 2018 10:48 pm

raywoods wrote:
Tue Jul 03, 2018 2:53 pm

Code: Select all

System: Host: woods-laptop Kernel: 4.15.0-24-generic x86_64
That's the cause. See this: https://git.kernel.org/pub/scm/linux/ke ... a661f01144

Avoid that kernel and wait for a later update.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

externa1
Level 1
Level 1
Posts: 47
Joined: Fri Mar 23, 2018 11:45 am

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by externa1 » Thu Jul 05, 2018 3:44 am

JeremyB wrote:
Wed Jul 04, 2018 5:03 pm
Do you have an older kernel that works? If so boot into it and use update manager/view/linux kernels to uninstall 4.15.0-24
then download and install
http://kernel.ubuntu.com/~jsalisbury/lp ... g4_all.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb

This has a proposed fix to the issue, if the default download location is home/Downloads try in terminal

Code: Select all

cd Downloads
sudo dpkg -i linux*.deb
Then try the proposed fix by rebooting
That worked for me thx

rg
Christian

User avatar
catweazel
Level 18
Level 18
Posts: 8881
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by catweazel » Thu Jul 05, 2018 3:50 am

JeremyB wrote:
Wed Jul 04, 2018 5:03 pm
Do you have an older kernel that works? If so boot into it and use update manager/view/linux kernels to uninstall 4.15.0-24
then download and install
http://kernel.ubuntu.com/~jsalisbury/lp ... g4_all.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb

This has a proposed fix to the issue, if the default download location is home/Downloads try in terminal

Code: Select all

cd Downloads
sudo dpkg -i linux*.deb
Then try the proposed fix by rebooting
Nice catch. You must've trawled the mail archive looking for that.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

JeremyB
Level 20
Level 20
Posts: 10586
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by JeremyB » Thu Jul 05, 2018 5:06 am

Another workaround https://ubuntuforums.org/showthread.php ... st13781140

Code: Select all

sudo apt install haveged
sudo systemctl enable haveged

raywoods
Level 2
Level 2
Posts: 80
Joined: Mon Aug 10, 2009 5:48 pm
Location: Barkingside, ILFORD, Essex. UK
Contact:

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by raywoods » Thu Jul 05, 2018 7:44 am

Okay. On mains power and did the instructions from JeremyB
1. Switch to earlier Kernel on reboot
2. Removed Linux Kernel 4.15.0-24
3. Saved to /Downloads to following deb files
http://kernel.ubuntu.com/~jsalisbury/lp ... g4_all.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb
http://kernel.ubuntu.com/~jsalisbury/lp ... _amd64.deb
Then ran
cd Downloads
sudo dpkg -i linux*.deb
from the Terminal
Rebooted and still no joy (over six minutes from POST to GUI on my stop watch)

The Blame list reads as follows:

32.362s lightdm.service
32.362s plymouth-quit-wait.service
6.471s networkd-dispatcher.service
6.044s udisks2.service
5.960s ModemManager.service
4.975s ubuntu-system-adjustments.service
4.796s dev-sda5.device
4.771s NetworkManager.service
3.117s accounts-daemon.service
2.813s wpa_supplicant.service
2.399s apport.service
2.392s grub-common.service
2.332s polkit.service
1.907s kerneloops.service
1.894s gpu-manager.service
1.888s pppd-dns.service
1.765s hddtemp.service
1.765s thermald.service
1.761s alsa-restore.service
1.744s lm-sensors.service
1.714s networking.service
1.696s rsyslog.service
1.524s ntp.service
1.435s systemd-journal-flush.service
1.429s apparmor.service
1.373s systemd-logind.service
1.062s keyboard-setup.service
1.009s dns-clean.service
964ms systemd-modules-load.service
820ms speech-dispatcher.service
816ms avahi-daemon.service
775ms systemd-fsck@dev-disk-by\x2duuid-ee6d4608\x2d2469\x2d4cf3\x2dbf
682ms systemd-udevd.service
601ms systemd-sysctl.service
579ms systemd-tmpfiles-setup-dev.service
510ms systemd-tmpfiles-setup.service
488ms sys-kernel-debug.mount
487ms dev-hugepages.mount
457ms systemd-remount-fs.service
436ms dev-mqueue.mount
418ms kmod-static-nodes.service
398ms systemd-journald.service
386ms systemd-resolved.service
373ms plymouth-start.service
340ms dev-disk-by\x2duuid-0d64a12f\x2d3012\x2d4477\x2d8140\x2d4d775a5
326ms home.mount
308ms upower.service
289ms systemd-rfkill.service
258ms plymouth-read-write.service
244ms console-setup.service
242ms openvpn.service
220ms systemd-random-seed.service
170ms systemd-user-sessions.service
159ms user@1000.service
155ms systemd-update-utmp.service
132ms systemd-udev-trigger.service
91ms setvtrgb.service
83ms ufw.service
63ms flatpak-system-helper.service
40ms systemd-backlight@leds:dell::kbd_backlight.service
36ms systemd-backlight@backlight:intel_backlight.service
24ms rtkit-daemon.service
12ms ureadahead-stop.service
8ms sys-kernel-config.mount
8ms systemd-update-utmp-runlevel.service
6ms sys-fs-fuse-connections.mount

At least Linux Mint 19 is working well on my Desktop (and being more economical with the system memory too! (About 500MB on start up). I just wish this lump in my lap would speed up its boot, it is fine once into the GUI.

gm10
Level 17
Level 17
Posts: 7067
Joined: Thu Jun 21, 2018 5:11 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by gm10 » Thu Jul 05, 2018 9:14 am

raywoods wrote:
Thu Jul 05, 2018 7:44 am
Rebooted and still no joy (over six minutes from POST to GUI on my stop watch)
Considering the startup time measured by systemd-analyze was 45-52s until graphical.target and about 2 minutes for the full thing, you see to be losing a lot of time before the kernel even starts. So the problem would be with GRUB2. Maybe someone can walk you through it, I don't have time right now (you could try a sudo grub-install; sudo update-grub first).
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

raywoods
Level 2
Level 2
Posts: 80
Joined: Mon Aug 10, 2009 5:48 pm
Location: Barkingside, ILFORD, Essex. UK
Contact:

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by raywoods » Thu Jul 05, 2018 11:25 am

I've had a look at my grub file...
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

The output from "update-grub"

ray@woods-laptop:~$ sudo update-grub
[sudo] password for ray:
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-4.15.0-24-generic
Found initrd image: /boot/initrd.img-4.15.0-24-generic
Found linux image: /boot/vmlinuz-4.15.0-20-generic
Found initrd image: /boot/initrd.img-4.15.0-20-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
done

Other observations

On closing down I did notice some error messages flashing up and I took a photograph of it. (This was from another Kernel though. The original with Mint 19.)
The messages have a common theme...
[drm:drm_atomic_helper_wait_for_depedencies [drm_kms_helper]] *ERROR*......
May this have something to do with this problem?
Ray

gm10
Level 17
Level 17
Posts: 7067
Joined: Thu Jun 21, 2018 5:11 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by gm10 » Thu Jul 05, 2018 11:44 am

Ok, here's one problem:

You said you
raywoods wrote:
Thu Jul 05, 2018 7:44 am
2. Removed Linux Kernel 4.15.0-24
but apparently you did not or you installed it again:
raywoods wrote:
Thu Jul 05, 2018 11:25 am
Found linux image: /boot/vmlinuz-4.15.0-24-generic
Found initrd image: /boot/initrd.img-4.15.0-24-generic
So you'll need to boot into the -20 kernel again (press shift during boot, select advanced, and boot the 4.15-0.20 kernel), then once booted open Update Manager > View > Linux kernels > click on 4.15.0-24 and then on remove. Run Update Manager and install all updates including the -23 kernel.

Your error message means there's a problem with your graphics driver, but let's handle the kernel first. Post us the output from inxi -Fxz once you're done (put code tags around it for readabiltiy please, 5th button above the text input pane). The output of blkid and of cat /etc/fstab would also be helpful.
Last edited by gm10 on Thu Jul 05, 2018 2:10 pm, edited 1 time in total.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

ssspace
Level 2
Level 2
Posts: 63
Joined: Mon Dec 18, 2017 8:44 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by ssspace » Thu Jul 05, 2018 12:02 pm

I saw another user complaining about very slow boots, 10 minutes:

https://forum.snapcraft.io/t/snapd-serv ... -0-24/6205

Some bug with the kernel.

agkozak
Level 1
Level 1
Posts: 1
Joined: Wed Jul 04, 2018 10:35 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by agkozak » Thu Jul 05, 2018 12:15 pm

When I was running Linux Mint 18.3, I saw boot times of only a handful of seconds. Version 19 brought me up to 40-120 seconds. I've been working on getting back to my boot time for Linux Mint 18.3 and I've finally succeeded (I'm on my third fresh installation in one day).

Something is very wrong in Linux Mint 19 with how the encrypted home folder and encrypted swap file are set up. I found that the problem went away if I didn't opt to encrypt my home folder during installation. I then used the instructions in https://www.howtogeek.com/116032/how-to ... ng-ubuntu/ to encrypt my $HOME folder and set up an encrypted swap file. The swap file was a little harder to get working than the guide suggested.

Finally, I blacklisted the linux-4.15.0-24.26 kernel.

raywoods
Level 2
Level 2
Posts: 80
Joined: Mon Aug 10, 2009 5:48 pm
Location: Barkingside, ILFORD, Essex. UK
Contact:

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by raywoods » Thu Jul 05, 2018 7:03 pm

Hi gm10
Sorry about the confusion over that kernel, looking at those deb packages, they installed the 24 kernel again! Anyway, now running on 4.15.0-23 and 4.15.0-24 is blacklisted.
Output for inxi -Fxz is...

Code: Select all

System:    Host: woods-laptop Kernel: 4.15.0-23-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: portable System: Dell product: Latitude D630 serial: N/A
           Mobo: Dell model: 0KU184 serial: N/A
           BIOS: Dell v: A13 date: 07/28/2008
Battery    BAT0: charge: 86.6 Wh 137.8% condition: 62.8/86.6 Wh (73%)
           model: Sony DELL 00 status: Full
CPU:       Dual core Intel Core2 Duo T8100 (-MCP-) 
           arch: Penryn rev.6 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 8376
           clock speeds: max: 2101 MHz 1: 1399 MHz 2: 1184 MHz
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.04hz
           OpenGL: renderer: Mesa DRI Intel 965GM
           version: 2.1 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-23-generic
Network:   Card-1: Broadcom Limited NetXtreme BCM5755M Gigabit Ethernet PCIE
           driver: tg3 v: 3.137 bus-ID: 09:00.0
           IF: enp9s0 state: down mac: <filter>
           Card-2: Intel PRO/Wireless 3945ABG [Golan] Network Connection
           driver: iwl3945 v: in-tree:s bus-ID: 0c:00.0
           IF: wlp12s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (29.4% used)
           ID-1: /dev/sda model: WDC_WD5000LPVX size: 500.1GB
Partition: ID-1: / size: 28G used: 16G (61%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 427G used: 118G (30%) fs: ext4 dev: /dev/sda6
           ID-3: swap-1 size: 4.00GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 148 Uptime: 11 min Memory: 944.8/1984.2MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
and blkid...

Code: Select all

/dev/sda1: UUID="0d64a12f-3012-4477-8140-4d775a568023" TYPE="swap" PARTUUID="0005a832-01"
/dev/sda5: UUID="cfa016ca-619a-45aa-b182-3570cf6e54f9" TYPE="ext4" PARTUUID="0005a832-05"
/dev/sda6: UUID="ee6d4608-2469-4cf3-bf37-491d4c922a5d" TYPE="ext4" PARTUUID="0005a832-06"
plus cat /etc/fstab

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=cfa016ca-619a-45aa-b182-3570cf6e54f9 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=ee6d4608-2469-4cf3-bf37-491d4c922a5d /home           ext4    defaults        0       2
# swap was on /dev/sda1 during installation
UUID=0d64a12f-3012-4477-8140-4d775a568023 none            swap    sw              0       0
I must admit, this is all getting my brain going and thanks for your help.
Ray

KBD47
Level 7
Level 7
Posts: 1743
Joined: Fri Jul 29, 2011 12:03 am

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by KBD47 » Thu Jul 05, 2018 7:34 pm

Just saw this:
Ubuntu 18.04 Linux Kernel Update Causes Boot Delays Of 4 Minutes Or More On Some Systems
https://www.linuxuprising.com/2018/07/u ... auses.html
Odd issues like this is why I disabled level 4 updates for Mint 19 on mission critical machines, and also why it is a bad idea to update anything right before you know you will need your machine in working order.

User avatar
Gofer83
Level 1
Level 1
Posts: 33
Joined: Thu Feb 03, 2011 10:57 am

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by Gofer83 » Fri Jul 06, 2018 3:29 am

I had kernel 4.15.0-24 already installed in Mint 18.3 and the boot time was few seconds (normal).
After the upgrade to Mint 19, boot time is taking about 1 minute.

Code: Select all

systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @43.619s
└─multi-user.target @43.619s
  └─smbd.service @43.511s +106ms
    └─nmbd.service @8.416s +35.093s
      └─network-online.target @8.409s
        └─NetworkManager-wait-online.service @2.011s +6.397s
          └─NetworkManager.service @1.569s +440ms
            └─dbus.service @1.420s
              └─basic.target @1.341s
                └─sockets.target @1.341s
                  └─cups.socket @1.341s
                    └─sysinit.target @1.321s
                      └─systemd-timesyncd.service @576ms +744ms
                        └─systemd-tmpfiles-setup.service @435ms +133ms
                          └─systemd-journal-flush.service @200ms +234ms
                            └─systemd-journald.service @149ms +49ms
                              └─systemd-journald-audit.socket @148ms
                                └─system.slice @140ms
                                  └─-.slice @139ms
The same kernel on ElementaryOS makes no problems with boot time:

Code: Select all

systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @7.320s
└─multi-user.target @7.320s
  └─getty.target @7.319s
    └─getty@tty1.service @7.319s
      └─rc-local.service @7.304s +2ms
        └─network-online.target @7.303s
          └─NetworkManager-wait-online.service @1.480s +5.822s
            └─NetworkManager.service @1.246s +230ms
              └─dbus.service @866ms
                └─basic.target @864ms
                  └─sockets.target @864ms
                    └─snapd.socket @836ms +9ms
                      └─sysinit.target @817ms
                        └─apparmor.service @387ms +426ms
                          └─local-fs.target @387ms
                            └─run-user-1000-gvfs.mount @14.909s
                              └─run-user-1000.mount @14.722s
                                └─local-fs-pre.target @370ms
                                  └─systemd-remount-fs.service @349ms +19ms
                                    └─systemd-journald.socket @149ms
                                      └─-.slice @140ms
I'm not sure if those slow boot times are really only kernel's fault.

SOLUTION FOUND:
Removing the "quiet" parameter from "/etc/default/grub" configuration brought back 10s boot time :mrgreen:
SYSTEM: Linux Mint 19 Tara 64bit | KERNEL: 4.15.0-24-generic | GUI: Cinnamon 3.8.7 | CPU: i7-6700K @ 4.3Ghz | GPU: Asus GTX1080 Strix (nVidia Driver 396.18) | RAM: 32GB Gskill Ripjaws 4 (3000Mhz) | SSD:Kingston HyperX 120GB

fireman999
Level 1
Level 1
Posts: 1
Joined: Sat Jul 07, 2018 3:19 am

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by fireman999 » Sat Jul 07, 2018 3:50 am

Hi All,

I have a Lenovo ThinkPad T430 with an i5 processor, 8 Gb Ram and a SSD. It's an old machine, but half decent. A few days ago I installed Mint XFCE and the boot up times were terrible. Yesterday I installed Mint Cinnamon, and the start up time was several minutes. I almost gave up on Mint. This morning I reinstalled Mint Cinnamon without the kernel updates and it's working fine! The kernel that I am using is the 4.15.0-20
I hope the issues with the latest kernel (4.15.0-24) is sorted out soon.

octathlon
Level 2
Level 2
Posts: 61
Joined: Sat Jun 28, 2014 3:14 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by octathlon » Sat Jul 07, 2018 2:38 pm

Here is another older laptop with the same problem if anyone wants to compare the specs. I installed Mint 19 (XFCE) and got the slow boot times on the initial install. Then I did updates including kernel to -24 and still have the same problem.

Code: Select all

gjd@Pang:~$ systemd-analyze
Startup finished in 1min 9.769s (kernel) + 54.695s (userspace) = 2min 4.465s
graphical.target reached after 50.639s in userspace

gjd@Pang:~$ systemd-analyze blame
         35.123s apt-daily.service
         31.837s lightdm.service
         31.833s plymouth-quit-wait.service
         10.685s dev-sda5.device
          8.257s systemd-journal-flush.service
          7.225s keyboard-setup.service
          7.088s lvm2-monitor.service
          5.987s systemd-udevd.service
          5.709s systemd-sysctl.service
          4.094s udisks2.service
          3.969s networkd-dispatcher.service
          3.847s ubuntu-system-adjustments.service
          3.315s ModemManager.service
          3.274s NetworkManager.service
          3.258s accounts-daemon.service
          2.051s thermald.service
          1.809s systemd-modules-load.service
          1.652s polkit.service
          1.239s systemd-tmpfiles-setup-dev.service
          1.220s grub-common.service
           946ms dns-clean.service
           915ms mnt-d0d31936\x2d301f\x2d4abc\x2da390\x2db18bd87f4f13.mount
           877ms apt-daily-upgrade.service
           750ms systemd-tmpfiles-setup.service
           701ms systemd-update-utmp.service
           679ms apparmor.service
           573ms systemd-journald.service
           444ms speech-dispatcher.service
           421ms kerneloops.service
           415ms gpu-manager.service
           414ms lm-sensors.service
           382ms plymouth-read-write.service
           361ms systemd-remount-fs.service
           353ms systemd-logind.service
           349ms console-setup.service
           348ms ufw.service
           335ms systemd-random-seed.service
           310ms networking.service
           301ms kmod-static-nodes.service
           244ms ntp.service
           222ms avahi-daemon.service
           218ms packagekit.service
           216ms plymouth-start.service
           213ms upower.service
           195ms rsyslog.service
           194ms dev-mqueue.mount
           192ms dev-hugepages.mount
           191ms sys-kernel-debug.mount
           177ms systemd-udev-trigger.service
           162ms systemd-hostnamed.service
           158ms systemd-rfkill.service
           155ms wpa_supplicant.service
           128ms apport.service
           127ms user@1000.service
           102ms blk-availability.service
            95ms systemd-resolved.service
            87ms hddtemp.service
            56ms systemd-user-sessions.service
            56ms openvpn.service
            46ms setvtrgb.service
            44ms alsa-restore.service
            39ms systemd-tmpfiles-clean.service
            38ms dev-disk-by\x2duuid-a90b0a4e\x2d2a80\x2d4458\x2d9d10\x2db6ccb2b
            20ms rtkit-daemon.service
            15ms pppd-dns.service
            15ms ureadahead-stop.service
            11ms systemd-backlight@backlight:acpi_video0.service
             9ms systemd-update-utmp-runlevel.service
             4ms sys-kernel-config.mount
             4ms sys-fs-fuse-connections.mount
lines 48-70/70 (END)
inxi output:

Code: Select all

gjd@Pang:~$ inxi -Fxz
System:    Host: Pang Kernel: 4.15.0-24-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: - product: N/A serial: N/A
           Mobo: COMPAL model: IFL91 v: REFERENCE serial: N/A
           BIOS: COMPAL v: 1.10 date: 06/26/2007
Battery    BAT1: charge: 53.3 Wh 100.0% condition: 53.3/53.3 Wh (100%)
           model: LIDP PA3465U status: N/A
CPU:       Dual core Intel Core2 Duo T7300 (-MCP-) 
           arch: Conroe rev.10 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 7979
           clock speeds: max: 2001 MHz 1: 1196 MHz 2: 1184 MHz
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1280x800@59.91hz
           OpenGL: renderer: Mesa DRI Intel 965GM
           version: 2.1 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network:   Card-1: Broadcom Limited NetLink BCM5906M Fast Ethernet PCIE
           driver: tg3 v: 3.137 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
           Card-2: Intel PRO/Wireless 3945ABG [Golan] Network Connection
           driver: iwl3945 v: in-tree:s bus-ID: 0c:00.0
           IF: wlp12s0 state: up mac: <filter>
Drives:    HDD Total Size: 160.0GB (6.0% used)
           ID-1: /dev/sda model: Hitachi_HTS54161 size: 160.0GB
Partition: ID-1: / size: 25G used: 6.1G (27%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 3.22GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 50.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 157 Uptime: 1:03 Memory: 372.4/1984.7MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
Mint 19 Cinnamon 64bit on Dell Inspiron N7110 Dual core Intel Core i5-2450M
Mint 19 XFCE 64bit on System76 Pangolin Intel Core 2 duo
Full-time Linux user since 2007, Mint since 2014

Scoubidou
Level 1
Level 1
Posts: 4
Joined: Sat May 05, 2012 12:40 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by Scoubidou » Wed Jul 11, 2018 4:51 pm

Hello,

I upgraded to Linux Mint MATE 19 on my Intel NUC with a i915 chipset. It works well with kernel 4.15.0.20, 22, 23 but takes about 5 minutes to start with 24. I simply blacklisted kernel 4.15.0.24.
Very annoying for people who use default settings in LM MATE 19, with automatic kernel updates !!! They all use Timeshift for the first time.

Post Reply

Return to “Installation & Boot”