[SOLVED] Linux Mint 19 very slow boot times of ten minutes or so.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
octathlon
Level 2
Level 2
Posts: 60
Joined: Sat Jun 28, 2014 3:14 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by octathlon » Wed Jul 11, 2018 5:44 pm

I removed kernel 4.15.0-24 and went to 4.15.0-20 but my boot time is still just as slow (over 3 minutes to get to the login screen). I tried the "cleanup" commands posted elsewhere but just got an error that whatever grep was looking for didn't exist.

I think there is something else going on instead of just a bug in -24, especially since others have reported using that kernel without problems in Mint 18.3 and only having problems after installing Mint 19.

I'm also getting a few CRTC:41:pipe B "flip_done timed out" errors at shutdown, whatever that means.

I'll hold off moving to 19 on my main laptop until I understand the problem and that it's been fixed or how to work around it.
Mint 17 Cinnamon 64bit on Dell Inspiron N7110 Dual core Intel Core i5-2450M
Mint 19 XFCE 64bit on System76 Pangolin Intel Core 2 duo
Full-time Linux user since 2007, Mint since 2014

User avatar
trytip
Level 8
Level 8
Posts: 2134
Joined: Tue Jul 05, 2016 1:20 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by trytip » Wed Jul 11, 2018 8:14 pm

seems most peoples have issue with these two: for systemd-analyze blame
31.837s lightdm.service
31.833s plymouth-quit-wait.service
mine is this but i have an old system with 5 spinning drives
3.582s lightdm.service
3.575s plymouth-quit-wait.service
in my endeavour to get better fonts and replacing a lot of libfreetype2 packages (which freeze the computer while it regenerates something) upon reboot the same two .service took a long time. i was tempted to hit the power button which i did, thinking the boot process froze. when i powered it on again it took a long time for boot but when finally desktop came in, the cinnamon menu was gone replaced by the mint mate menu and all my desktop settings were not mine.

replaced the libfreetype2 packages with the mint repo versions which again froze the computer. rebooted, WAITED, then waited some more. desktop shows up and everything was back to normal. waited a few more minutes for everything to load and rebooted again.

the last time everything went according to what i feel is my normal boot time.

ps: i did use ukuu to load kernel 4.17.4 not sure if that's of any relevance
Last edited by trytip on Fri Jul 13, 2018 10:03 am, edited 1 time in total.
Image

aljoriz
Level 4
Level 4
Posts: 273
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by aljoriz » Thu Jul 12, 2018 9:21 pm

remove kernel -24
If only the second time: The kernel -24 has been causing trouble for many people. I don't know what the problem is exactly because personally I had no trouble with that kernel version. What you do is you press shift at boot time right at the start (after BIOS screen ends, before the Mint logo comes up) to get into the GRUB boot menu, select the advances option there and go with the -20 kernel version. Then, once booted, and assuming you booted fine, go to Software Manager > View > Linux Kernels and remove the -24 kernel.
viewtopic.php?t=272278

raywoods
Level 2
Level 2
Posts: 80
Joined: Mon Aug 10, 2009 5:48 pm
Location: Barkingside, ILFORD, Essex. UK
Contact:

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by raywoods » Mon Jul 16, 2018 2:30 pm

I must admit, I've surrendered and gone back to LinuxMint 18.2 which still has the 30 second delay before Plymouth starts but at least gets its binary bits into gear after that. The six + minutes of Mint 19 is far too long and for me, playing with kernels makes no difference.

I think there is a problem with GRUB2 and SystemD. (Probably looking for hardware not existing on my laptop.) Hopefully someone stumbles across the cause and does something about it.

Keep banging your heads against the brick walls guys!

octathlon
Level 2
Level 2
Posts: 60
Joined: Sat Jun 28, 2014 3:14 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by octathlon » Mon Jul 16, 2018 2:49 pm

raywoods wrote:
Mon Jul 16, 2018 2:30 pm
I must admit, I've surrendered and gone back to LinuxMint 18.2 which still has the 30 second delay before Plymouth starts but at least gets its binary bits into gear after that. The six + minutes of Mint 19 is far too long and for me, playing with kernels makes no difference.
Fortunately, I only installed 19 on my secondary laptop which is pretty much just a backup and test machine. I'm still using 17 on my main laptop, so I'll need to upgrade to something fairly soon. It will probably be 18.3 instead of 19. I don't know if the issue would occur on that one, but I don't want to mess around with a beautifully working system to find out (if anyone else has a Dell Inspiron laptop, please let me know how it went for you!).

As you said, playing with different kernels has made no difference for many of us, but I have no idea what to do other than wait and see if someone figures it out and fixes it.
Mint 17 Cinnamon 64bit on Dell Inspiron N7110 Dual core Intel Core i5-2450M
Mint 19 XFCE 64bit on System76 Pangolin Intel Core 2 duo
Full-time Linux user since 2007, Mint since 2014

gort2000
Level 1
Level 1
Posts: 10
Joined: Wed Jul 04, 2018 4:49 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by gort2000 » Mon Jul 16, 2018 3:21 pm

The problem with very long boot times with LM19 on my old HP laptop was initially resolved by downgrading the kernel to below 4.8. I had noticed boot times creeping up from kernel 4.8 and above. However kernels 4.15 boot times were too long to be of practical use. All versions of kernel 4.15 were giving long boot times, not just 4.15.0-24
I discovered the problem lay with the Intel Mobile GM965/GL960 Integrated Graphics Controller.
In short, normal boot times were restored to kernel 4.15 (but not 4.15.0-24) by adding "video=SVIDEO-1:d" to /etc/default/grub line GRUB_CMDLINE_LINUX_DEFAULT
It now reads;

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"

Then update grub; sudo update-grub
Last edited by gort2000 on Mon Jul 16, 2018 4:15 pm, edited 2 times in total.

octathlon
Level 2
Level 2
Posts: 60
Joined: Sat Jun 28, 2014 3:14 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by octathlon » Mon Jul 16, 2018 3:48 pm

gort2000 wrote:
Mon Jul 16, 2018 3:21 pm
In short, normal boot times were restored to kernel 4.15 (but not 4.15.0-24) by adding "video=SVIDEO-1:d" to /etc/default/grub line GRUB_CMDLINE_LINE_LINUX_DEFAULT
It now reads;

GRUB_CMDLINE_LINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"
BLESS YOU, kind gort2000! :D :D :D

I have the Intel Mobile GM965 graphics and that fixed the problem for me! Time to login screen is now 45 seconds instead of 3.5 minutes, and time after logging in is just a few seconds instead of over another minute.

One note: The line I modified is GRUB_CMDLINE_LINUX_DEFAULT rather than GRUB_CMDLINE_LINE_LINUX_DEFAULT

Thanks again for that info!
Mint 17 Cinnamon 64bit on Dell Inspiron N7110 Dual core Intel Core i5-2450M
Mint 19 XFCE 64bit on System76 Pangolin Intel Core 2 duo
Full-time Linux user since 2007, Mint since 2014

gort2000
Level 1
Level 1
Posts: 10
Joined: Wed Jul 04, 2018 4:49 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by gort2000 » Mon Jul 16, 2018 3:52 pm

Thanks octathlon. I've altered the text error.

raywoods
Level 2
Level 2
Posts: 80
Joined: Mon Aug 10, 2009 5:48 pm
Location: Barkingside, ILFORD, Essex. UK
Contact:

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by raywoods » Fri Jul 20, 2018 6:19 pm

:( Warning the 4.15 series Linux Kernel doesn't like old Hardware :(
I've been happily using Mint 18.3, since dumping Mint 19 because of the horrendous boot time, then Update Manager installed the 4.15 kernel today. This slowed my boot time right down, just like Mint 19. I've now removed and blacklisted this kernel and gone back to 4.13 series which was originally installed, so all is well and happy in the garden again. Needless to say, there is something rotten in the heart of 4.15 kernel series and I hope it is sorted before the 4.17 series comes with Linux Mint. The 4.15 series certainly doesn't like my Dell Latitude D630.

gort2000
Level 1
Level 1
Posts: 10
Joined: Wed Jul 04, 2018 4:49 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by gort2000 » Sat Jul 21, 2018 6:45 am

The 4.15 series certainly doesn't like my Dell Latitude D630.
Have you tried the "video=SVIDEO-1:d" fix?

raywoods
Level 2
Level 2
Posts: 80
Joined: Mon Aug 10, 2009 5:48 pm
Location: Barkingside, ILFORD, Essex. UK
Contact:

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by raywoods » Sat Jul 21, 2018 7:48 am

Wow! Modified my GRUB with the line starting GRUB_CMDLINE_LINUX_DEFAULT= now reads GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d" That even improved the start up time of my current kernel (4.13) with the Hard Disk working continuously unlike the fits and starts before. I will now try updateing to the latest kernel for Mint 18.3 (4.15.0-29). Thank you. :D
Last edited by raywoods on Thu Jul 26, 2018 1:31 pm, edited 1 time in total.

raywoods
Level 2
Level 2
Posts: 80
Joined: Mon Aug 10, 2009 5:48 pm
Location: Barkingside, ILFORD, Essex. UK
Contact:

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by raywoods » Sat Jul 21, 2018 8:02 am

Now running on the 4.15.0-29 and have a cold metal to GUI (including manual Log in) of <1 minute on my ten year old lump. I will wait for the upgrade to Mint 19 via the Update Manager. Thanks everyone for your help. :) :) :)


In case you too are suffering a similar problem, here is what I did.
1. I entered into the /ect folder as the Administrator (Right click on the folder and select "Open as Administrator").
2. From the new window, open the /default folder.
3. Find the file "grub", right click on it and open in the Text Editor.
3a. It is a good idea to do a quick "Save As" and generate a grub.bak file (just in case)!
4. Find the line starting "GRUB_CMDLINE_LINE_LINUX_DEFAULT=" and place a "#" at the start of the line to make it a 'comment' and stop it from being read by the system.
5. Insert a line underneath and type/copy GRUB_CMDLINE_LINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"
6. Save the file as grub (not grub.bak!)
7. You now need to open the Terminal Command Line and enter "sudo update-grub". This sets up the system to enact your new grub file on rebooting.
8. Close all your open windows and check all those backup files again, you never know!

Once this has been done, reboot your computer and hopefully your box will be hot and kicking! If not, you will still have your grub.bak file to fall back upon.

Don't forget, always ensure you have up to date backups on hand so, if the worse occurs, you can reinstall from scratch.

My thanks to gort2000 who put me onto the track of this solution.
Last edited by raywoods on Thu Jul 26, 2018 1:41 pm, edited 1 time in total.

ajaya123
Level 1
Level 1
Posts: 23
Joined: Sun Jul 22, 2018 10:03 am

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by ajaya123 » Mon Jul 23, 2018 3:41 am

hey ,
a)
1.-->
you should re-install
2.--> use some of swap
3.-->the main thing is set your bios to boot from hard disk first ,
b)
if the problem exist even that try the same bootable stick at other pc , hense you should update your hardware the main cause is 32 bit processor is always slower then 64 bit

ajaya123
Level 1
Level 1
Posts: 23
Joined: Sun Jul 22, 2018 10:03 am

Re: [SOLVED] Linux Mint 19 very slow boot times of ten minutes or so.

Post by ajaya123 » Mon Jul 23, 2018 12:19 pm

please mention which of instruction help you to solve

raywoods
Level 2
Level 2
Posts: 80
Joined: Mon Aug 10, 2009 5:48 pm
Location: Barkingside, ILFORD, Essex. UK
Contact:

Re: [SOLVED] Linux Mint 19 very slow boot times of ten minutes or so.

Post by raywoods » Thu Jul 26, 2018 1:45 pm

As you can now see, I've updated my entries accordingly. (I found the solution on a different thread and did the necessary there and forgot I should do likewise here.) Anyway, the job is done and I'm cooking on Gas!

ajaya123
Level 1
Level 1
Posts: 23
Joined: Sun Jul 22, 2018 10:03 am

Re: [SOLVED] Linux Mint 19 very slow boot times of ten minutes or so.

Post by ajaya123 » Sat Jul 28, 2018 11:51 pm

raywoods wrote:
Thu Jul 26, 2018 1:45 pm
As you can now see, I've updated my entries accordingly. (I found the solution on a different thread and did the necessary there and forgot I should do likewise here.) Anyway, the job is done and I'm cooking on Gas!
:shock: :? :!:

Blas
Level 1
Level 1
Posts: 1
Joined: Mon Jul 30, 2018 11:56 am

Re: [SOLVED] Linux Mint 19 very slow boot times of ten minutes or so.

Post by Blas » Mon Jul 30, 2018 12:59 pm

I am using an old Dell Inspiron 1525. My boot times were easily three minutes or more. The GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d" edit described above has appeared to fix the issue. Thanks.

ajaya123
Level 1
Level 1
Posts: 23
Joined: Sun Jul 22, 2018 10:03 am

Re: [SOLVED] Linux Mint 19 very slow boot times of ten minutes or so.

Post by ajaya123 » Tue Jul 31, 2018 1:01 pm

tanksssssssss :D

mendoza61
Level 1
Level 1
Posts: 1
Joined: Sat Aug 04, 2018 5:19 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by mendoza61 » Sat Aug 04, 2018 5:25 pm

gm10 wrote:
Tue Jul 03, 2018 3:36 pm
raywoods wrote:
Tue Jul 03, 2018 2:53 pm
I've seen quite a few other threads about relating to very slow boot times so there appears to be a common theme arising. (Perhaps all Developers should get their old rigs out from the attic and try them there before releasing their little gems out into the big wide World?)
The world can't stop turning just because people are still using ancient hardware. There are more lightweight distributions out there than Mint. You might fare better with Lubuntu or an even more light-weight non-Ubuntu distribution.

But back to your Mint for now. Try this first: apt remove colord lvm2.

Reboot and post systemd-analyze and systemd-analyze blame outputs again.
Sorry, but I wouldn't blame old hardware for this. I have 2 notebooks - 1st one about 10 years old Acer Aspire 5740G. And second msi 7RD. First one boots with mint in ... I haven't notice how long. Few seconds. Second - more than 30 sec, sometimes longer. Fighting now to reach less than 30 sec.

gm10
Level 10
Level 10
Posts: 3340
Joined: Thu Jun 21, 2018 5:11 pm

Re: Linux Mint 19 very slow boot times of ten minutes or so.

Post by gm10 » Sat Aug 04, 2018 5:50 pm

mendoza61 wrote:
Sat Aug 04, 2018 5:25 pm
Sorry, but I wouldn't blame old hardware for this. I have 2 notebooks - 1st one about 10 years old Acer Aspire 5740G. And second msi 7RD. First one boots with mint in ... I haven't notice how long. Few seconds. Second - more than 30 sec, sometimes longer. Fighting now to reach less than 30 sec.
I wasn't blaming old hardware, I was responding to his statement that developers should test on old hardware.

Post Reply

Return to “Installation & Boot”