[SOLVED] Login fails after 18.3 to 19 upgrade

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Doctor Funkenstein
Level 2
Level 2
Posts: 68
Joined: Wed Jan 31, 2018 4:16 pm

[SOLVED] Login fails after 18.3 to 19 upgrade

Post by Doctor Funkenstein » Fri Jul 06, 2018 10:54 am

Hi all,

My machine froze on the screensaver at some point during the update process last night. I don't know if "froze" is the proper term since it was still displaying the current time, but it wouldn't accept input from the touchpad/keyboard, so I restarted it.

It boots to the login screen, but when I try to login it says
"unable to launch "cinnamon-session-cinnamon" X session ---
"cinnamon-session-cinnamon" not found; falling back to default session."

I click okay and it goes back to the login screen. Hitting control-alt-f1 and attempting to login through that method also fails. It says my username/password are incorrect. I have never typed in my username in this fashion so maybe there is a trick to it.

Any way I can open up a terminal or something and un-**** this situation? I did a backup with Timeshift beforehand but that doesn't do me much good if I can't login!

Thanks in advance.
Last edited by Doctor Funkenstein on Fri Jul 06, 2018 5:49 pm, edited 1 time in total.

Doctor Funkenstein
Level 2
Level 2
Posts: 68
Joined: Wed Jan 31, 2018 4:16 pm

Re: Login fails after 18.3 to 19 upgrade

Post by Doctor Funkenstein » Fri Jul 06, 2018 1:46 pm

Update: I figured out how to do a Timeshift restore from the root terminal thingy (it's an option when you press shift during bootup).

The CPU overheated while restoring and now I can't perform a Timeshift either (throws an error about sda1 already being mounted or something).

Please help, for I'm beginning to suspect I am totally screwed.

User avatar
mrmajik45
Level 5
Level 5
Posts: 597
Joined: Tue Aug 29, 2017 9:51 pm
Location: USA, indiana
Contact:

Re: Login fails after 18.3 to 19 upgrade

Post by mrmajik45 » Fri Jul 06, 2018 1:52 pm

Step 1. Get better cooling.
Step 2. Try AGANE
ReactOS Donator ~ $5.00 | Linux Mint Donator ~ $1.00 in BTC

User avatar
Flemur
Level 17
Level 17
Posts: 7069
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Login fails after 18.3 to 19 upgrade

Post by Flemur » Fri Jul 06, 2018 2:00 pm

Doctor Funkenstein wrote:
Fri Jul 06, 2018 1:46 pm
Update: I figured out how to do a Timeshift restore from the root terminal thingy (it's an option when you press shift during bootup).
The CPU overheated while restoring and now I can't perform a Timeshift either (throws an error about sda1 already being mounted or something).
"timeshift" doesn't seem to be very robust, I see a lot of problems and confusions about it in this forum. One very good reason not to use it, which I don't.
Please help, for I'm beginning to suspect I am totally screwed.
Did you replace MDM with "lightdm" as part of the upgrade? You're supposed to.

If NOT, and if timeshift hasn't fried your system, go to the root terminal thingy and type this:

Code: Select all

sudo apt-get install lightdm
If should ask you about removing MDM.

If you already have lightdm, go to the root terminal thingy and try

Code: Select all

sudo dpkg-reconfigure lightdm 
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

Doctor Funkenstein
Level 2
Level 2
Posts: 68
Joined: Wed Jan 31, 2018 4:16 pm

Re: Login fails after 18.3 to 19 upgrade

Post by Doctor Funkenstein » Fri Jul 06, 2018 4:04 pm

mrmajik45 wrote:
Fri Jul 06, 2018 1:52 pm
Step 1. Get better cooling.
Step 2. Try AGANE
What exactly do you mean by AGANE? I'm not finding anything with Google.

Yes, lightdm was installed. Thanks though!

User avatar
mrmajik45
Level 5
Level 5
Posts: 597
Joined: Tue Aug 29, 2017 9:51 pm
Location: USA, indiana
Contact:

Re: Login fails after 18.3 to 19 upgrade

Post by mrmajik45 » Fri Jul 06, 2018 4:07 pm

"Again"
ReactOS Donator ~ $5.00 | Linux Mint Donator ~ $1.00 in BTC

Doctor Funkenstein
Level 2
Level 2
Posts: 68
Joined: Wed Jan 31, 2018 4:16 pm

Re: Login fails after 18.3 to 19 upgrade

Post by Doctor Funkenstein » Fri Jul 06, 2018 4:18 pm

So I was able to reinstall cinnamon from the command line. It now allows me to log in, but displays the error:

"Cinnamon just crashed. You are currently running in Fallback Mode. Do you want to restart Cinnamon?"

If I click yes, it just crashes again. So far I am able to open things from the welcome menu and such, but I have no toolbar.

User avatar
mrmajik45
Level 5
Level 5
Posts: 597
Joined: Tue Aug 29, 2017 9:51 pm
Location: USA, indiana
Contact:

Re: Login fails after 18.3 to 19 upgrade

Post by mrmajik45 » Fri Jul 06, 2018 4:19 pm

Can you open cmd and type: cinnamon --version
and tell us the output
ReactOS Donator ~ $5.00 | Linux Mint Donator ~ $1.00 in BTC

Doctor Funkenstein
Level 2
Level 2
Posts: 68
Joined: Wed Jan 31, 2018 4:16 pm

Re: Login fails after 18.3 to 19 upgrade

Post by Doctor Funkenstein » Fri Jul 06, 2018 4:31 pm

Yes. Output is:

"cinnamon: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory"

User avatar
mrmajik45
Level 5
Level 5
Posts: 597
Joined: Tue Aug 29, 2017 9:51 pm
Location: USA, indiana
Contact:

Re: Login fails after 18.3 to 19 upgrade

Post by mrmajik45 » Fri Jul 06, 2018 4:35 pm

So you have the problem I had, copy and paste this whole line of code to the terminal, this should fix it.

Code: Select all

sudo apt install --reinstall libegl1 libegl1-mesa=18.0.0~rc5-1ubuntu1 libgbm1=18.0.0~rc5-1ubuntu1 libgl1-mesa-dri=18.0.0~rc5-1ubuntu1 libgl1-mesa-glx=18.0.0~rc5-1ubuntu1 libglapi-mesa=18.0.0~rc5-1ubuntu1 libgles2-mesa=18.0.0~rc5-1ubuntu1 libosmesa6=18.0.0~rc5-1ubuntu1 libwayland-egl1-mesa=18.0.0~rc5-1ubuntu1 libxatracker2=18.0.0~rc5-1ubuntu1
ReactOS Donator ~ $5.00 | Linux Mint Donator ~ $1.00 in BTC

Doctor Funkenstein
Level 2
Level 2
Posts: 68
Joined: Wed Jan 31, 2018 4:16 pm

Re: Login fails after 18.3 to 19 upgrade

Post by Doctor Funkenstein » Fri Jul 06, 2018 5:14 pm

mrmajik45 wrote:
Fri Jul 06, 2018 4:35 pm
So you have the problem I had, copy and paste this whole line of code to the terminal, this should fix it.

Code: Select all

sudo apt install --reinstall libegl1 libegl1-mesa=18.0.0~rc5-1ubuntu1 libgbm1=18.0.0~rc5-1ubuntu1 libgl1-mesa-dri=18.0.0~rc5-1ubuntu1 libgl1-mesa-glx=18.0.0~rc5-1ubuntu1 libglapi-mesa=18.0.0~rc5-1ubuntu1 libgles2-mesa=18.0.0~rc5-1ubuntu1 libosmesa6=18.0.0~rc5-1ubuntu1 libwayland-egl1-mesa=18.0.0~rc5-1ubuntu1 libxatracker2=18.0.0~rc5-1ubuntu1
This worked, thanks!

One more thing before I mark this as solved: Is there some way I can check my install of 19 and make sure it wasn't fouled up by all the problems I had?

Also, it says that it is running Cinnamon with software rendering which will use a lot of CPU...how do I fix that?

User avatar
mrmajik45
Level 5
Level 5
Posts: 597
Joined: Tue Aug 29, 2017 9:51 pm
Location: USA, indiana
Contact:

Re: Login fails after 18.3 to 19 upgrade

Post by mrmajik45 » Fri Jul 06, 2018 5:26 pm

Well now you're where i'm at, Im also trying to fix the software rendering problem.
ReactOS Donator ~ $5.00 | Linux Mint Donator ~ $1.00 in BTC

Doctor Funkenstein
Level 2
Level 2
Posts: 68
Joined: Wed Jan 31, 2018 4:16 pm

Re: Login fails after 18.3 to 19 upgrade

Post by Doctor Funkenstein » Fri Jul 06, 2018 5:49 pm

mrmajik45 wrote:
Fri Jul 06, 2018 5:26 pm
Well now you're where i'm at, Im also trying to fix the software rendering problem.
Cool (well not, but at least I'm not the only one), do you already have a thread open?

User avatar
mrmajik45
Level 5
Level 5
Posts: 597
Joined: Tue Aug 29, 2017 9:51 pm
Location: USA, indiana
Contact:

Re: [SOLVED] Login fails after 18.3 to 19 upgrade

Post by mrmajik45 » Fri Jul 06, 2018 5:50 pm

Yeah but no one has respond in a while. Hey software rendering is better than no rendering. Rendering = graphics.
ReactOS Donator ~ $5.00 | Linux Mint Donator ~ $1.00 in BTC

Post Reply

Return to “Installation & Boot”