[solved] Dual boot Mint 19 with win 10 - problem with grub

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
JVR
Level 1
Level 1
Posts: 38
Joined: Sun Jun 26, 2011 6:16 pm

Re: Dual boot Mint 19 with win 10 - problem with grub

Post by JVR » Sat Jul 14, 2018 7:54 pm

Thanks Helix. Freeing space on W10, then preparing it with GParted, choosing the "something else" option and keeping the laptop unplugged from the internet did the trick for me. Now I am facing a serious issue I can't get pass through: wifi will not show in network settings. I have gotten good help from several people and like you I have spent whole afternoons and nights searching in this forum, writing to people and trying things that worked for others, to no avail. That transition from BIOS to UEFI is such a pain in the butt!

Helix-the-II
Level 1
Level 1
Posts: 5
Joined: Sat Jul 14, 2018 7:01 pm

Re: Dual boot Mint 19 with win 10 - problem with grub

Post by Helix-the-II » Mon Jul 16, 2018 12:14 am

Can you use ethernet to troubleshoot the drivers?

User avatar
Mroptonix
Level 1
Level 1
Posts: 22
Joined: Tue Jul 10, 2018 5:38 pm

Re: Dual boot Mint 19 with win 10 - problem with grub

Post by Mroptonix » Tue Jul 17, 2018 6:26 am

Without reinstalling LM19 and with the last config problem get solved.
I think other users with this problem can solve it by this method:
see the first post to find out the problem.

solution
1. adding windows entry manually in grub:
do this in this manner:
open file 40_custom in this path /etc/grub.d using this command in teminal

Code: Select all

sudo nemo
and add this lines to the end of the file:

menuentry "Windows" {
insmod part_msdos
insmod ntfs
set root='(hd0,msdos1)'
chainloader +1
}


2. use a windows booted DVD and do a ready to use boot repair option!

pddm
Level 1
Level 1
Posts: 5
Joined: Wed Jul 11, 2018 1:33 pm

Re: Dual boot Mint 19 with win 10 - problem with grub

Post by pddm » Tue Jul 17, 2018 7:11 pm

Mroptonix wrote:
Fri Jul 13, 2018 8:24 am
pddm wrote:
Thu Jul 12, 2018 3:39 pm
I think there is a big confusion:
Legacy (CSM) and UEFI are two options of the Boot Mode setting in the Bios.
During an operating system's installation process, it will adhere to that setting and install accordingly.
Legacy generally puts the boot loader on the MBR while UEFI places it on the EFI partition.
If the setting in the bios is changed the boot for already installed operating system(s) has to be fixed in consequence.
Now Linux Mint 19 has absolutely no problems installing on a Legacy configured system and should work directly.

If Linux Mint 19 is installed on an UEFI system it most possibly failed with 'grub-efi-amd64-signed package failed to install into /target/' error.
To fix that Boot with a USB drive with SuperGrub2disk. https://www.supergrubdisk.org/super-grub2-disk/
Once you start up Mint 19 from the hard disk simply run

Code: Select all

sudo update-grub
from terminal.


So using this method there is no need for reinstalling LM19?
Correct.

Post Reply

Return to “Installation & Boot”