[solved] LM19: No symbol table. Press any key to continue

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
User avatar
DarrenG
Level 1
Level 1
Posts: 46
Joined: Mon Jun 23, 2014 9:12 pm
Location: New Zealand

[solved] LM19: No symbol table. Press any key to continue

Post by DarrenG » Fri Jul 13, 2018 7:56 pm

Having updated from 18.3 to 19 cinnamon via a clean installation I am now experiencing an error message "No symbol table. Press any key to continue" similar to https://bugs.launchpad.net/ubuntu/+sour ... ug/1633839.

I set up my my SSD and HDD as follows

sda1 /boot
sda2 /
sda3 /home
sda4 /swap

sdb1 /data

the best solution from the launchpad article seems to be

Code: Select all

sudo grub-install /dev/sda
sudo update-grub
sudo reboot
Is this a common problem? I haven't struck it before.
Last edited by DarrenG on Sat Jul 14, 2018 1:05 am, edited 1 time in total.
“People shouldn't be afraid of their government. Governments should be afraid of their people.”

User avatar
catweazel
Level 17
Level 17
Posts: 7830
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: LM19: No symbol table. Press any key to continue

Post by catweazel » Fri Jul 13, 2018 9:22 pm

DarrenG wrote:
Fri Jul 13, 2018 7:56 pm
Is this a common problem? I haven't struck it before.
From the link you posted:

This bug affects 46 people

From go ogle:

About 37 results

I'd say that, no, it isn't common.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

User avatar
DarrenG
Level 1
Level 1
Posts: 46
Joined: Mon Jun 23, 2014 9:12 pm
Location: New Zealand

Re: [solved] LM19: No symbol table. Press any key to continue

Post by DarrenG » Sat Jul 14, 2018 9:48 pm

I wonder if its because I created a separate /boot partition? I got in the habit of doing that when I had multi OS accessing a common data partition. Now everybody in my house uses mint the /boot is not really needed.
“People shouldn't be afraid of their government. Governments should be afraid of their people.”

Gizmouk
Level 1
Level 1
Posts: 3
Joined: Sat Jun 23, 2018 9:07 am

Re: [solved] LM19: No symbol table. Press any key to continue

Post by Gizmouk » Thu Jul 19, 2018 5:06 am

Followed DarrenG's instructions.... made no difference.
I'll just go with the flow and hit any key to continue :)
:)

I upgraded from LM18.3 to LM19 on my elderly HP XW8600 with 6GB memory and a shedful of disks.

I am delighted with Linux, as a recent XP convert and bore the hell out of my friends with the virtues of non-MS running

eddie5903
Level 1
Level 1
Posts: 4
Joined: Wed Dec 23, 2015 11:49 am

Re: [solved] LM19: No symbol table. Press any key to continue

Post by eddie5903 » Sun Jul 22, 2018 11:31 am

DarrenG's instructions worked for me. I have a dual boot Windows 7/Linux laptop, each operating system has it's own drive.

Anyway, Darren thanks for your help! 8)

GazFlowers1
Level 1
Level 1
Posts: 1
Joined: Sun Feb 17, 2019 7:44 pm

Re: [solved] LM19: No symbol table. Press any key to continue

Post by GazFlowers1 » Sun Feb 17, 2019 7:58 pm

I have a dual boot Windows 7/Linux laptop, both running from separate partitions on an SSD
Had just upgraded from 18.3 to 19 when the error appeared.
DarrenG's instructions worked for me.

Post Reply

Return to “Installation & Boot”