[Solved] /boot partition has no space.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
gm10
Level 19
Level 19
Posts: 9829
Joined: Thu Jun 21, 2018 5:11 pm

Re: [Solved] /boot partition has no space.

Post by gm10 » Mon Jul 23, 2018 5:25 am

Tuxkid wrote:
Mon Jul 23, 2018 5:13 am
No. There is only 121 and 124 present and I have 140Mb of space on that partition.

Do I need to update grub again?

Thanks for all the help.
So no 4.4.0-127 packages left in Synaptic but the /boot/vmlinuz-4.4.0-127-generic file remains? Then you can remove it manually sudo rm /boot/vmlinuz-4.4.0-127-generic, same for other files that may be left behind without corresponding packages (hopefully none). And yes, I'd run a sudo update-grub after that to be sure. And that's it, all done. That was fun, right?! :lol:

You should now be able to update your kernel again (since -124 isn't the latest version) and you should be able to remove the others the normal way via Update Manager > View > Linux kernels to make room, where necessary (don't let it fill up again).
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

Post Reply

Return to “Installation & Boot”