Linux can't start with 2 RAMs, but Windows can!

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Lakratti
Level 1
Level 1
Posts: 1
Joined: Fri Jul 20, 2018 1:32 pm

Linux can't start with 2 RAMs, but Windows can!

Post by Lakratti » Fri Jul 20, 2018 1:42 pm

I have a laptop Samsung R460 with Intel 2 Duo and 2GB RAM (in 1st slot and 2nd slot is empty). Then I bought additional RAM with the same size and frequency and any Linux can't start, my laptop reboots every time when I try. Reinstallation doesn't help, I tried Debian, Ubuntu - the same story. If I use only one slot with any memory I have - everything's OK. What's wrong with Linux? Windows is installed and works without any problem!

User avatar
Moem
Level 17
Level 17
Posts: 7010
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Linux can't start with 2 RAMs, but Windows can!

Post by Moem » Fri Jul 20, 2018 1:46 pm

Hello, can you please post the result of the following terminal command, and enclose it in code tags? That's the button marked </>.
This is needed for pretty much any question about your system, so it's a good habit to post it straight away.

Code: Select all

inxi -Fxz
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

Neil Edmond
Level 5
Level 5
Posts: 886
Joined: Thu Dec 26, 2013 10:19 am
Location: N.E. AR USA

Re: Linux can't start with 2 RAMs, but Windows can!

Post by Neil Edmond » Fri Jul 20, 2018 1:52 pm

I would suggest that you run Memtest86+ on each of your two RAM modules, one at a time. This will reveal any defects or errors in the RAM, and identify which is giving the problems. Might even be good to swap each into both slots just to make sure there is not an issue with either slot.

Linux and Windows do address RAM in a slightly different way, so it is possible that Windows never even attempts to address the defective sector of memory, whereas Linux is smart enough to detect it right off. I too have had a similar situation happen to me a while back. I had a faulty RAM module.

Post Reply

Return to “Installation & Boot”