Wsjtx dependency error

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
kensown
Level 1
Level 1
Posts: 1
Joined: Tue Dec 19, 2017 4:46 pm

Wsjtx dependency error

Post by kensown » Sat Aug 11, 2018 10:51 am

I am running Mint 19 fresh install-updated and am unable to install wsjtx. In the past I have installed using launchpad but Ubuntu 18.04 is not yet supported for ham radio apps. Download the .deb file from source forge but install gives a dependency error. Any suggestions would be appreciated.

User avatar
JOPETA
Level 13
Level 13
Posts: 4670
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Wsjtx dependency error

Post by JOPETA » Sat Aug 11, 2018 3:32 pm

Did you try from repo ( i.e. sudo apt-get install wsjtx)? Also you can install newer version from this ppa.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

richard-g8jvm
Level 3
Level 3
Posts: 118
Joined: Fri Jul 26, 2013 12:46 pm

Re: Wsjtx dependency error

Post by richard-g8jvm » Sat Aug 11, 2018 4:02 pm

Hi
definitely use the ppa provided, the repo versions tend to be a bit old, and missing a lot.
just follow the instruction on the ppa page.
remember to update hamlib once you have jtsdk installed, which provides wsjtx, wsjt, wspr and hamlib
https://launchpad.net/~ki7mt/+archive/ubuntu/jtsdk
There is also MSHV which has a lighter gui, the source code is availble on the MSHV page,
IF you are using LM19
to build MSHV you need to build it with gcc-4.8 and g++-4.8, edit the makefile to use these and importantly set LINK to use g++-4.8
If you need ready built binaries , PM me and I can give you the official link to get them.
HTH
Richard G8JVM

Post Reply

Return to “Installation & Boot”