Acer laptop upgrade to mint 19 going horribly wrong [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
corkie
Level 1
Level 1
Posts: 6
Joined: Tue Aug 14, 2018 2:01 pm

Acer laptop upgrade to mint 19 going horribly wrong [SOLVED]

Post by corkie » Thu Aug 16, 2018 6:53 pm

I installed mint 18.3 on an Acer ES1-512. I changing the boot mode to legacy to a) get the live usb to boot and b) get mint installed and running on my HDD. To get window (8.1) to run I would reboot in UEFI mode. In legacy mode there are two small problems. a) the touchpad is inoperative b) No power management functions work. The touch pad work-around is to plug in a usb mouse. Power management is an issue because once the screen goes off there is no way to revive it and shutting down the computer from the menu doesn't actually do much to except kill off mint and make the still running system unusable. You have to sit on the power button until the blue light goes off. The system can then be restarted by repressing the power button. Not so bad but I was trying out a mint 19 live USB stick and I noticed it would boot in UEFI mode. Something the 18.3 stick would never do. I also noticed that the touch pad was still inoperative but the power management system was now fully operational. I decided to upgrade and to try dual booting in UEFI mode.

After a failed mint 19 installation in a new partition I tried Boot-repair but that just removed grub and that destroyed my ability to run mint 18.3 in legacy mode. So I boned up on partition editing, deleted the new partition and resized and reformatted the original linux data partition. So now I have installed mint 19 on that partition but it won't install grub in any form that works. Because I installed mint 19 in UEFI mode booting in legacy mode drops into grub rescue mode with the error that /boot/grub/i386-pc/normal.mod can't be found. Not surprising because all the interesting bits of /boot/grub/ are in a sub called /x86_64-efi/ There is no /i386-pc/ subdirectory. That is a pity. If I knew what to put there is suppose i could create it and copy in..

Back in UEFI mode on the live mint 19 usb I tried https://sites.google.com/site/easylinuxtipsproject/6 That actually fixed the boot sequence destroyed by the windows loader but falls over with a mysterious error which I will now reveal.(slightly mangled due to repost problems)

Code: Select all

 mint@mint:~$ sudo mount /dev/sda6 / mnt 
 mint@mint:~$ for i in /dev /dev/pts /proc /sys; do sudo mount -B $i /mnt$i; done 
 mint@mint:~$ modprobe efivars 
 mint@mint:~$ sudo chroot /mnt 
 root@mint:/# apt-get install 
 --reinstall grub-efi-amd64 Reading package lists... Done 
 Building dependency tree Reading state information... Done 
 0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 4 not upgraded. 
 Need to get 0 B/46.8 kB of archives. After this operation, 0 B of additional disk space will be used. 
 Preconfiguring packages ... (Reading database ... 233701 files and directories currently installed.) Preparing to unpack .../grub-efi-amd64_2.02-2ubuntu8_amd64.deb ... 
 Unpacking grub-efi-amd64 (2.02-2ubuntu8) over (2.02-2ubuntu8) ... 
 Setting up grub-efi-amd64 (2.02-2ubuntu8) ... 
 Installing for x86_64-efi platform. Installation finished. No error reported. Generating grub configuration file ... 
 Found linux image: /boot/vmlinuz-4.15.0-20-generic 
 Found initrd image: /boot/initrd.img-4.15.0-20-generic
So far so good but no joy for me.

Code: Select all

 WARNING: Failed to connect to lvmetad. Falling back to device scanning. 
 grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your device.map. 
 Adding boot menu entry for EFI firmware configuration done Processing triggers for shim-signed (1.34.9+13-0ubuntu2) ... 
 Secure Boot not enabled on this system. 
 root@mint:/# exit exit 
 mint@mint:~$ 
I have no idea what lvmetad is and why we need to connect to it.
A search with error message was no help.
Also no idea why we need to have a grub drive for /dev/sdb1 surely all we want to work is /dev/sda ?
We have /dev/sda2 as the EFI partition and dev/sda6 is the mint 19 data partition.
Anyway thought I'd give this forum a shot before going back to legacy mode
Last edited by corkie on Mon Aug 20, 2018 11:57 am, edited 3 times in total.

User avatar
Tomgin5
Level 5
Level 5
Posts: 819
Joined: Sat Mar 19, 2016 2:37 pm
Location: Beaverton, Oregon USA

Re: upgrade to mint 19 going horribly wrong

Post by Tomgin5 » Fri Aug 17, 2018 2:23 am

definitely go back to legacy and turn off fast boot and secure boot. I have had nothing but difficulty with EUFI screwing everything up.

bill_steamshovel
Level 2
Level 2
Posts: 70
Joined: Fri Jul 13, 2018 8:30 am

Re: upgrade to mint 19 going horribly wrong

Post by bill_steamshovel » Fri Aug 17, 2018 2:43 am

Can you really choose between UEFI and Legacy - my newbie impression is that you must boot up in one or the other and that is not a choice - rather it is dictated by the hardware on your computer. Keen to bettwer understand this .... what should I be reading ?

Bill

User avatar
catweazel
Level 17
Level 17
Posts: 7755
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: upgrade to mint 19 going horribly wrong

Post by catweazel » Fri Aug 17, 2018 2:50 am

bill_steamshovel wrote:
Fri Aug 17, 2018 2:43 am
Can you really choose between UEFI and Legacy - my newbie impression is that you must boot up in one or the other and that is not a choice - rather it is dictated by the hardware on your computer. Keen to bettwer understand this .... what should I be reading ?
Your impression needs to be corrected :)

When invoking a BIOS boot menu, many machines, depending on the BIOS settings (usually a setting titled UEFI or Legacy Boot), will present both a EUFI and legacy boot option for the same device.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

corkie
Level 1
Level 1
Posts: 6
Joined: Tue Aug 14, 2018 2:01 pm

Re: upgrade to mint 19 going horribly wrong

Post by corkie » Fri Aug 17, 2018 2:56 am

MY BIOS won't let me disable Secure mode in UEFI boot so a Legacy mode install is my only option it seems.
Grub now tells me "Error - No Symbol Table - Press any key to continue" .
Probably trying to offer me a dual boot but windows won't cooperate.
So I do that and It is a non fatal error. Mint boots up anyway. Hooray.
I'll have a poke around later and see what partitions on sda I can mount.

User avatar
catweazel
Level 17
Level 17
Posts: 7755
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: upgrade to mint 19 going horribly wrong

Post by catweazel » Fri Aug 17, 2018 3:02 am

corkie wrote:
Fri Aug 17, 2018 2:56 am
Grub now tells me "Error - No Symbol Table - Press any key to continue" .
https://bugs.launchpad.net/ubuntu/+sour ... ug/1633839
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

corkie
Level 1
Level 1
Posts: 6
Joined: Tue Aug 14, 2018 2:01 pm

Re: upgrade to mint 19 going horribly wrong

Post by corkie » Fri Aug 17, 2018 8:18 pm

Thanks CW. I note that no one in that discussion has a theory about what they actually fixed.
I suspect that telling the installer to use the EFI partition /dev/sda2 as boot partition was my mistake.
The experts say to use lsblk or sudo fdisk -l or sudo sfdisk -l to identify your boot partition but look at my results.
lsblk finds the mount point and swap disk but can't find boot

Code: Select all

mikeb@mikeb-Aspire-ES1-512:~$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 931,5G  0 disk 
├─sda1   8:1    0   600M  0 part 
├─sda2   8:2    0   300M  0 part 
├─sda3   8:3    0   128M  0 part 
├─sda4   8:4    0 524,5G  0 part 
├─sda5   8:5    0  14,2G  0 part 
├─sda6   8:6    0   387G  0 part /
└─sda7   8:7    0   3,9G  0 part [SWAP]
sr0     11:0    1  1024M  0 rom  
 
fdisk has all the partition names but no *

Code: Select all

 
mikeb@mikeb-Aspire-ES1-512:~$ sudo fdisk -l
Disk /dev/sda: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
...
Device          Start        End    Sectors   Size Type
/dev/sda1        2048    1230847    1228800   600M Windows recovery environment
/dev/sda2     1230848    1845247     614400   300M EFI System
/dev/sda3     1845248    2107391     262144   128M Microsoft reserved
/dev/sda4     2107392 1101985617 1099878226 524,5G Microsoft basic data
/dev/sda5  1923827712 1953523711   29696000  14,2G Windows recovery environment
/dev/sda6  1101985792 1913616651  811630860   387G Linux filesystem
/dev/sda7  1915680768 1923827711    8146944   3,9G Linux swap

Partition table entries are not in disk order.
 
sfdisk no better

Code: Select all

mikeb@mikeb-Aspire-ES1-512:~$ sudo sfdisk -l
Disk /dev/sda: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
...
Device          Start        End    Sectors   Size Type
/dev/sda1        2048    1230847    1228800   600M Windows recovery environment
/dev/sda2     1230848    1845247     614400   300M EFI System
/dev/sda3     1845248    2107391     262144   128M Microsoft reserved
/dev/sda4     2107392 1101985617 1099878226 524,5G Microsoft basic data
/dev/sda5  1923827712 1953523711   29696000  14,2G Windows recovery environment
/dev/sda6  1101985792 1913616651  811630860   387G Linux filesystem
/dev/sda7  1915680768 1923827711    8146944   3,9G Linux swap

Partition table entries are not in disk order.
We still have the dead touchpad and power management problems.
On a positive note /dev/sda4 mounts from the gui no problem. Some progress I guess.

corkie
Level 1
Level 1
Posts: 6
Joined: Tue Aug 14, 2018 2:01 pm

Re: upgrade to mint 19 going horribly wrong

Post by corkie » Sat Aug 18, 2018 11:38 am

Rather than do anything fancy I decided to re-install mint 19 on top of itself without formatting the partition.
I did the "do something else" option and selected the existing linux partition and put the mount point "/" there. e.g.

download/file.php?id=20156&mode=view

I left well alone the "Device for boot loader installation"

The reinstall worked and my Grub error is gone.

The idea behind not formatting was that my firefox bookmarks would survive. Which they did.
I dare say that my home directory would have survived but as it was already empty due to an earlier mishap I'm not sure.

deepakdeshp
Level 11
Level 11
Posts: 3856
Joined: Sun Aug 09, 2015 10:00 am

Re: upgrade to mint 19 going horribly wrong

Post by deepakdeshp » Sat Aug 18, 2018 1:43 pm

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
Flemur
Level 16
Level 16
Posts: 6195
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: upgrade to mint 19 going horribly wrong

Post by Flemur » Sat Aug 18, 2018 2:08 pm

corkie wrote:
Fri Aug 17, 2018 8:18 pm
lsblk finds the mount point and swap disk but can't find boot
I don't think "boot" indicates anything useful.
My system is
grub bootloader on sda (disk)
grub files on sda1 (/boot/grub/grub.cfg - unbuntu), those files point to Mint's /boot/vmlinuz on sda2, and
mint on sda2 - and sda2 is marked "boot". They're both primary partitions.

I think Mint marked it's own partition (sda2) as boot when it installed grub, but then later I made the ubuntu install (sda1) control booting and the old "boot" marker remained. I can wipe out the marked "boot" partition and the computer can still boot ubuntu on sda1
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

corkie
Level 1
Level 1
Posts: 6
Joined: Tue Aug 14, 2018 2:01 pm

Re: upgrade to mint 19 going horribly wrong

Post by corkie » Sat Aug 18, 2018 3:52 pm

Thanks for the info deepakdeshp and Flemur.
I'm like a dog with a bone and thanks to some discussion elsewhere in this forum I can report some success.
I found out that to disable secure mode I had to create a supervisor pw in the bios.
https://itsfoss.com/disable-secure-boot-in-acer/
That worked and so suitably emboldened I switched to UEFI boot with secure-boot switched off and reinstalled mint 19.
It all seemed ok but sure enough, up pops windoze upon reboot. So I went back to the oracle and found this article
which shows how to add your linux startup file to secure-boot's list of trusted files
https://itsfoss.com/no-bootable-device-found-ubuntu/
So back in UEFI secure mode, imagine my disappointment when the boot order problem appears to be intractable.
No matter what you do, this system will always boot windows. But I tried one more thing.

Tapping F12 (on boot-up)

Hey presto I am presented with a nice little boot menu with Mint and windows on offer.
No prizes for guessing which one I chose.
The first time I did it, secure-boot popped up a blue screen with an "are you sure" prompt.
That appears to be a one off.

So now I have mint 19 running in UEFI secure mode.
Because the system will now resume etc I won't need to reboot all the time.
Just the non operative touch pad to sort out now :)
Update -
The touch pad doesn't work on winows either. Marking this as [solved]. Thanks everyone.

Post Reply

Return to “Installation & Boot”