Solved: Linx Mint 19 Hangs on Boot After Updates (ASUS UEFI BIOS Secure Boot issue)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Auerilas
Level 1
Level 1
Posts: 36
Joined: Fri Nov 18, 2016 1:26 pm

Solved: Linx Mint 19 Hangs on Boot After Updates (ASUS UEFI BIOS Secure Boot issue)

Post by Auerilas » Mon Sep 17, 2018 12:08 pm

Hi all,
I recently updated several packages on my desktop machine (including the linux kernel). I shut down the desktop and, when I started it up again, I found that it was hanging on boot. No mint splash screen, it never even got that far. The screen to enter BIOS showed up, then just a blank screen. I wasn't sure what was happening so, on a hunch, I entered BIOS. I found that my BIOS was set to use Windows UEFI on startup:
IMG_20180917_095349.jpg
I wasn't sure what this was, so I changed the option to 'Other OS':
IMG_20180917_095405.jpg
Everything *appears* to be in order, but I don't know what happened. Any thoughts on why the sudden change? Here is my recent update history.
Screenshot from 2018-09-17 09-57-32.png
Last edited by Auerilas on Mon Sep 17, 2018 5:10 pm, edited 6 times in total.

Auerilas
Level 1
Level 1
Posts: 36
Joined: Fri Nov 18, 2016 1:26 pm

Re: Linx Mint 19 Hangs on Boot After Updates

Post by Auerilas » Mon Sep 17, 2018 12:08 pm

More update history
Screenshot from 2018-09-17 09-58-12.png

DAMIEN1307
Level 7
Level 7
Posts: 1910
Joined: Tue Feb 21, 2017 8:13 pm
Location: Alamogordo, New Mexico, USA

Re: Linx Mint 19 Hangs on Boot After Updates (UEFI issue?)

Post by DAMIEN1307 » Mon Sep 17, 2018 12:12 pm

if im reading your screen shots correctly, it appears that your "secure boot" is enabled...it should be disabled to avoid boot problems in linux OS...DAMIEN

edit...if you read the bottom of your screen shot, it tells you that "secure boot" is only used for microsoft windows systems in so many words or less.
ORDO AB CHAO

Auerilas
Level 1
Level 1
Posts: 36
Joined: Fri Nov 18, 2016 1:26 pm

Re: Linx Mint 19 Hangs on Boot After Updates (UEFI issue?)

Post by Auerilas » Mon Sep 17, 2018 2:22 pm

I did see that, and I've tried to turn it off. But the setting is disabled in my BIOS and I have no idea how to do that. What's odd is that it did seem to be working up to this point.

Auerilas
Level 1
Level 1
Posts: 36
Joined: Fri Nov 18, 2016 1:26 pm

Re: Linx Mint 19 Hangs on Boot After Updates (UEFI issue?)

Post by Auerilas » Mon Sep 17, 2018 2:32 pm

So I re-read the help text at the bottom of my BIOS, and I found online instructions for disabling secure boot. That does seem to be the problem. The way the help text reads, secure boot only works if Windows UEFI is selected, while selecting "Other OS" disables secure boot. Likewise, I went in and manually disabled secure boot by deleting the keys, and now I can select either Windows UEFI or Other OS to boot. Either way works, because either way disables secure boot. I've updated the title because this issue and resolution are specific to ASUS motherboards with ASUS Bios, and might help someone else who has this issue.

Thanks!

DAMIEN1307
Level 7
Level 7
Posts: 1910
Joined: Tue Feb 21, 2017 8:13 pm
Location: Alamogordo, New Mexico, USA

Re: Linx Mint 19 Hangs on Boot After Updates (ASUS UEFI BIOS Secure Boot issue)

Post by DAMIEN1307 » Mon Sep 17, 2018 2:40 pm

your welcome...DAMIEN

PS...in the subject line of your first post...if this is solved, mark that subject line as solved so all will know. that way it will flag people to view it if they are having the same problem.
ORDO AB CHAO

User avatar
simonsaysthis
Level 2
Level 2
Posts: 50
Joined: Sun Jun 11, 2017 1:39 pm
Location: Johannesburg

Re: Linx Mint 19 Hangs on Boot After Updates (UEFI issue?)

Post by simonsaysthis » Mon Sep 17, 2018 4:57 pm

Auerilas wrote:
Mon Sep 17, 2018 2:32 pm
So I re-read the help text at the bottom of my BIOS, and I found online instructions for disabling secure boot. That does seem to be the problem. The way the help text reads, secure boot only works if Windows UEFI is selected, while selecting "Other OS" disables secure boot. Likewise, I went in and manually disabled secure boot by deleting the keys, and now I can select either Windows UEFI or Other OS to boot. Either way works, because either way disables secure boot. I've updated the title because this issue and resolution are specific to ASUS motherboards with ASUS Bios, and might help someone else who has this issue.

Thanks!
Thanks so much for this post dude. Also got an Asus Mobo and wasn't even aware I had secure boot enabled too. Just deleted the keys and managed to disable.

Post Reply

Return to “Installation & Boot”