system freezes and boot manager is reset on reboot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
adeswas
Level 1
Level 1
Posts: 4
Joined: Fri Dec 18, 2015 4:00 pm

system freezes and boot manager is reset on reboot

Post by adeswas » Fri Sep 21, 2018 12:36 pm

Hi all. This is such a weird problem that I think it's a one off, but MAYBE someone out there has experienced it. Not even sure in which forum to post.

Have got an acer laptop with an aftermarket evo SSD. Dual boot Mint Tara (cinnamon) and Windose 10 with UEFI. Often while using Mint (doesn't happen with Windose), the system will crash--everything stops and I have to force a hard reboot. On that reboot I get an error that no bootable device is installed. I go to BIOS and see that the grub boot loader has been mysteriously moved from first boot option to 5th and windose boot loader is placed in number one spot. I put the grub bootloader back into the first boot option spot, save, reboot and all is well...until the next crash.

Happens too randomly to get an accurate fix on any process or event that triggers it. Have reinstalled Mint, and MS. No change. Has happened since Mint 18.1. All upgrades are up to date.

Any ideas. I'm no coder but have been around Linux for quite some time so I can make my way around the cli if need be

Thanks in advance
Adrian

User avatar
kc1di
Level 13
Level 13
Posts: 4787
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: system freezes and boot manager is reset on reboot

Post by kc1di » Sun Sep 23, 2018 5:33 am

It's hard to say from the description given. But a good place to start is to do this in a terminal and post the output so others will know what hardware is involved.

Code: Select all

inxi -Fxz


Another place to look would be the system logs found in /var/log and /var/crash see if anything shows up there.
I think the boot problem may be a separate issue. but not sure.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

adeswas
Level 1
Level 1
Posts: 4
Joined: Fri Dec 18, 2015 4:00 pm

Re: system freezes and boot manager is reset on reboot

Post by adeswas » Tue Sep 25, 2018 12:32 pm

Thank you. I'll get on it

adeswas
Level 1
Level 1
Posts: 4
Joined: Fri Dec 18, 2015 4:00 pm

Re: system freezes and boot manager is reset on reboot

Post by adeswas » Tue Sep 25, 2018 12:35 pm

Results:

System: Host: a-Notebook-mint Kernel: 4.15.0-34-generic x86_64
bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: laptop System: Acer product: Aspire V3-112P v: V1.16 serial: N/A
Mobo: Acer model: R2 v: Type2 - A01 Board Version serial: N/A
UEFI: Insyde v: V1.16 date: 10/20/2015
Battery BAT1: charge: 40.2 Wh 100.0% condition: 40.2/48.9 Wh (82%)
model: LGC AC14B8K status: Full
CPU: Quad core Intel Celeron N2940 (-MCP-)
arch: Silvermont rev.8 cache: 1024 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 14660
clock speeds: max: 2249 MHz 1: 673 MHz 2: 804 MHz 3: 753 MHz
4: 920 MHz
Graphics: Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1366x768@60.06hz
OpenGL: renderer: Mesa DRI Intel Bay Trail
version: 4.2 Mesa 18.0.5 Direct Render: Yes
Audio: Card Intel Atom Processor Z36xxx/Z37xxx Series High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-34-generic
Network: Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
driver: ath9k bus-ID: 02:00.0
IF: wlp2s0 state: up mac: <filter>
Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 03:00.0
IF: enp3s0 state: down mac: <filter>
Drives: HDD Total Size: 500.1GB (11.9% used)
ID-1: /dev/sda model: Samsung_SSD_850 size: 500.1GB temp: 0C
Partition: ID-1: / size: 211G used: 48G (24%) fs: ext4 dev: /dev/sda5
ID-2: swap-1 size: 8.46GB used: 0.00GB (0%)
fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 45.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 211 Uptime: 14 min Memory: 1249.9/7858.7MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

Post Reply

Return to “Installation & Boot”