LM7 + Mint4Win + Windows 7 + RAID 0 = not working... why ?

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
javs

LM7 + Mint4Win + Windows 7 + RAID 0 = not working... why ?

Post by javs » Sun Jun 21, 2009 9:16 pm

Hello,

New poster here... first things first, sorry if my problem has already been submitted.

I'm trying to get LM7 to work, to no avail. Long story short...
  • I'm running a Core 2 Quad under Windows 7 Ultimate RC x64
  • Target HDD is a 500 GB * 2 RAID 0 array (provided by chipset (Intel G33 Express))
  • I ran Mint4Win using administrator privileges and Windows Vista SP2 compatibility settings (as a workaround for this bug). Install was a breeze.
  • After reboot, Linux_Mint_Main appears in boot menu. When I select it, LM7 splash screen appears with the green progress bar BUT a few seconds later, a black screen with some text and an (initramfs) prompt shows up.
Weird, uh ? What am I supposed to do to make LM7 work ? Does LM7 have trouble recognizing RAID ?

BCDEdit shows entry as follow :

Code: Select all

identificateur          {aacfbee2-39ab-11de-85d2-d34f313f8065}
device                  partition=C:
path                    \mint\winboot\wubildr.mbr
description             Linux_Mint_Main
Any help will be appreciated.

Thank you :)

User avatar
markcynt
Level 6
Level 6
Posts: 1117
Joined: Sun May 17, 2009 10:53 am
Location: Lakeland Florida

Re: LM7 + Mint4Win + Windows 7 + RAID 0 = not working... why ?

Post by markcynt » Mon Jun 22, 2009 5:09 am

I've never tried Mint4Win and I've never tried installing Linux Mint on a RAID 0 setup but I have tried Ubuntu via a normal install and my RAID was not recognized. With the Ubuntu Alternate Install CD however, my RAID was recognized and Ubuntu was easily installed.

I think it would be nice for Mint to make an alternate install CD. Not sure that it makes sense for them though.
Image
P5N-E SLI, Core2Duo E6850 3GHZ X 2
2 GB DDR2 800MHZ
EVGA 8800GTS 320MB
2x320GB Hitachi
Arctic Cooling Freezer 7 Pro

javs

Re: LM7 + Mint4Win + Windows 7 + RAID 0 = not working... why ?

Post by javs » Mon Jun 22, 2009 8:05 am

Hello markcynt,

I know Ubuntu Alternate CD will work without problems... that's why I installed LM7 using Mint4Win (Wubi). I thought it was the ideal workaround... no need to mess with RAID modules (dmraid, fakeraid, you name it). Yeah, I/O disk performance decreases when RAID should compensate it.

I don't thlnk guys behind LM will release an Alternate CD anytime soon. However, they should integrate RAID modules on default CD with graphical installation instead.

One thing's for sure, I will not give up RAID only to make LM7 work... I want to keep my RAID 0 array to install OSes and my HP 750 GB Personal Media Drive for data.

I'm wondering... how can you get the splash screen to show up and get an initramfs prompt a few seconds later :? ? It may have something to do with some setting, somewhere... I remember last year, when installing Ubuntu 8.04 with Wubi, I've had to change some setting in a file to make the thing work.

Any other suggestions ? If I find an answer on my own, I will post it.

Post Reply

Return to “Installation & Boot”