Page 1 of 1

[Solved] How to boot Linux Mint on Lenovo ideapad 100S-14IBR?

Posted: Fri Nov 09, 2018 11:02 am
by hehemrin
I have installed Mint 19 on my Lenovo ideapad 100S-14IBR. I selected to take away discovered partition (maybe that is the Lenovo WIndows/recovery partition?), as well as everything installed. I had Windows 10, 64 bit, originally.

Installation went smoothly. Only the issue I cannot boot Mint. When I start the laptop, I get these options:
1. Windows Boot Manager
2. eMMC Disk: SanDisk iNAND 32GB"

I can still start the Live-Mint on the USB-memory.

I have in this forum and elsewhere seen similar problem discussed, although not any clear solution and especially not for me as new to Linux and not that very deeply skilled in computers.

One post in this forum wrote "You'll need to add the file "bootia32.efi" to /efi/BOOT/"? I don’t know or understand if 32 bit EFI can be relevant for me? If it is relevant, where do I find and how do I add this file? I should do it via the Live-Mint?

Or is it anything else?

Grateful for any help to be able to boot my Mint installation! Bear in mind I’m not a very advanced computer handler.

Re: How to boot Linux Mint on Lenovo ideapad 100S-14IBR?

Posted: Thu Nov 15, 2018 5:48 pm
by hehemrin
I have solved my issue with a work around:
My first installation was done in BIOS (legacy) mode. Now I changed to EFI mode in the Boot setup. It also required that I disabled "Secure boot" in the Boot setup. When I installed Mint 19 in EFI mode, it worked without any problem to boot and use Linux Mint 19 on this laptop stated in the title; Lenovo ideapad 100S-14IBR.

Re: [Solved] How to boot Linux Mint on Lenovo ideapad 100S-14IBR?

Posted: Tue Nov 20, 2018 12:30 am
by GlennD
I purchased new a Lenovo Ideapad 110s sold with pre-installed Windows 10. After finding the Windows 10 and Lenovo software took about 27 Gb of the 32 Gb SSD, and "important" Windows 10 updates wouldn't download owing to lack of disk space, obviously the unit was only set up for people short on ideas and no wish to update.
So dumping Windows 10 altogether I installed Linux Mint 19 Xfce from an external USB-connected DVD drive. Installation seemed smooth, but the Ideapad wouldn't reboot.
After some digging on this and Ubuntu forums I've just successfully reinstalled the Xfce with the following settings in BIOS:
USB Legacy - Enabled
Wireless - Enabled
Hotkey Mode - Not relevant
Intel Virtual Technology - Enabled
BIOS Flash Back - Disabled
Intel Trust Platform Technology - Disabled
Boot Mode - Legacy Support
Boot Priority - UEFI First
USB Boot - Enabled
PXE Boot To LAN - Disabled
OS Optimized Defaults - Disabled
I installed this time without using the wi-fi (to speed up installation). Rebooting worked fine, I've now connected the wi-fi and downloaded updates. Less than 30% of the SSD is used by the current setup.

Re: [Solved] How to boot Linux Mint on Lenovo ideapad 100S-14IBR?

Posted: Tue Nov 20, 2018 6:34 pm
by hehemrin
Good to hear that you GlennD also solved and got the Mint installation working!

I'm not sure on this statement: But because you had Boot prio: UEFI first, I would guess that your Mint also was installed in UEFI mode. I had Boot mode: UEFI, (ie no Legacy support at all). I believe, if you are interested you can try now change Boot mode to UEFI (only); if your Mint starts it was installed in EFI mode. For me it worked to have WiFi on as well, but that's a minor thing.

I agree, it is a lot of disk space now! Just make sure you do not save TimeShift on same disc, then you will have a lot space lost for those safety backup (which indeed always are best to have on another disc).

So, now I hope we and more with troubles with Windows on eg Lenovo ideapad 1002 can enjoy Mint!

By the way, I wrote a short story about this; Cheap laptop reborn: ... ik-hemrin/