Super slow boot :/

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
gil5587
Level 1
Level 1
Posts: 12
Joined: Sat Oct 27, 2018 8:01 am

Super slow boot :/

Post by gil5587 » Sun Nov 11, 2018 4:01 pm

HI guys,

I've installed Linux mint 19 CInnamon a few weeks ago.
since the fresh installation, the boot time is very very slow, also when logging out the system, it takes much time.
I'm using an SSD for the OS, that makes my issue more awkward.. :cry:


This is my system info:
Screenshot from 2018-11-11 21-41-57.png

$ systemd-analyze:

Code: Select all

Startup finished in 6.581s (firmware) + 11.224s (loader) + 3.502s (kernel) + 1min 32.985s (userspace) = 1min 54.293s
graphical.target reached after 1min 32.977s in userspace
$ systemd-analyze blame:

Code: Select all

25.082s NetworkManager.service
         25.052s lightdm.service
         25.050s plymouth-quit-wait.service
          8.021s NetworkManager-wait-online.service
          1.360s apparmor.service
          1.261s systemd-resolved.service
          1.162s systemd-timesyncd.service
           716ms ufw.service
           597ms apt-daily-upgrade.service
           590ms keyboard-setup.service
           537ms dev-sdb2.device
           438ms apt-daily.service
           288ms systemd-logind.service
           208ms systemd-journal-flush.service
           167ms udisks2.service
           156ms systemd-udevd.service
           146ms ModemManager.service
           145ms networkd-dispatcher.service
           136ms accounts-daemon.service
           127ms systemd-modules-load.service
           109ms grub-common.service
           108ms ubuntu-system-adjustments.service
           104ms upower.service
lines 1-23...skipping...
         25.082s NetworkManager.service
         25.052s lightdm.service
         25.050s plymouth-quit-wait.service
          8.021s NetworkManager-wait-online.service
          1.360s apparmor.service
          1.261s systemd-resolved.service
          1.162s systemd-timesyncd.service
           716ms ufw.service
           597ms apt-daily-upgrade.service
           590ms keyboard-setup.service
           537ms dev-sdb2.device
           438ms apt-daily.service
           288ms systemd-logind.service
           208ms systemd-journal-flush.service
           167ms udisks2.service
           156ms systemd-udevd.service
           146ms ModemManager.service
           145ms networkd-dispatcher.service
           136ms accounts-daemon.service
           127ms systemd-modules-load.service
           109ms grub-common.service
           108ms ubuntu-system-adjustments.service
           104ms upower.service
           102ms apport.service
            95ms speech-dispatcher.service
            93ms networking.service
            76ms lvm2-monitor.service
            75ms wpa_supplicant.service
            72ms mnt-pci\x2d0000:00:1f.2\x2data\x2d1\x2dpart1.mount
            71ms thermald.service
            68ms avahi-daemon.service
            67ms virtualbox.service
            64ms swapfile.swap
            60ms systemd-udev-trigger.service
            56ms pppd-dns.service
            56ms lm-sensors.service
            51ms systemd-tmpfiles-setup.service
            47ms rsyslog.service
            45ms systemd-tmpfiles-setup-dev.service
            44ms systemd-journald.service
            44ms gpu-manager.service
            34ms dns-clean.service
            34ms user@1000.service
            32ms systemd-fsck@dev-disk-by\x2duuid-0846\x2d9578.service
            31ms alsa-restore.service
            24ms systemd-sysctl.service
            23ms plymouth-start.service
            21ms colord.service
            20ms packagekit.service
            19ms boot-efi.mount
            16ms dev-mqueue.mount
            16ms sys-kernel-debug.mount
            15ms hddtemp.service
            12ms dev-hugepages.mount
            11ms plymouth-read-write.service
            10ms kerneloops.service
            10ms systemd-tmpfiles-clean.service
            10ms polkit.service
            10ms systemd-remount-fs.service
             9ms ureadahead-stop.service
             9ms blk-availability.service
             6ms console-setup.service
             5ms systemd-update-utmp.service
             5ms systemd-update-utmp-runlevel.service
lines 1-64
         25.082s NetworkManager.service
         25.052s lightdm.service
         25.050s plymouth-quit-wait.service
          8.021s NetworkManager-wait-online.service
          1.360s apparmor.service
          1.261s systemd-resolved.service
          1.162s systemd-timesyncd.service
           716ms ufw.service
           597ms apt-daily-upgrade.service
           590ms keyboard-setup.service
           537ms dev-sdb2.device
           438ms apt-daily.service
           288ms systemd-logind.service
           208ms systemd-journal-flush.service
           167ms udisks2.service
           156ms systemd-udevd.service
           146ms ModemManager.service
           145ms networkd-dispatcher.service
           136ms accounts-daemon.service
           127ms systemd-modules-load.service
           109ms grub-common.service
           108ms ubuntu-system-adjustments.service
           104ms upower.service
           102ms apport.service
            95ms speech-dispatcher.service
            93ms networking.service
            76ms lvm2-monitor.service
            75ms wpa_supplicant.service
            72ms mnt-pci\x2d0000:00:1f.2\x2data\x2d1\x2dpart1.mount
            71ms thermald.service
            68ms avahi-daemon.service
            67ms virtualbox.service
            64ms swapfile.swap
            60ms systemd-udev-trigger.service
            56ms pppd-dns.service
            56ms lm-sensors.service
            51ms systemd-tmpfiles-setup.service
            47ms rsyslog.service
            45ms systemd-tmpfiles-setup-dev.service
            44ms systemd-journald.service
            44ms gpu-manager.service
            34ms dns-clean.service
            34ms user@1000.service
            32ms systemd-fsck@dev-disk-by\x2duuid-0846\x2d9578.service
            31ms alsa-restore.service
            24ms systemd-sysctl.service
            23ms plymouth-start.service
            21ms colord.service
            20ms packagekit.service
            19ms boot-efi.mount
            16ms dev-mqueue.mount
            16ms sys-kernel-debug.mount
            15ms hddtemp.service
            12ms dev-hugepages.mount
            11ms plymouth-read-write.service
            10ms kerneloops.service
            10ms systemd-tmpfiles-clean.service
            10ms polkit.service
            10ms systemd-remount-fs.service
             9ms ureadahead-stop.service
             9ms blk-availability.service
             6ms console-setup.service
             5ms systemd-update-utmp.service
             5ms systemd-update-utmp-runlevel.service
             5ms systemd-random-seed.service
             3ms kmod-static-nodes.service
             2ms systemd-user-sessions.service
             2ms nvidia-persistenced.service
             2ms rtkit-daemon.service
             2ms setvtrgb.service
             1ms sys-kernel-config.mount
             1ms sys-fs-fuse-connections.mount
             1ms openvpn.service
Lines 51-73/73 (END)
$ df -h:

Code: Select all

Filesystem      Size  Used Avail Use% Mounted on
udev            3.9G     0  3.9G   0% /dev
tmpfs           787M  1.5M  785M   1% /run
/dev/sdb2       439G   43G  374G  11% /
tmpfs           3.9G  214M  3.7G   6% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           3.9G     0  3.9G   0% /sys/fs/cgroup
/dev/sdb1       511M  6.1M  505M   2% /boot/efi
/dev/sda1       458G   83G  353G  19% /mnt/pci-0000:00:1f.2-ata-1-part1
tmpfs           787M   52K  786M   1% /run/user/1000
$ systemd-analyze critical chain:

Code: Select all

Unknown operation critical.
Tell me if needed more info to provide.
Hope someone can resolve my problem :?
thanks in advance!

DAMIEN1307
Level 6
Level 6
Posts: 1247
Joined: Tue Feb 21, 2017 8:13 pm
Location: Alamogordo, New Mexico, USA

Re: Super slow boot :/

Post by DAMIEN1307 » Sun Nov 11, 2018 4:22 pm

List of Items to Disable from Start-Up: just copy and paste commands one at a time into your terminal and follow the prompts that are given:

Code: Select all

 sudo systemctl disable ModemManager.service

Code: Select all

sudo systemctl disable NetworkManager-wait-online.service

Code: Select all

 sudo systemctl disable pppd-dns.service

Code: Select all

sudo systemctl mask plymouth-quit-wait.service
Then Reboot...

then test boot time...

Code: Select all

systemd-analyze
in order to see total boot up items running, then run...

Code: Select all

systemd-analyze blame
in order to see if any other culprits appear.

these are usually the main culprits in a slow booting system.
ORDO AB CHAO

gil5587
Level 1
Level 1
Posts: 12
Joined: Sat Oct 27, 2018 8:01 am

Re: Super slow boot :/

Post by gil5587 » Sun Nov 11, 2018 6:41 pm

DAMIEN1307 wrote:
Sun Nov 11, 2018 4:22 pm
List of Items to Disable from Start-Up: just copy and paste commands one at a time into your terminal and follow the prompts that are given:

Code: Select all

 sudo systemctl disable ModemManager.service

Code: Select all

sudo systemctl disable NetworkManager-wait-online.service

Code: Select all

 sudo systemctl disable pppd-dns.service

Code: Select all

sudo systemctl mask plymouth-quit-wait.service
Then Reboot...

then test boot time...

Code: Select all

systemd-analyze
in order to see total boot up items running, then run...

Code: Select all

systemd-analyze blame
in order to see if any other culprits appear.

these are usually the main culprits in a slow booting system.
First of all, ty very much for your fast response!

After doing what you said:
$ systemd-analyze:

Code: Select all

Startup finished in 6.599s (firmware) + 11.236s (loader) + 2.683s (kernel) + 36.569s (userspace) = 57.088s
graphical.target reached after 36.564s in userspace
Much better! but still very weak xd

$ systemd-analyze blame:

Code: Select all

         35.389s systemd-resolved.service
         34.856s systemd-timesyncd.service
           686ms ufw.service
           578ms keyboard-setup.service
           526ms dev-sdb2.device
           509ms udisks2.service
           491ms apport.service
           482ms speech-dispatcher.service
           427ms lm-sensors.service
           403ms networkd-dispatcher.service
           384ms grub-common.service
           358ms accounts-daemon.service
           332ms systemd-logind.service
           325ms alsa-restore.service
           248ms systemd-journal-flush.service
           191ms NetworkManager.service
           150ms systemd-udevd.service
           146ms systemd-modules-load.service
           123ms apparmor.service
           113ms networking.service
           111ms systemd-tmpfiles-setup.service
           102ms upower.service
            95ms mnt-pci\x2d0000:00:1f.2\x2data\x2d1\x2dpart1.mount
            87ms ubuntu-system-adjustments.service
            76ms lvm2-monitor.service
            71ms virtualbox.service
            66ms swapfile.swap
            63ms lightdm.service
            61ms systemd-tmpfiles-setup-dev.service
            60ms systemd-udev-trigger.service
            48ms gpu-manager.service
            46ms systemd-journald.service
            38ms wpa_supplicant.service
            37ms systemd-fsck@dev-disk-by\x2duuid-0846\x2d9578.service
            34ms thermald.service
            34ms avahi-daemon.service
            29ms user@1000.service
            27ms systemd-sysctl.service
            24ms dns-clean.service
            24ms plymouth-start.service
            20ms rsyslog.service
            18ms nvidia-persistenced.service
            17ms hddtemp.service
            15ms blk-availability.service
            14ms dev-hugepages.mount
            14ms polkit.service
            14ms kerneloops.service
            12ms systemd-remount-fs.service
            12ms sys-kernel-debug.mount
            11ms boot-efi.mount
            11ms plymouth-read-write.service
            11ms kmod-static-nodes.service
            10ms flatpak-system-helper.service
            10ms colord.service
             9ms dev-mqueue.mount
             7ms openvpn.service
             6ms systemd-random-seed.service
             5ms systemd-update-utmp.service
             4ms ureadahead-stop.service
             4ms systemd-user-sessions.service
             3ms console-setup.service
             3ms systemd-update-utmp-runlevel.service
             3ms rtkit-daemon.service
             2ms sys-kernel-config.mount
             2ms sys-fs-fuse-connections.mount
             1ms setvtrgb.service
 Lines 44-66/66 (END)
What else can be done?
I have to say, when I boot the system, it first making the normal boot bip sound, and showing the motherboard screen:
(like this)
https://www.wikihow.com/Get-to-the-BIOS ... Step-2.jpg

after that, nothing happen (black screen) for like 40 seconds, and then it makes the boot bip sound again (little bit different sound tho) and after some time the OS finally finishing the boot.

User avatar
trytip
Level 9
Level 9
Posts: 2517
Joined: Tue Jul 05, 2016 1:20 pm

Re: Super slow boot :/

Post by trytip » Sun Nov 11, 2018 7:06 pm

i hear same issues with secure boot . do you have disabled secure boot and legacy support enabled?
Image

gil5587
Level 1
Level 1
Posts: 12
Joined: Sat Oct 27, 2018 8:01 am

Re: Super slow boot :/

Post by gil5587 » Sun Nov 11, 2018 7:47 pm

trytip wrote:
Sun Nov 11, 2018 7:06 pm
i hear same issues with secure boot . do you have disabled secure boot and legacy support enabled?
I don't remember, I need to check.
what's the case with it?

User avatar
trytip
Level 9
Level 9
Posts: 2517
Joined: Tue Jul 05, 2016 1:20 pm

Re: Super slow boot :/

Post by trytip » Sun Nov 11, 2018 8:05 pm

can you disable secure boot and enable legacy support see if that makes a difference
Image

gil5587
Level 1
Level 1
Posts: 12
Joined: Sat Oct 27, 2018 8:01 am

Re: Super slow boot :/

Post by gil5587 » Sun Nov 11, 2018 8:39 pm

trytip wrote:
Sun Nov 11, 2018 8:05 pm
can you disable secure boot and enable legacy support see if that makes a difference
yayyy!!
No idea what exactly I've done XD
but now:

Code: Select all

Startup finished in 8.497s (firmware) + 11.230s (loader) + 4.501s (kernel) + 2.777s (userspace) = 27.007s
graphical.target reached after 2.771s in userspace
the secure boot was already disabled.
the legacy support was enabled, but I changed it from "legacy only" to "legacy first".
hmm I did a few more things which I don't think they are related to this case haha
but this thing might affect it:
(before)
https://imgur.com/a/wVPs7qV

I changed UEFI OS's place to first boot option.

User avatar
all41
Level 14
Level 14
Posts: 5020
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Super slow boot :/

Post by all41 » Sun Nov 11, 2018 9:08 pm

gil5587 wrote:
Sun Nov 11, 2018 4:01 pm


$ systemd-analyze critical chain:

Code: Select all

Unknown operation critical.
The correct inquiry here is
systemd-analyze critical-chain
The missing hyphen is why you did not get correct
terminal output
Proud to be a supporter and monthly contributor to Mint.

gil5587
Level 1
Level 1
Posts: 12
Joined: Sat Oct 27, 2018 8:01 am

Re: Super slow boot :/

Post by gil5587 » Sun Nov 11, 2018 9:18 pm

all41 wrote:
Sun Nov 11, 2018 9:08 pm
gil5587 wrote:
Sun Nov 11, 2018 4:01 pm


$ systemd-analyze critical chain:

Code: Select all

Unknown operation critical.
The correct inquiry here is
systemd-analyze critical-chain
The missing hyphen is why you did not get correct
terminal output
thanks!

$ systemd-analyze critical-chain:

Code: Select all

The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @2.771s
└─multi-user.target @2.771s
  └─virtualbox.service @2.689s +81ms
    └─network-online.target @2.689s
      └─network.target @2.688s
        └─NetworkManager.service @2.505s +183ms
          └─dbus.service @2.196s
            └─basic.target @2.001s
              └─sockets.target @2.001s
                └─uuidd.socket @2.001s
                  └─sysinit.target @1.705s
                    └─systemd-timesyncd.service @850ms +854ms
                      └─systemd-tmpfiles-setup.service @822ms +21ms
                        └─local-fs.target @819ms
                          └─boot-efi.mount @806ms +12ms
                            └─systemd-fsck@dev-disk-by\x2duuid-0846\x2d9578.serv
                              └─local-fs-pre.target @769ms
                                └─keyboard-setup.service @152ms +616ms
                                  └─systemd-journald.socket @151ms
                                    └─system.slice @151ms
                                      └─-.slice @149ms
lines 2-24/24 (END)

User avatar
trytip
Level 9
Level 9
Posts: 2517
Joined: Tue Jul 05, 2016 1:20 pm

Re: Super slow boot :/

Post by trytip » Sun Nov 11, 2018 9:32 pm

these new bios settings are getting too advanced for anyone to know what they do. half that stuff goes way over my head.
Image

gil5587
Level 1
Level 1
Posts: 12
Joined: Sat Oct 27, 2018 8:01 am

Re: Super slow boot :/

Post by gil5587 » Sun Nov 11, 2018 9:47 pm

trytip wrote:
Sun Nov 11, 2018 9:32 pm
these new bios settings are getting too advanced for anyone to know what they do. half that stuff goes way over my head.
xD
well, anyway it's fine now.
Are there any other things that can be disabled from startup to make the boot time even faster?

I would like to know why I have so many boot options on bios and what is the correct one:
https://imgur.com/a/wVPs7qV

Also, another problem I have; when I log out or shut down the OS it takes a lot of time as well to do so... :cry:

User avatar
trytip
Level 9
Level 9
Posts: 2517
Joined: Tue Jul 05, 2016 1:20 pm

Re: Super slow boot :/

Post by trytip » Sun Nov 11, 2018 10:20 pm

i believe these are entries leftover from installing linux mint or ubuntu but i wouldn't know where to begin on removing them. sad fact is that if you install mint on a uefi system then you delete it the uefi entry still stays in your bios. EasyUEFI Free 2.7 may help but it's works in windows only and new versions are now premium or maybe the trial can help you once https://www.easyuefi.com/index-us.html

some shutdown debugging may help you https://freedesktop.org/wiki/Software/s ... /#index2h1
Image

User avatar
smurphos
Level 8
Level 8
Posts: 2258
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Super slow boot :/

Post by smurphos » Mon Nov 12, 2018 12:08 am

gil5587 wrote:
Sun Nov 11, 2018 8:39 pm

Code: Select all

Startup finished in 8.497s (firmware) + 11.230s (loader) + 4.501s (kernel) + 2.777s (userspace) = 27.007s
graphical.target reached after 2.771s in userspace
You should be able to knock off most of the (loader) time - viewtopic.php?f=42&t=280896

Re your slow shutdown if you can share the output of inxi -Fxz that so we've got a bit more info about your system that would be helpful. The output recorded in /var/logs/syslog* from a shutdown sequence would be helpful as-well. i think the shutdown debug script in trytip's link will provide the same output.

gil5587
Level 1
Level 1
Posts: 12
Joined: Sat Oct 27, 2018 8:01 am

Re: Super slow boot :/

Post by gil5587 » Mon Nov 12, 2018 10:25 am

smurphos wrote:
Mon Nov 12, 2018 12:08 am
gil5587 wrote:
Sun Nov 11, 2018 8:39 pm

Code: Select all

Startup finished in 8.497s (firmware) + 11.230s (loader) + 4.501s (kernel) + 2.777s (userspace) = 27.007s
graphical.target reached after 2.771s in userspace
You should be able to knock off most of the (loader) time - viewtopic.php?f=42&t=280896

Re your slow shutdown if you can share the output of inxi -Fxz that so we've got a bit more info about your system that would be helpful. The output recorded in /var/logs/syslog* from a shutdown sequence would be helpful as-well. i think the shutdown debug script in trytip's link will provide the same output.
WOW!
You're awesome!

Code: Select all

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Code: Select all

Startup finished in 6.568s (firmware) + 2.282s (loader) + 4.552s (kernel) + 3.271s (userspace) = 16.675s
graphical.target reached after 3.262s in userspace
Is there anything here I can disable?
Screenshot from 2018-11-12 16-21-00.png
About the slow shutdown/logout,
Seems like when steam is open it makes this delay..
Sadly, this issue is known since a few years ago, and still, I don't think there's a solution :c

User avatar
trytip
Level 9
Level 9
Posts: 2517
Joined: Tue Jul 05, 2016 1:20 pm

Re: Super slow boot :/

Post by trytip » Mon Nov 12, 2018 11:52 am

if you want to chisel more time off your user startup disable the
cinnamon settings daemon xrandr
flatpak
mint update

i think it's about time linux mint put some detailed descriptions on some of these startup items and if they can be disabled.
Image

Post Reply

Return to “Installation & Boot”