[SOLVED] No option for linux in dual boot; windows 10; legacy

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
trope
Level 3
Level 3
Posts: 194
Joined: Tue Feb 19, 2013 1:10 pm

[SOLVED] No option for linux in dual boot; windows 10; legacy

Post by trope » Sat Nov 17, 2018 2:31 pm

I have a new laptop with windows 10. I installed linux mint as a dual boot (19, tara), and the installation went fine. I made new logical partitions for it. However, when I reboot, it goes directly into Windows 10 and there is no option for linux mint. I do not have a windows 10 CD as it did not come with the laptop, so I have no option to reinstall windows. What I have tried so far:

Code: Select all

sudo update-grub
while in linux from the bootable usb, but I get the error message:
failed to get canonical path of '/cow'
I turned off the fast startup from Windows 10.

The laptop is set for legacy boot. I tried changing it to UEFI, but when rebooting, I get the error message "no bootable devices found." Not sure if I need to change some settings in the boot menu that would allow UEFI mode.

I tried to access UEFI settings in Windows 10 from advanced settings, but there is no option for UEFI settings.
Last edited by trope on Sun Nov 18, 2018 12:25 pm, edited 1 time in total.

User avatar
vansloneker
Level 4
Level 4
Posts: 313
Joined: Sat Mar 17, 2018 6:10 am

Re: No option for linux in dual boot; windows 10; legacy

Post by vansloneker » Sat Nov 17, 2018 3:04 pm

From my point of view you did best to install in legacy mode.
You can not just change the bios boot mode from legacy to uefi if there is no uefi disk in the system, or if you are not installing something in uefi.
And the same vice versa.

You wrote: " I made new logical partitions for it." Does this mean you followed the procedure of "something else" or "manual" and did not choose the installer option of installing Linux Mint alongside Windows 10?

Then I think, the bootloader is in an inappropriate place.

From where you are, just Windows booting, no Grub selection screen, I see only two options:
1 reinstall Mint and follow the installer suggestion to install alongside W10
2 run Boot Repair to fix the boot.
Unless stated otherwise Mint 18.3-64 XFCE

User avatar
administrollaattori
Level 15
Level 15
Posts: 5677
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: No option for linux in dual boot; windows 10; legacy

Post by administrollaattori » Sat Nov 17, 2018 4:22 pm

What laptop and how installed?

Code: Select all

inxi -Fxzop

Code: Select all

cat /proc/mdstat

Code: Select all

sudo parted -l

trope
Level 3
Level 3
Posts: 194
Joined: Tue Feb 19, 2013 1:10 pm

Re: No option for linux in dual boot; windows 10; legacy

Post by trope » Sun Nov 18, 2018 1:51 am

vansloneker wrote:
Sat Nov 17, 2018 3:04 pm

You wrote: " I made new logical partitions for it." Does this mean you followed the procedure of "something else" or "manual" and did not choose the installer option of installing Linux Mint alongside Windows 10?
I used gparted. There was a partition for boot and one for Windows 10. Since making 2 more primary partitions for linux mint and for a swap would use up all 4 partitions, I made an extended partition comprised of 2 logical partitions of which one is for linux mint + root and one is a swap. I then used the Mint installer and chose "something else", and selected the partition that I had set up in gparted. I got the advice to set up the partitions first in gparted here:
viewtopic.php?f=46&t=281712&p=1553579#p1553643

trope
Level 3
Level 3
Posts: 194
Joined: Tue Feb 19, 2013 1:10 pm

Re: No option for linux in dual boot; windows 10; legacy

Post by trope » Sun Nov 18, 2018 2:08 am

administrollaattori wrote:
Sat Nov 17, 2018 4:22 pm
What laptop and how installed?

Code: Select all

inxi -Fxzop

Code: Select all

cat /proc/mdstat

Code: Select all

sudo parted -l

Code: Select all

System:    Host: mint Kernel: 4.15.0-20-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Dell product: Latitude E5450 serial: N/A
           Mobo: Dell model: 0DCPV1 v: A00 serial: N/A
           UEFI [Legacy]: Dell v: A18 date: 01/03/2018
Battery    BAT0: charge: 38.0 Wh 81.5% condition: 46.7/52.4 Wh (89%)
           model: LGC-LGC3.4 DELL 8V5GX59 status: Discharging
CPU:       Dual core Intel Core i5-5300U (-MT-MCP-) 
           arch: Broadwell rev.4 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9179
           clock speeds: max: 2900 MHz 1: 968 MHz 2: 1103 MHz 3: 907 MHz
           4: 1117 MHz
Graphics:  Card: Intel HD Graphics 5500 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           version: 4.5 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card-1 Intel Broadwell-U Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Card-2 Intel Wildcat Point-LP High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Intel Ethernet Connection (3) I218-LM
           driver: e1000e v: 3.2.6-k port: f080 bus-ID: 00:19.0
           IF: eno1 state: down mac: <filter>
           Card-2: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 1008.0GB (1.7% used)
           ID-1: /dev/sda model: WDC_WD10SPCX size: 1000.2GB temp: 24C
           ID-2: USB /dev/sdb model: DT_Micro size: 7.7GB temp: 0C
Partition: ID-1: / size: 3.9G used: 68M (2%) fs: overlay dev: N/A
           ID-2: swap-1 size: 17.83GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Unmounted: ID-1: /dev/sda1 size: 0.37G fs: NTFS
           label: System uuid: C07C4F777C4F676E
           ID-2: /dev/sda2 size: 63.46G fs: NTFS
           label: Windows uuid: D6CC50A6CC5082A3
           ID-3: /dev/sda5 size: 31.46G
           label: N/A uuid: 88b0e9e1-f12f-4419-a19b-29dcff122f05
           ID-4: /dev/sdb1 size: 1.99G
           label: Linux Mint 19 MATE 64-bit uuid: 2018-07-17-12-34-23-00
           ID-5: /dev/sdb2 size: 0.00G fs: FAT (12 bit)
           label: N/A uuid: 044E-AC17
Sensors:   System Temperatures: cpu: 48.0C mobo: 25.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 179 Uptime: 1 min Memory: 442.4/7849.8MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
mint@mint:~$ cat /proc/mdstat
Personalities : 
unused devices: <none>
mint@mint:~$ sudo parted -l
Model: ATA WDC WD10SPCX-00K (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  368MB   367MB   primary   ntfs            boot
 2      368MB   63.8GB  63.5GB  primary   ntfs
 3      63.8GB  113GB   49.3GB  extended
 5      63.8GB  95.3GB  31.5GB  logical   ext4
 6      95.3GB  113GB   17.8GB  logical   linux-swap(v1)


Warning: The driver descriptor says the physical block size is 2048 bytes, but
Linux says it is 512 bytes.
Ignore/Cancel? i                                                          
Model: Kingston DT Micro (scsi)
Disk /dev/sdb: 31.0GB
Sector size (logical/physical): 2048B/512B
Partition Table: mac
Disk Flags: 

Number  Start   End     Size    File system  Name   Flags
 1      2048B   6143B   4096B                Apple
 2      1988MB  1990MB  2392kB               EFI

sda5 is where I installed mint.

User avatar
administrollaattori
Level 15
Level 15
Posts: 5677
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: No option for linux in dual boot; windows 10; legacy

Post by administrollaattori » Sun Nov 18, 2018 8:23 am

For making sure that Legacy Grub will be installed, run via liveDVD or USB

Code: Select all

sudo mount /dev/sda5 /mnt
sudo grub-install --boot-directory=/mnt/boot /dev/sda
sudo umount /mnt
PS. Iqnore cow messages. :wink:

trope
Level 3
Level 3
Posts: 194
Joined: Tue Feb 19, 2013 1:10 pm

Re: [SOLVED] No option for linux in dual boot; windows 10; legacy

Post by trope » Sun Nov 18, 2018 12:26 pm

It worked, thanks!

User avatar
vansloneker
Level 4
Level 4
Posts: 313
Joined: Sat Mar 17, 2018 6:10 am

Re: No option for linux in dual boot; windows 10; legacy

Post by vansloneker » Sun Nov 18, 2018 2:06 pm

administrollaattori wrote:
Sun Nov 18, 2018 8:23 am
...

PS. Iqnore cow messages. :wink:
It wasn't addressed to me but I don't understand this?
Unless stated otherwise Mint 18.3-64 XFCE

User avatar
administrollaattori
Level 15
Level 15
Posts: 5677
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: No option for linux in dual boot; windows 10; legacy

Post by administrollaattori » Sun Nov 18, 2018 2:13 pm

vansloneker wrote:
Sun Nov 18, 2018 2:06 pm
administrollaattori wrote:
Sun Nov 18, 2018 8:23 am
...

PS. Iqnore cow messages. :wink:
It wasn't addressed to me but I don't understand this?
I meant
failed to get canonical path of '/cow'

User avatar
vansloneker
Level 4
Level 4
Posts: 313
Joined: Sat Mar 17, 2018 6:10 am

Re: [SOLVED] No option for linux in dual boot; windows 10; legacy

Post by vansloneker » Sun Nov 18, 2018 2:23 pm

I get it, thanks.
Unless stated otherwise Mint 18.3-64 XFCE

Post Reply

Return to “Installation & Boot”