Mint 19 on Fujitsu Siemens AMILO La 1703

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Sat Nov 24, 2018 1:32 pm

administrollaattori wrote:
Sat Nov 24, 2018 1:08 pm
mhenriday wrote:
Sat Nov 24, 2018 12:52 pm
The major problem seems to lie here ; how can I activate this unit ?...
You need to export when the pin is correct
Image
Copy that exported file into /etc for example, and make that sound.py startable via systemd. I am not quite sure if the line should be

Code: Select all

[Service]
Type=oneshot
ExecStart=/etc/sound.py
... or

Code: Select all

[Service]
Type=oneshot
ExecStart=cd /etc && ./sound.py
When I click Exp in the HDA Analyzer toolbar, a small box entitled Export to Python script appears with «# No chang» in a narrow box and two buttons, «OK» and «Save as» from which to choose. Which of these two should I select, and how should I proceed thereafter in order to copy the file into /etc and make sound.py startable via systemd ?...

Henri

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by administrollaattori » Sat Nov 24, 2018 1:42 pm

mhenriday wrote:
Sat Nov 24, 2018 1:32 pm
When I click Exp in the HDA Analyzer toolbar, a small box entitled Export to Python script appears with «# No chang» in a narrow box and two buttons, «OK» and «Save as» from which to choose. Which of these two should I select, and how should I proceed thereafter in order to copy the file into /etc and make sound.py startable via systemd ?...
I have not installed HDA Analyzer in this computer, but when exporting, the file should go into your home directory. If that file is workable, sounds should work. You can test it like running sudo ./sound.py and test sounds via Sound Settings
sound settings.png

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Sat Nov 24, 2018 2:49 pm

administrollaattori wrote:
Sat Nov 24, 2018 1:42 pm
mhenriday wrote:
Sat Nov 24, 2018 1:32 pm
When I click Exp in the HDA Analyzer toolbar, a small box entitled Export to Python script appears with «# No chang» in a narrow box and two buttons, «OK» and «Save as» from which to choose. Which of these two should I select, and how should I proceed thereafter in order to copy the file into /etc and make sound.py startable via systemd ?...
I have not installed HDA Analyzer in this computer, but when exporting, the file should go into your home directory. If that file is workable, sounds should work. You can test it like running sudo ./sound.py and test sounds via Sound Settings
sound settings.png
Running sudo ./run.py and then clicking the Exp button gives me the following :
Exporterar_från_HDAAnalyzer_2018-11-24_19-24-44.png
- in the terminal itself I see :
Terminalavbild_2018-11-24 _9-34-46.png
Terminalavbild_2018-11-24 _9-34-46.png (22.15 KiB) Viewed 372 times
Alas, if I click OK in the former, nothing changes with respect to my sound hardware ; I still see :
Ljudinställningar_2018-11-24_17-32-22.png
Ljudinställningar_2018-11-24_17-32-22.png (25.63 KiB) Viewed 372 times
i e, my sound card remains inactivated. Unfortunately, I haven't been able to figure out where to go from here....

Henri

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by administrollaattori » Sat Nov 24, 2018 4:20 pm

mhenriday wrote:
Sat Nov 24, 2018 2:49 pm
my sound card remains inactivated. Unfortunately, I haven't been able to figure out where to go from here....
'
Run alsamixer and see if there is something muted, etc. Install also pavucontrol and see what options it can do. Command aplay -l tells audio devices. Rebooting can help also. :wink:

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Sun Nov 25, 2018 9:21 am

administrollaattori wrote:
Sat Nov 24, 2018 4:20 pm
mhenriday wrote:
Sat Nov 24, 2018 2:49 pm
my sound card remains inactivated. Unfortunately, I haven't been able to figure out where to go from here....
'
Run alsamixer and see if there is something muted, etc.
Alsamixer_2018-11-25_13-41-43.png
Unable to make any adjustments here.
Install also pavucontrol and see what options it can do.
Pavucontrol_2018-11-25_13-49-15.png

Note that under «Ouput units» only a «dummy output» is listed ; when I request that hardware output units be shown, I'm told that none such are
available :
Pavucontrol_2018-11-25_13-50-55.png
Command aplay -l tells audio devices.
**** Lista över PLAYBACK hårdvaruenheter ****
kort 0: VT82xx [HDA VIA VT82xx], enhet 0: VT1708 Analog [VT1708 Analog]
Underordnade enheter: 1/1
Underordnad enhet nr. 0: subdevice #0
kort 0: VT82xx [HDA VIA VT82xx], enhet 6: Si3054 Modem [Si3054 Modem]
Underordnade enheter: 1/1
Underordnad enhet nr. 0: subdevice #0
Rebooting can help also. :wink:
I'm a past master at rebooting, but alas, here my efforts have not sufficed.... :(

Henri

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by administrollaattori » Sun Nov 25, 2018 11:03 am

La 1703's problem is that sounds are coming from headphones. You could plug headphones in and test if there comes sounds. If not, install alsa-tools-gui and run hdajackretask

Image

If that does not help, reinstall alsa
https://help.ubuntu.com/community/Sound ... gProcedure

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Sun Nov 25, 2018 4:13 pm

administrollaattori wrote:
Sun Nov 25, 2018 11:03 am
La 1703's problem is that sounds are coming from headphones. You could plug headphones in and test if there comes sounds.
No sound.
If not, install alsa-tools-gui and run hdajackretask

Image
My set up differs somewhat from the above ; I tried the following settings :
HDA-jack_retask_2018-11-25_20-52-00.png
but no joy, with or without headphones....
If that does not help, reinstall alsa
https://help.ubuntu.com/community/Sound ... gProcedure
Get back to this one tomorrow ! Skam den som ger sig !....

Henri

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by administrollaattori » Sun Nov 25, 2018 4:53 pm

Take X off from internal speaker and apply. :wink:

I tested in this Lenovo, and if X was on, sound disappeared.
speaker.png

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Wed Nov 28, 2018 1:48 pm

administrollaattori wrote:
Sun Nov 25, 2018 4:53 pm
Take X off from internal speaker and apply. :wink:

I tested in this Lenovo, and if X was on, sound disappeared.
speaker.png
I must confess, administratollaattori, that I don't quite grasp what you mean here by
Take X off from internal speaker and apply.
After reinstalling alsa, (I followed the instructions found here) and finding - to my dismay, if not to my surprise - that sound had not been restored, I then ran hdajackretask, which indicated that none of the following pins - all those listed - were connected : 0x1d, 0x1e, 0x1f, 0x20, ox21, 0x22, 0x23, 0x24, 0x25. 0x26. Which of them - if, indeed, any - should I override in order to get the sound working ?...

Henri

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by administrollaattori » Wed Nov 28, 2018 3:24 pm

mhenriday wrote:
Wed Nov 28, 2018 1:48 pm
I must confess, administratollaattori, that I don't quite grasp what you mean here by
Take X off from internal speaker and apply.
If X is in the box - device is off, if there is no X in the box _ - device is on.

Edit: What tells

Code: Select all

pacmd list-sinks

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Thu Nov 29, 2018 1:17 pm

administrollaattori wrote:
Wed Nov 28, 2018 3:24 pm
mhenriday wrote:
Wed Nov 28, 2018 1:48 pm
I must confess, administratollaattori, that I don't quite grasp what you mean here by
Take X off from internal speaker and apply.
If X is in the box - device is off, if there is no X in the box _ - device is on.
Again, I'm not sure to just what box you are referring, If you mean the little box entitled Override under each listed pin, removing the X and applying the settings there gives me the following :
HDA-jack_retasking_2018-11-29_18-00-08.png
in which relevant pins, e g, ox1c (internal speaker) and t0x20 (green headphone front), do seem to be connected. However. I still get no sound....
Edit: What tells

Code: Select all

pacmd list-sinks
After running

Code: Select all

pacmd list-sinks
I see
pacmd_list-sinks_2018-11-29_17-18-41.png
Note that state is given as SUSPEND, suspend cause as IDLE, and device.description under properties as "Attrapputgång" (Dummy ouput). Herein, I suspect lies the problem, but how can I modify the settings so as to turn a dummy output into a real one ?...

Henri

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Thu Nov 29, 2018 1:58 pm

mhenriday wrote:
Thu Nov 29, 2018 1:17 pm
administrollaattori wrote:
Wed Nov 28, 2018 3:24 pm
mhenriday wrote:
Wed Nov 28, 2018 1:48 pm
I must confess, administratollaattori, that I don't quite grasp what you mean here by
Take X off from internal speaker and apply.
If X is in the box - device is off, if there is no X in the box _ - device is on.
Again, I'm not sure to just what box you are referring, If you mean the little box entitled Override under each listed pin, removing the X and applying the settings there gives me the following :HDA-jack_retasking_2018-11-29_18-00-08.png
in which relevant pins, e g, ox1c (internal speaker) and t0x20 (green headphone front), do seem to be connected. However. I still get no sound....
Edit: What tells

Code: Select all

pacmd list-sinks
After running

Code: Select all

pacmd list-sinks
I seepacmd_list-sinks_2018-11-29_17-18-41.png
Note that state is given as SUSPEND, suspend cause as IDLE, and device.description under properties as "Attrapputgång" (Dummy ouput). Herein, I suspect lies the problem, but how can I modify the settings so as to turn a dummy output into a real one ?...

Henri
Update : after checking once again, I see now that some settings have indeed changed ; cf the following two screenshots which display the results of running

Code: Select all

pacmd list-sinks
pacmd_list-sinks_2018-11-29_18-44-10.png
and
pacmd_list-sinks_2018-11-29_18-49-10.png
with that above. Even the information listed for hardware under sound settings has changed -
Ljudinställningar_hårdvara_2018-11-29_18-36-03.png
and the hardware now seem to be activated, but when I test my speakers, I still don't get a peep....

Frustrating ! :(

Henri

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by administrollaattori » Thu Nov 29, 2018 2:39 pm

mhenriday wrote:
Thu Nov 29, 2018 1:58 pm
the hardware now seem to be activated, but when I test my speakers, I still don't get a peep....
Output for pacmd list-sinks | grep analog ?

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Thu Nov 29, 2018 3:08 pm

administrollaattori wrote:
Thu Nov 29, 2018 2:39 pm
mhenriday wrote:
Thu Nov 29, 2018 1:58 pm
the hardware now seem to be activated, but when I test my speakers, I still don't get a peep....
Output for pacmd list-sinks | grep analog ?
pacmd_list-sinks_grep_analog_2018-11-29_20-03-24.png
Henri

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Fri Nov 30, 2018 10:16 am

mhenriday wrote:
Thu Nov 29, 2018 3:08 pm
administrollaattori wrote:
Thu Nov 29, 2018 2:39 pm
mhenriday wrote:
Thu Nov 29, 2018 1:58 pm
the hardware now seem to be activated, but when I test my speakers, I still don't get a peep....
Output for pacmd list-sinks | grep analog ?
pacmd_list-sinks_grep_analog_2018-11-29_20-03-24.png

Henri
What result should I have expected from performing pacmd list-sinks | grep analog, administrollaattori ? If I do so on my main box, I see the following :
pacmd_list-sinks_grep_analog_2018-11-30_14-57-30.png
Henri

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by administrollaattori » Fri Nov 30, 2018 12:29 pm

How about if you boot using Mint 17.2 Mate liveUSB or DVD and make a sound.py file and copy that file into your installed system?
viewtopic.php?f=42&t=201165&p=1045621#p1045621

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Tue Dec 04, 2018 1:14 pm

administrollaattori wrote:
Fri Nov 30, 2018 12:29 pm
How about if you boot using Mint 17.2 Mate liveUSB or DVD and make a sound.py file and copy that file into your installed system?
viewtopic.php?f=42&t=201165&p=1045621#p1045621
I've gone back to your original instructions on setting Node [0x26]PIN and exporting the file
pyscript_2018-12-04_17-31-37.png
and then saving it under /etc
Filen_sound-py_2018-12-04_17-34-39.png
As seen here,
Sound-py_2018-12-04_18-05-32.png
the file was indeed saved under /etc (but not, nota bene, in subdirectory systemd). Were these measures you had in mind ; i e have I understood your instructions aright?...

If, Indeed, I have done so, the question becomes whether I should execute

Code: Select all

[Service]
Type=oneshot
ExecStart=/etc/sound.py
or

Code: Select all

[Service]
Type=oneshot
ExecStart=cd /etc && ./sound.py
Which do you suggest I try to make sound.py startable via systemd ?...

Again, many, many thanks for all your help. I hope to resolve the sound problem before Tuesday, 11 December, when I've promised to deliver the machine to its owner....

Henri

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Wed Dec 05, 2018 4:24 am

mhenriday wrote:
Tue Dec 04, 2018 1:14 pm
If, Indeed, I have done so, the question becomes whether I should execute

Code: Select all

[Service]
Type=oneshot
ExecStart=/etc/sound.py
or

Code: Select all

[Service]
Type=oneshot
ExecStart=cd /etc && ./sound.py
Which do you suggest I try to make sound.py startable via systemd ?...

Again, many, many thanks for all your help. I hope to resolve the sound problem before Tuesday, 11 December, when I've promised to deliver the machine to its owner....

Henri
I've considered attempting to perform the actions above one after the other ; i e, if the first one doesn't work, try the second - but had to give up, as I don't know exactly what I should do - is it simply a matter of copying one of the code sequences above in a terminal and pressing «Enter» (only the last line looks like the type of command with which I am familiar) or is there something else that has to be done ?...

Henri

User avatar
administrollaattori
Level 15
Level 15
Posts: 5881
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by administrollaattori » Thu Dec 06, 2018 8:31 am

mhenriday wrote:
Wed Dec 05, 2018 4:24 am
I've considered attempting to perform the actions above one after the other ; i e, if the first one doesn't work, try the second - but had to give up, as I don't know exactly what I should do - is it simply a matter of copying one of the code sequences above in a terminal and pressing «Enter» (only the last line looks like the type of command with which I am familiar) or is there something else that has to be done ?...
An another choice is to add the script to the root crontab. An example:

Code: Select all

sudo crontab -e
.... add a line

Code: Select all

@reboot cd /etc && ./sound.py
... save and quit
Ctrl o
Ctrl x

User avatar
mhenriday
Level 4
Level 4
Posts: 211
Joined: Sun Jan 15, 2012 3:56 pm
Location: Stockholm

Re: Mint 19 on Fujitsu Siemens AMILO La 1703

Post by mhenriday » Thu Dec 06, 2018 10:00 am

administrollaattori wrote:
Thu Dec 06, 2018 8:31 am
mhenriday wrote:
Wed Dec 05, 2018 4:24 am
I've considered attempting to perform the actions above one after the other ; i e, if the first one doesn't work, try the second - but had to give up, as I don't know exactly what I should do - is it simply a matter of copying one of the code sequences above in a terminal and pressing «Enter» (only the last line looks like the type of command with which I am familiar) or is there something else that has to be done ?...
An another choice is to add the script to the root crontab. An example:

Code: Select all

sudo crontab -e
.... add a line

Code: Select all

@reboot cd /etc && ./sound.py
... save and quit
Ctrl o
Ctrl x
As this screen shot
crontab_2018-12-06_14-19-36.png
shows, administrollaattori, I was able to use GNU nano 2.9.3 to add the sequence

Code: Select all

@reboot cd /etc && ./sound.py[
to crontab, save and exit, but in the process the name of the file was changed by default to /tmp/crontabzXbL6g/crontab/. In any event rebooting did not provide me with sound and the HDA Controller has been switched off :
HDA_Controller_2018-12-06 _14-39-28.png
and Output is now once again a dummy :
Output_2018-12-06 _4-41-06.png
Almost back to square one ; how do you suggest I can turn the HDA Controller on and make the Output real ? Unfortunately, the three-attachment limit prevents me from here showing what I see on performing

Code: Select all

pacmd list-sinks
but in the event it would be of interest, I can do so in a new post to this thread....

Henri
Last edited by mhenriday on Fri Dec 07, 2018 9:16 am, edited 1 time in total.

Post Reply

Return to “Installation & Boot”