Page 1 of 2

Linux 19.1 - Screen Blinks...

Posted: Thu Dec 20, 2018 8:47 am
by mottechy
Hallo,
I have updated my Linux Mint 19 to 19.1 today.
But after the installation, the screen blinks all the time.
Any solution?

Re: Linux 19.1 - Screen Blinks...

Posted: Thu Dec 20, 2018 9:37 am
by hpmc13
I don't have a solution for you but I have the same problem I think. On mine anything that I touch flickers and blinks repeatedly - including the text that I'm now trying to type. If i right-click on the desktop then highlight anything it blinks repeatedly. Trying to watch video is hideous.

Code: Select all

System:    Host: workpc Kernel: 4.15.0-43-generic x86_64 bits: 64 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.8 
           Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> 
           Mobo: Gigabyte model: 990FXA-UD3 R5 v: x.x serial: <filter> BIOS: American Megatrends v: F2 date: 04/01/2015 
CPU:       Topology: 8-Core model: AMD FX-8350 bits: 64 type: MCP arch: Bulldozer L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 70726 
           Speed: 1947 MHz min/max: 1400/4400 MHz Core speeds (MHz): 1: 1405 2: 1405 3: 1406 4: 1406 5: 1406 6: 1405 7: 1406 
           8: 1398 
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: ZOTAC driver: nvidia v: 415.23 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.6 driver: nvidia resolution: 1280x1024~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 415.23 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Device-2: NVIDIA vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k4.15.0-43-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: 2.3LK-NAPI 
           port: c000 bus ID: 05:00.0 
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.31 TiB used: 592.77 GiB (44.2%) 
           ID-1: /dev/sda model: ZOTAC ZTSSD-A4P-120G size: 111.79 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-60WN4A0 size: 931.51 GiB 
           ID-3: /dev/sdc vendor: Western Digital model: WD3200AAJS-22B4A0 size: 298.09 GiB 
Partition: ID-1: / size: 29.34 GiB used: 15.37 GiB (52.4%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 28.84 GiB used: 6.38 GiB (22.1%) fs: ext4 dev: /dev/sda2 
           ID-3: swap-1 size: 1.99 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 33.0 C mobo: 30.0 C gpu: nvidia temp: 44 C 
           Fan Speeds (RPM): cpu: 0 fan-1: 774 fan-3: 0 fan-4: 1442 fan-5: 0 gpu: nvidia fan: 0% 
           Voltages: 12v: N/A 5v: N/A 3.3v: N/A vbat: 3.10 
Info:      Processes: 261 Uptime: 11m Memory: 15.63 GiB used: 1.45 GiB (9.3%) Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 
           Shell: bash v: 4.4.19 inxi: 3.0.27 
Upgraded Nvidia drivers, no change. Rebooted a couple times. Will have to Timeshift back to 19.

Re: Linux 19.1 - Screen Blinks...

Posted: Thu Dec 20, 2018 9:43 am
by Jarew
Same problem with screen blinking after 19.1 upgrade. Nvidia GT1030 graphics card. Thank goodness for timeshift.

Re: Linux 19.1 - Screen Blinks...

Posted: Thu Dec 20, 2018 9:53 am
by TheBlueRaja
Same issue here - Nvidia 1080 - Timeshifted back.

Re: Linux 19.1 - Screen Blinks...

Posted: Thu Dec 20, 2018 2:00 pm
by hpmc13
I HAVE NOT TRIED THIS since I timeshifted back to 19, but this was in the comments in the announcement page:

For anyone getting a bunch of window flickering after the upgrade who is using the proprietary NVIDIA driver, try turning “allow flipping” off in the openGL settings in the NVIDIA settings panel.

I might have a go at it later.

Re: Linux 19.1 - Screen Blinks...

Posted: Thu Dec 20, 2018 2:40 pm
by hpmc13
**Update From Below**
Turning all of that off introduced screen tearing on my system. Long story short, what I found is that turning both Allow Flipping in Nvidia-settings and Enable VBlank in General Settings, then right-clicking the task bar, hitting Troubleshooting, then Restart Cinnamon makes it all good. You've got to do that each time you reboot, but it solves the problem for now ... at least for me. Your mileage may vary.

Decided to not wait. This does help drastically, but didn't quite solve it - I still had some artifacts when I resized windows. Then I went into System Settings -> General and turned off Enable VBlank and the flickering is gone. However, I think (though I'm not sure) that that last setting is what enables V-Sync which may introduce more issues. Proceed at your own risk.

Re: Linux 19.1 - Screen Blinks...

Posted: Thu Dec 20, 2018 5:47 pm
by mottechy
I think I will wait till the issue is solved...
In these days I need my Laptop at good working condition.
So no time to test...
Update please, if it is really solved.
thanks
hpmc13 wrote:
Thu Dec 20, 2018 2:40 pm
**Update From Below**
Turning all of that off introduced screen tearing on my system. Long story short, what I found is that turning both Allow Flipping in Nvidia-settings and Enable VBlank in General Settings, then right-clicking the task bar, hitting Troubleshooting, then Restart Cinnamon makes it all good. You've got to do that each time you reboot, but it solves the problem for now ... at least for me. Your mileage may vary.

Decided to not wait. This does help drastically, but didn't quite solve it - I still had some artifacts when I resized windows. Then I went into System Settings -> General and turned off Enable VBlank and the flickering is gone. However, I think (though I'm not sure) that that last setting is what enables V-Sync which may introduce more issues. Proceed at your own risk.

Re: Linux 19.1 - Screen Blinks...

Posted: Fri Dec 21, 2018 4:12 am
by Piyush_Raut
I logged out and selected the desktop environment as cinnamon (software rendering) on the login screen. After I logged in, my problem was solved. No more screen flickering.

Re: Linux 19.1 - Screen Blinks...

Posted: Fri Dec 21, 2018 5:37 am
by mottechy
Must be repeated every time? Or only once?
Piyush_Raut wrote:
Fri Dec 21, 2018 4:12 am
I logged out and selected the desktop environment as cinnamon (software rendering) on the login screen. After I logged in, my problem was solved. No more screen flickering.

Re: Linux 19.1 - Screen Blinks...

Posted: Fri Dec 21, 2018 9:48 am
by Piyush_Raut
mottechy wrote:
Fri Dec 21, 2018 5:37 am
Must be repeated every time? Or only once?
Piyush_Raut wrote:
Fri Dec 21, 2018 4:12 am
I logged out and selected the desktop environment as cinnamon (software rendering) on the login screen. After I logged in, my problem was solved. No more screen flickering.
You need to do it only once. It is automatically selected as default option from next time.
Also, the performance is affected in software rendering.

Re: Linux 19.1 - Screen Blinks...

Posted: Fri Dec 21, 2018 11:37 am
by Yfrwlf
hpmc13 wrote:
Thu Dec 20, 2018 2:00 pm
I HAVE NOT TRIED THIS since I timeshifted back to 19, but this was in the comments in the announcement page:

For anyone getting a bunch of window flickering after the upgrade who is using the proprietary NVIDIA driver, try turning “allow flipping” off in the openGL settings in the NVIDIA settings panel.

I might have a go at it later.
I was the one who reported that, and was surprised to not find anyone else with the same problem until now, and as others have reported that just fixes the flickering but you still have screen tearing. Software rendering isn't a solution if you use the system to play high-end videos or for gaming. Tried everything I could think of and didn't get it to work. Meanwhile, on another system with a NVIDIA card, everything worked perfectly and the upgrade to 19.1 went without a hitch. Very odd that only specific hardware may be effected by this. This is my situation so far:

4K monitor running the desktop @4K connected over Display Port to a GTX 1070 working just fine after upgrading to 19.1.

4K monitor running the desktop @1080p connected over HDMI to a GTX 970 having the flicker or no v-sync problem.

Trying a reinstall to make absolutely sure it's not some configuration issue.

Re: Linux 19.1 - Screen Blinks...

Posted: Fri Dec 21, 2018 3:27 pm
by hpmc13
I'm running a GTX 960 through HDMI with a second monitor through DVI that's having the problem. I don't have another system that I can try it on, but I can try it in live mode, or unplug monitors to test.

Each time I boot I just restart Cinnamon and it's perfectly fine - none of the other settings seem to matter as far as the flickering goes. Allow flipping OFF seems to alleviate it a bit, and turning off Enable VBlank doesn't change anything unless your restart Cinnamon anyway. So now I have Allow Flipping OFF, Enable VBlank ON, and I'm restarting Cinnamon on each boot, which is a PITA, but not all that bad. No flickering, no screen-tearing.

Re: Linux 19.1 - Screen Blinks...

Posted: Fri Dec 21, 2018 6:56 pm
by Yfrwlf
After reinstalling Mint 19.1 including the proprietary NVIDIA driver, the problem is gone.

Would someone please try opening mintwelcome or "Welcome Screen" as it's called in the menu, and go to "First Steps" and try selecting the "traditional" or "modern" desktop layouts and see if either of those fix the problem? Because I have a sneaky suspicion that will take care of it, that there is some weird configuration cruft being leftover after upgrades that isn't getting cleaned out for certain configurations that is causing this problem.

Re: Linux 19.1 - Screen Blinks...

Posted: Sat Dec 22, 2018 8:21 am
by mottechy
Good news (at least here)...
It seems the problem is fixed.
I updated the system in to 19.1 and everything is working fine...(till now..)
Hope it is the same result for you all...
Have a good Christmas time...with Mint 19.1 :) :D

Re: :Solved: Linux 19.1 - Screen Blinks... :Solved:

Posted: Tue Dec 25, 2018 11:55 am
by benchrest
I'm having the problem with dual monitors and both modern and traditional desktop. My laptop does not have the problem with single screen and traditional desktop. But my laptop does not have nvidia where as my desktop has GTX 1050ti. I guess I need to use the modern through I dislike the look as GRAMPS locks up the system using traditional desktop. Reminds me of someone telling me I can keep my insurance if I like it. I am also having some other issues so after finishing a project I am working on I may reinstall 19.0 fresh. Timeshift only works if one realizes they have problems right away.
I thought I could use traditional except when uses GRAMPS switch to modern. But it seems to lose its setting and I have to reconfigure after switching.

Re: Linux 19.1 - Screen Blinks...

Posted: Thu Dec 27, 2018 11:10 pm
by ScottMayo
Recently installed Mint 19.1 on a laptop. I7 processors, Intel HD Graphics 530 graphics. No nvidia here. Flickering and rectangular blackouts are nearly nonstop on the second monitor.

The irony is, I'd finally told all my friends that Linux was finally ready for prime time and they could all dump Windows.

Workaround would be interesting but this is a plea to fix this as fast as possible. There's obviously a significant bug is generating the screen image - the blacked out rectangles generally correspond to edges of existing windows. The flickering screams "buffering problem". It's widely reproducible. This one can't be that hard?

Re: Linux 19.1 - Screen Blinks...

Posted: Fri Dec 28, 2018 12:06 pm
by benchrest
Glad to see I'm not the only one with issues. But I bought the bullet yesterday and reinstalled LM 19 Cinnamon on my desktop and laptop. I also scratched my home directory and copied just my document, .mozzila and .thunderbird file to it. Ridding me of .config and other such configuration files to be recreated from scratch. So far so good. Have not got my server software setup yet but feel pretty good at this point. I think the new modern look and maintaining the traditional to work like it did is very important now. Hope the problems get priority over adding more new function.
But please don't do like me and upgrade for upgrades sake especially when you have a lot of work to get done.

Re: Linux 19.1 - Screen Blinks...

Posted: Mon Dec 31, 2018 8:36 am
by VtPoet
//Would someone please try opening mintwelcome or "Welcome Screen" as it's called in the menu, and go to "First Steps" and try selecting the "traditional" or "modern" desktop layouts and see if either of those fix the problem? //

Hi Yfrwlf, this is the first thing I tried. The flickering was severe immediately after the upgrade. I opened the welcome screen and switched to the "modern" desktop. This didn't help. I then rebooted into the modern desktop. Still, just as bad. It was only after alt-f2+r that the problem went away. The laptop was sleeping last night, then woke up this morning, still no problems. So, on my system at least, rebooting the Cinnamon DE (as opposed to the laptop) fixes the problem. Kind of a work around....

Re: Linux 19.1 - Screen Blinks...

Posted: Mon Dec 31, 2018 12:31 pm
by Yfrwlf
VtPoet wrote:
Mon Dec 31, 2018 8:36 am
//Would someone please try opening mintwelcome or "Welcome Screen" as it's called in the menu, and go to "First Steps" and try selecting the "traditional" or "modern" desktop layouts and see if either of those fix the problem? //

Hi Yfrwlf, this is the first thing I tried. The flickering was severe immediately after the upgrade. I opened the welcome screen and switched to the "modern" desktop. This didn't help. I then rebooted into the modern desktop. Still, just as bad. It was only after alt-f2+r that the problem went away. The laptop was sleeping last night, then woke up this morning, still no problems. So, on my system at least, rebooting the Cinnamon DE (as opposed to the laptop) fixes the problem. Kind of a work around....
Try creating a new user and see if the problem still exists? That will at least confine the issue to the system config or user config. Again, if you get sick of it, you can always try reinstalling which seems to be one way of solving it! I'm not sure what ALT-F2 then r does, reset the window manager? "r" isn't an alias or command in the terminal so it must be some special window manager command. If creating a new user fixes it, you could compare all the configuration files between the two users. If it doesn't fix it, it's probably a system config file so you'd have to compare all system files against a freshly installed system to find the difference.

Re: Linux 19.1 - Screen Blinks...

Posted: Mon Dec 31, 2018 1:18 pm
by VtPoet
Thanks Yfrwif, over at the Linux Mint Blog, where you also posted a comment, a possible solution was mentioned further down:
Everything works fine by removing the (useless option ?) “CLUTTER_PAINT=disable-clipped-redraws:disable-culling” in the /etc/environment file and after the upgrade.
I've tried that but haven't rebooted yet.

//I'm not sure what ALT-F2 then r does, reset the window manager?//

Yes, it reboots/resets the window manager. It's a Cinnamon specific command that simply requires typing "r" into the Alt-F2 window. The fact that this works makes me think it's user independent. I'm tempted to think that there's something in the initial boot routine (a holdover) that is being improperly invoked. Resetting the window manager, I assume, bypasses this initial boot sequence, so the correct settings are invoked. But this is all above my pay grade. And I still haven't tested with the CLUTTER_PAINT variable commented out.