[SOLVED] Linux Mint 19.1 Installer Type selection not working

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
[Jonathan_C_Linux]
Level 1
Level 1
Posts: 21
Joined: Fri Dec 28, 2018 9:30 pm
Location: Pleasanton, California

[SOLVED] Linux Mint 19.1 Installer Type selection not working

Post by [Jonathan_C_Linux] »

This is my first experience with Linux. I have a brand new Acer Nitro AN515-53 with a I5-8300 CPU and 8 GB of RAM running Windows 10. The only stuff on it either came preloaded or was necessary to install Linux. I can boot Linux from the USB without any problems. I am attempting to completely replace windows 10 with Mint 19.1 Cinnamon and am unconcerned about any data loss that will occur. I downloaded the ISO from (University of Washington, Mathematics). The installer works normally, select language, keyboard, download third party drivers. But when I get to the installation type section it immediately displays the screen for manually partitioning the drive as if I had selected "Something Else". I cannot access the normal Installation Type section and I have very little knowledge about partitioning a drive.
Last edited by [Jonathan_C_Linux] on Sun Dec 30, 2018 2:57 am, edited 2 times in total.

User avatar
Pierre
Level 20
Level 20
Posts: 10279
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Linux Mint 19.1 Installer Type selection not working

Post by Pierre »

has that Acer got the 1Tb Sata drive installed ?

if so, then initially use Gparted, in the Administration section, of the LinuxMint Live Media,
to pre-prepare that drive, with a set of say, 2 - 3 Linux ext4 partitions on it.
- - since you are not interested in keeping the win-10, then use Gparted to delete the windows partitions, first.
then see if the Linux installer will now recognise the new partitions.

BTW: even though you don't plan on using the existing Windows System,
- you should Back It Up, by creating an Restore Backup by using the existing Acer Backup Program
Just In Case - - as you just never know ..
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

[Jonathan_C_Linux]
Level 1
Level 1
Posts: 21
Joined: Fri Dec 28, 2018 9:30 pm
Location: Pleasanton, California

Re: Linux Mint 19.1 Installer Type selection not working

Post by [Jonathan_C_Linux] »

No, unfortunately my computer currently has the 256 GB SSD installed.

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: Linux Mint 19.1 Installer Type selection not working

Post by gm10 »

[Jonathan_C_Linux] wrote:
Fri Dec 28, 2018 9:55 pm
when I get to the installation type section it immediately displays the screen for manually partitioning the drive as if I had selected "Something Else". I cannot access the normal Installation Type section and I have very little knowledge about partitioning a drive.
I'd have to look up the installer's code to see why it would do that - I would expect this only when it cannot find an automatic partitioning scheme that works. Does it show the full 256 GB, i.e. all partitions, when in that "Something else" view? There are situations like Windows with active fast boot and/or hibernation that will usually cause it to stay away from those respective partitions to prevent data loss, that's why I'm asking. There's also situations where there SSD is in RAID mode, but then you typically won't get to access any partition at all.

I agree with Pierre insofar as you can delete all existing partitions externally (with the Disks or GParted tools available via the Mint menu) before running the installer. No need to create the partitions manually though, once you wiped everything just run the installer and it should show you the automatic option again.

[Jonathan_C_Linux]
Level 1
Level 1
Posts: 21
Joined: Fri Dec 28, 2018 9:30 pm
Location: Pleasanton, California

Re: Linux Mint 19.1 Installer Type selection not working

Post by [Jonathan_C_Linux] »

The only drive displayed is /dev/sda , which is the flash drive the ISO is loaded on.

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: Linux Mint 19.1 Installer Type selection not working

Post by gm10 »

So probably the RAID situation. Switch it the mode to AHCI in the UEFI (or Auto/Standard or whatever your UEFI may call it as long as it's not RAID) and then boot to the USB again and run

Code: Select all

sudo dmraid -Er /dev/sdX
(instead of /dev/sdX use the correct designation of the SSD, lsblk or sudo parted -l to find out)

After that you should be able to see the drive in the installer (if not try rebooting first, but should not be necessary).

[Jonathan_C_Linux]
Level 1
Level 1
Posts: 21
Joined: Fri Dec 28, 2018 9:30 pm
Location: Pleasanton, California

Re: Linux Mint 19.1 Installer Type selection not working

Post by [Jonathan_C_Linux] »

I was able to change the SATA mode from RST to AHCI in the UEFI menu. Installer now performs normally.

Post Reply

Return to “Installation & Boot”