Was I limited to 32 bit 19.1?

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Level 3
Level 3
Posts: 189
Joined: Fri May 27, 2011 7:09 pm

Was I limited to 32 bit 19.1?

Post by tpprynn »

I have installed Linux Mint 19.1 Cinnamon edition on a Lenovo Ideapad 120S. I had struggled with the EUFI business with three previous laptops, all of the type that have emmc drives. The structure of a Linux install iso seems to have changed a bit since I made my first attempts. I think with one of these laptops I was able to make progress by splicing a 32 bit efi file into the otherwise 64 bit OS, which I half understand is to do with the laptop's firmware being 32 bit. I tried Lubuntu on this laptop, 18.04.1 32 bit, but after a few days the install became corrupted for some reason and wouldn't boot, so I went back to Windows before becoming annoyed how often my metered data would be eaten by unstoppable updates.
That 32 bit Mint installed fine and behaves well except for having to create my own hotkeys for the time being till the kernel catches up. The laptop as it is can use 3.6 gb of RAM of the 4GB, and this amount is the same as for 64 bit Windows so I would think things aren't too bad. Is there a way round this though, could I have had 64 bit Mint? Ideally a simple, faff-free way? (These laptops with 32 bit firmware are common enough now and it seems a bit odd that the iso doesn't facilitate install and boot better without mystery-solving.) Obviously I know to disable secure boot etc. I had seen that the Lubuntu 64 install installed but failed to boot because of this efi file issue and assumed 64 bit Mint would fail in the same way.


User avatar
Level 5
Level 5
Posts: 996
Joined: Sat Mar 19, 2016 2:37 pm
Location: Beaverton, Oregon USA

Re: Was I limited to 32 bit 19.1?

Post by Tomgin5 »

I am not sure of the available Ram/SSR in your Idea pad but you may be running out of space for the OS to be able to comfortably run. You mentioned 4GB of HDD? Most LM in the 64 bit need at least 1 GB of RAM and 20 GB of drive space. 32 bit is a little less unless you go to LM XFCE 19.1 32 bit where 1 GB of RAM with >10GB of internal storage is desired. I have a couple of circa 2008 Dell insperon 910's that are very happy with the latter system. with 14 GB of an oddball SSD. If I save any text or other programs I have to put them in an external flash drive or DVD (usb).

To solve your problem list your (copy $ paste) the read out from "inxi -Fxzd".

Level 3
Level 3
Posts: 189
Joined: Fri May 27, 2011 7:09 pm

Re: Was I limited to 32 bit 19.1?

Post by tpprynn »

Thanks. Sorry, yes, to be clear the 4gb is the RAM. The emmc is 32gb. There's very good space on it still.

Output says:

Code: Select all

  Host: xxxxxx-Lenovo-ideapad-120S-11IAP Kernel: 4.15.0-20-generic i686 
  bits: 32 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.9 
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
  Type: Laptop System: LENOVO product: 81A4 v: Lenovo ideapad 120S-11IAP 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0P42934 WIN serial: <filter> 
  UEFI [Legacy]: LENOVO v: 6GCN29WW X64 date: 07/26/2018 
  ID-1: BAT1 charge: 11.9 Wh condition: 30.5/32.2 Wh (94%) 
  model: LENOVO BASE-BAT status: Discharging 
  Topology: Dual Core model: Intel Celeron N3350 bits: 64 type: MCP 
  arch: Goldmont rev: 9 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 4377 
  Speed: 796 MHz min/max: 800/2400 MHz Core speeds (MHz): 1: 796 2: 796 
  Device-1: Intel vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6) x86/MMX/SSE2 
  v: 4.5 Mesa 18.0.5 direct render: Yes 
  Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:0e.0 
  Sound Server: ALSA v: k4.15.0-20-generic 
  Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi 
  v: kernel port: 1040 bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 43.96 GiB used: 23.71 GiB (53.9%) 
  ID-1: /dev/mmcblk0 model: SC16G size: 14.84 GiB 
  ID-2: /dev/mmcblk1 model: DF4032 size: 29.12 GiB 
  Message: No Optical or Floppy data was found. 
  ID-1: / size: 10.94 GiB used: 7.64 GiB (69.8%) fs: ext4 
  dev: /dev/mmcblk1p1 
  ID-2: /home size: 16.60 GiB used: 6.31 GiB (38.0%) fs: ext4 
  dev: /dev/mmcblk1p6 
  ID-3: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/mmcblk1p5 
  System Temperatures: cpu: 34.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 182 Uptime: 2h 45m Memory: 3.58 GiB used: 1.04 GiB (29.0%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27
Last edited by Moem on Thu Jan 24, 2019 7:06 am, edited 1 time in total.
Reason: Adding [code] tags. They retain some formatting that makes your output easier to read.

User avatar
Level 20
Level 20
Posts: 10427
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Was I limited to 32 bit 19.1?

Post by Pierre »

if you still can't get LM19.x to install on that machine,,
then use the original Install Media, but with the PAE option, enabled
- - that should be in the Boot Menu List
to get the use of the full 4Gb of RAM on that machine.
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Level 16
Level 16
Posts: 6209
Joined: Sun Mar 27, 2016 6:58 pm

Re: Was I limited to 32 bit 19.1?

Post by rene »

Note I haven't any personal idea about any of that (and its solution might be the one you refer to already) but also see this thread: viewtopic.php?f=29&t=283381. At the very least apparently coming to a Mint Edition near you relatively shortly...

Post Reply

Return to “Installation & Boot”