Page 1 of 1

[Fixed] Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sat Feb 02, 2019 5:24 pm
by glitchathon
I rebooted into a black screen with no blinking cursor or anything. I thought I could get into the grub menu or recovery mode, but nothing works (shift, esc, etc). Any ideas on how to start troubleshooting?

Thanks!

Re: Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sat Feb 02, 2019 5:48 pm
by WharfRat
It could be a hardware problem.

What did you do just before rebooting :?:

To start narrowing things down, boot to the live media and paste back sudo blkid

Re: Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sat Feb 02, 2019 6:17 pm
by glitchathon
Thanks for the quick response!

So I am currently on a Live session of Mint 19.1. I just mounted my system drive and backed up the files I needed. So if worst comes to worst, I can reinstall.

Here is the output to sudo blkid:

Code: Select all

/dev/sda1: UUID="7FF0-F95A" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="edbefac1-32ae-47b7-a605-ae25a08c1460"
/dev/sda2: UUID="26bf0211-77d0-42be-a1b2-9393b18c34a0" TYPE="ext4" PARTUUID="a3c71d21-7074-46da-a3f8-e6519b05c073"
/dev/sdb1: LABEL="drive1" UUID="13260e27-a72f-41dc-b4e6-228fe637eded" TYPE="ext4" PARTLABEL="drive1" PARTUUID="5af5829f-ed2f-40b0-955b-c61523add5e4"
/dev/sdc1: LABEL="drive2" UUID="54db972f-dd1e-446b-9953-35febb1334a1" TYPE="ext4" PARTUUID="0cfbe33f-a013-4ec5-893b-190925eeda4d"
/dev/sdd1: LABEL="LINUX MINT" UUID="D06B-C783" TYPE="vfat" PARTUUID="0005dc0f-01"
/dev/loop0: TYPE="squashfs"
/dev/sda3: UUID="25c54da5-1f35-4908-aa8c-cf09ce64ab1e" TYPE="swap" PARTUUID="9ecf6f76-fde5-4ab0-aa43-af12c9a02c6b"
I actually did not do any major software or hardware changes before rebooting. I only rebooted because I usually like to do it once in awhile and it has been a couple of weeks since my last reboot.

Re: Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sat Feb 02, 2019 6:29 pm
by WharfRat
It's odd that you didn't fall into a grub prompt.

Check your BIOS/Firmware settings to make sure that it's set to boot the Mint disk and not the drive partitioned disk.

You can try reinstalling grub - these are the instructions

Re: Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sat Feb 02, 2019 6:31 pm
by glitchathon
WharfRat wrote:
Sat Feb 02, 2019 6:29 pm
It's odd that you didn't fall into a grub prompt.

Check your BIOS/Firmware settings to make sure that it's set to boot the Mint disk and not the drive partitioned disk.

You can try reinstalling grub - these are the instructions
I did manually select the system drive for booting and led to the same problem. I also tried reinstalling grub already, but I am going to follow these instructions as they are a bit different.
Thanks! Wish me luck!

edit: Oh, shoot. I just realized I should be using the Live CD of my original install, not of the latest? Hmmm, I am now thinking I should just reinstall the OS!

Re: Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sat Feb 02, 2019 6:38 pm
by WharfRat
It doesn't matter because you'll be in a chroot so your installed version repos will be used.

Re: Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sat Feb 02, 2019 6:44 pm
by glitchathon
WharfRat wrote:
Sat Feb 02, 2019 6:38 pm
It doesn't matter because you'll be in a chroot so your installed version repos will be used.
I decided to reinstall and the weird thing is that I am getting the same problem now with a brand new install of Mint Mate 19.1. The hard drive seems fine since i was able to copy files from it. Man, I am confused now!

Re: Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sat Feb 02, 2019 7:37 pm
by WharfRat
glitchathon wrote:
Sat Feb 02, 2019 6:44 pm
WharfRat wrote:
Sat Feb 02, 2019 6:38 pm
It doesn't matter because you'll be in a chroot so your installed version repos will be used.
I decided to reinstall and the weird thing is that I am getting the same problem now with a brand new install of Mint Mate 19.1. The hard drive seems fine since i was able to copy files from it. Man, I am confused now!
Is it possible to try another disk in that sata slot :?:

I hate to say this, but it's narrowing down to the disk or controller.

Re: Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sat Feb 02, 2019 7:43 pm
by glitchathon
WharfRat wrote:
Sat Feb 02, 2019 7:37 pm
glitchathon wrote:
Sat Feb 02, 2019 6:44 pm
WharfRat wrote:
Sat Feb 02, 2019 6:38 pm
It doesn't matter because you'll be in a chroot so your installed version repos will be used.
I decided to reinstall and the weird thing is that I am getting the same problem now with a brand new install of Mint Mate 19.1. The hard drive seems fine since i was able to copy files from it. Man, I am confused now!
Is it possible to try another disk in that sata slot :?:

I hate to say this, but it's narrowing down to the disk or controller.

Man, I disabled CSM and it booted up. Now I just reinstalled for no reason, haha. Oh well, I guess it's nice to have the latest Mint!

Re: Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sat Feb 02, 2019 7:54 pm
by WharfRat
glitchathon wrote:
Sat Feb 02, 2019 7:43 pm
WharfRat wrote:
Sat Feb 02, 2019 7:37 pm
glitchathon wrote:
Sat Feb 02, 2019 6:44 pm


I decided to reinstall and the weird thing is that I am getting the same problem now with a brand new install of Mint Mate 19.1. The hard drive seems fine since i was able to copy files from it. Man, I am confused now!
Is it possible to try another disk in that sata slot :?:

I hate to say this, but it's narrowing down to the disk or controller.

Man, I disabled CSM and it booted up. Now I just reinstalled for no reason, haha. Oh well, I guess it's nice to have the latest Mint!
Well a stupid mistake (CSM never enabled on its own for me) is better than a hardware failure :wink:

Re: Black Screen after rebooting Mint 18. Can’t get into recovery mode.

Posted: Sun Feb 03, 2019 3:50 am
by glitchathon
WharfRat wrote:
Sat Feb 02, 2019 7:54 pm
glitchathon wrote:
Sat Feb 02, 2019 7:43 pm
WharfRat wrote:
Sat Feb 02, 2019 7:37 pm

Is it possible to try another disk in that sata slot :?:

I hate to say this, but it's narrowing down to the disk or controller.

Man, I disabled CSM and it booted up. Now I just reinstalled for no reason, haha. Oh well, I guess it's nice to have the latest Mint!
Well a stupid mistake (CSM never enabled on its own for me) is better than a hardware failure :wink:
Yea, I have no idea why this happened. I haven’t been into the BIOS in ages. Spent the whole day setting up 19.1. Nice to be caught up!