[SOLVED] How to start Mint directly without showing boot menu.

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
ehoitinga
Level 1
Level 1
Posts: 12
Joined: Wed Aug 08, 2018 5:37 am

[SOLVED] How to start Mint directly without showing boot menu.

Post by ehoitinga » Tue Feb 05, 2019 10:31 am

Hi,

It seems like I always quarrel with grub. After the latest grub update (2.02-2ubuntu8.9 to 2.02-2ubuntu8.10) the boot menu suddenly pops up. Because I run only Linux Mint 19 and no other OS'es on my laptop, I want to skip the boot menu and start Mint directly. I did a search on the forum but all relevant posts concern 'showing the menu' in stead of skipping it.

I tried several google searches for this, but solutions given do not work. This is my /etc/default/grub file:

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
#GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""
GRUB_DISABLE_RECOVERY=true
GRUB_DISABLE_OS_PROBER=true
Whatever the value of GRUB_DEFAULT I always get the boot menu with a countdown of 30 seconds.

Does anyone have suggestions?

[Edit 06-FEB-19] Solution is here: viewtopic.php?f=46&t=287026

Thanks

Erik
Last edited by ehoitinga on Wed Feb 06, 2019 6:20 am, edited 1 time in total.

User avatar
Flemur
Level 17
Level 17
Posts: 7184
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: How to start Mint directly without showing boot menu.

Post by Flemur » Tue Feb 05, 2019 10:50 am

ehoitinga wrote:
Tue Feb 05, 2019 10:31 am

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'
Whatever the value of GRUB_DEFAULT I always get the boot menu with a countdown of 30 seconds.
Does anyone have suggestions?
Running

Code: Select all

info -f grub -n 'Simple configuration'
tells me that GRUB_DEFAULT is the default menu entry, and doesn't control any timing.
Internet search on

Code: Select all

hide grub menu
returns
http://ubuntuhandbook.org/index.php/201 ... grub-menu/
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

ehoitinga
Level 1
Level 1
Posts: 12
Joined: Wed Aug 08, 2018 5:37 am

Re: How to start Mint directly without showing boot menu.

Post by ehoitinga » Tue Feb 05, 2019 11:17 am

Sorry, where I wrote GRUB_DEFAULT I meant GRUB_TIMEOUT. Sorry for the mistake.

I already tried the solution given in the link you gave me but the menu still pops up.

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=10
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""
GRUB_DISABLE_RECOVERY=true
GRUB_DISABLE_OS_PROBER=true
Although I get the error message "Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported." after executing "sudo update-grub".

User avatar
Flemur
Level 17
Level 17
Posts: 7184
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: How to start Mint directly without showing boot menu.

Post by Flemur » Tue Feb 05, 2019 2:10 pm

ehoitinga wrote:
Tue Feb 05, 2019 11:17 am
I already tried the solution given in the link you gave me but the menu still pops up.

Code: Select all

GRUB_DEFAULT=0
GRUB_TIMEOUT=10
GRUB_HIDDEN_TIMEOUT=0
...
Although I get the error message "Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported." after executing "sudo update-grub".
That article might be old...
https://linoxide.com/linux-how-to/hide-grub-boot-linux/ (2018)

Code: Select all

GRUB_DEFAULT = 0
GRUB_TIMEOUT = 0
GRUB_DISABLE_OS_PROBER = true
Disclaimer: After the initial installation, I don't use grub software because it sucks.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

User avatar
smurphos
Level 12
Level 12
Posts: 4325
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: How to start Mint directly without showing boot menu.

Post by smurphos » Wed Feb 06, 2019 2:27 am

Sounds like this issue - viewtopic.php?f=46&t=287026

Solution is in the 2nd post.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
pbear
Level 8
Level 8
Posts: 2150
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: How to start Mint directly without showing boot menu.

Post by pbear » Wed Feb 06, 2019 2:31 am

Maybe, but notice also there's something off about the OP's grub config file.

ehoitinga, for comparison, on all my LM19 test boxes, even after the latest update, the active lines in /etc/default/grub by default are:

Code: Select all

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
Notably, GRUB_HIDDEN_TIMEOUT=0 was used in LM18, but isn't in 19.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

ehoitinga
Level 1
Level 1
Posts: 12
Joined: Wed Aug 08, 2018 5:37 am

Re: How to start Mint directly without showing boot menu.

Post by ehoitinga » Wed Feb 06, 2019 6:17 am

smurphos wrote:
Wed Feb 06, 2019 2:27 am
Sounds like this issue - viewtopic.php?f=46&t=287026

Solution is in the 2nd post.
Thanks @smurphos, this was indeed the problem. I searched for solutions in the Installation & Boot subforum thinking that this was a boot problem. So I don't know why I missed this post. Sorry for that, the solution was there. But why force 30 secs of menu? I use EFI and not LVM.

@pbear, my grub config file is a little different because I changed it. I added the line GRUB_CMDLINE_LINUX_DEFAULT="" to see the output of systemd. I added the lines GRUB_DISABLE_RECOVERY=true and GRUB_DISABLE_OS_PROBER=true because I do not want grub to generate recovery entries and I don't want grub to probe for other OS entries because there is only one.

The lines GRUB_HIDDEN_TIMEOUT=0 and GRUB_HIDDEN_TIMEOUT_QUIET=true I added as part of a solution for the menu popping up problem mentioned in other posts. I deleted these two lines because this solution did not work.

Anyway, its working again right now. I had not thought about looking for the error in /etc/grub.d/00_header. Thanks @smurphos for pointing this out. To everyone else, thanks for the help.

This is my latest grub config file:

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""
GRUB_DISABLE_RECOVERY=true
GRUB_DISABLE_OS_PROBER=true
Erik

ehoitinga
Level 1
Level 1
Posts: 12
Joined: Wed Aug 08, 2018 5:37 am

Re: [SOLVED] How to start Mint directly without showing boot menu.

Post by ehoitinga » Sat Feb 09, 2019 5:59 am

FYI

OK, I had an update to grub2 today via the update manager. So let's see what happens with the 'persistent grub menu bug'.

Upon the update of grub2 synaptic asked me to replace or keep the file /etc/grub.d/00_header. I chose to replace the file. Don't know if there are any other differences between the old and the new file. So to be on the safe side I had synaptic replace it.
Image
Image
An yes, on reboot the grub boot menu re-appears. After re-applying the patch:

Code: Select all

sudo sed -i "/recordfail_broken=/{s/1/0/}" /etc/grub.d/00_header
sudo update-grub
the menu is gone again and Mint starts up directly again.

Erik

MrGrimm
Level 5
Level 5
Posts: 648
Joined: Sun Nov 11, 2018 9:13 am

Re: [SOLVED] How to start Mint directly without showing boot menu.

Post by MrGrimm » Sat Feb 09, 2019 8:01 am

i know this is a dead thread(pun intended)but am i right in assuming that the following is why i don't see the grub menu when i restart? and before someone ask no i just took a quick look at it and closed it back out without making any changes.

Code: Select all

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

User avatar
smurphos
Level 12
Level 12
Posts: 4325
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: [SOLVED] How to start Mint directly without showing boot menu.

Post by smurphos » Sat Feb 09, 2019 10:02 am

MrGrimm wrote:
Sat Feb 09, 2019 8:01 am
am i right in assuming that the following is why i don't see the grub menu when i restart?
Yep - specifically

Code: Select all

GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
As an example for a 5 second visible grub menu you'd need....

Code: Select all

GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=5
After any edit you need to sudo update-grub for changes to take effect.

https://www.gnu.org/software/grub/manua ... figuration
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

MrGrimm
Level 5
Level 5
Posts: 648
Joined: Sun Nov 11, 2018 9:13 am

Re: [SOLVED] How to start Mint directly without showing boot menu.

Post by MrGrimm » Sat Feb 09, 2019 10:20 am

thanks ever so much. now is that a bug in a recent grub update, cause i've never messed with it. i've wanted to add time to it,but never got around to even researching how to do it. thanks again

User avatar
smurphos
Level 12
Level 12
Posts: 4325
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: [SOLVED] How to start Mint directly without showing boot menu.

Post by smurphos » Sat Feb 09, 2019 10:37 am

Nope not a bug - the default for a single boot Mint install is not to show the screen without user interaction. Holding left-shift at boot should show it even if hidden.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

MrGrimm
Level 5
Level 5
Posts: 648
Joined: Sun Nov 11, 2018 9:13 am

Re: [SOLVED] How to start Mint directly without showing boot menu.

Post by MrGrimm » Sat Feb 09, 2019 10:46 am

smurphos wrote:
Sat Feb 09, 2019 10:37 am
Nope not a bug - the default for a single boot Mint install is not to show the screen without user interaction. Holding left-shift at boot should show it even if hidden.

ok thanks for that. then it must of been something buggy o my end, cause till the update to 19.1 i always had it. under 5 seconds, but always had it. thanks again

fyi

just tested and works like a charm.

Post Reply

Return to “Installation & Boot”