Mint 19.1 Slow boot up

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
pinnerite
Level 1
Level 1
Posts: 30
Joined: Fri Dec 28, 2012 9:19 am

Mint 19.1 Slow boot up

Post by pinnerite » Mon Feb 18, 2019 7:57 am

I have identified two excessive delays during boot up and would welcome suggestions on how to remove them:

During the boot the following messages appear:
1) btrfs loaded
Scanning for btfrs filesystems.

I do not have any. Mine are all ext4. Why is this forced on me?

2) After the line 'Reached (something) system Time Synchronised' there comes:
A start job is running for dev-disk-by\.............a UIID ..............,device
Which trawls for one and a half minutes.
What is this for?
Can I avoid it?

User avatar
karlchen
Level 20
Level 20
Posts: 11427
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Mint 19.1 Slow boot up

Post by karlchen » Mon Feb 18, 2019 10:12 am

Hello, pinnerite.

Actually, we would need to have a few more objective and measurable details than you provided.
Therefore I would like to ask you to provide to us, please, ...
  • an inxi -Fxz report. This will give us a concise overview on your system hardware and on your system configuration.
    Please, open a terminal window. Make the terminal window full screen. Execute the commandline

    Code: Select all

    inxi -Fxz
    precisely as it has been typed here. Mark the complete text output which inxi will display with your mouse. Press <Ctrl><Shift>C in order to copy the marked text into the clibpboard. Paste it into your next reply.
    .
  • the output of the commandline systemd-analyze It will reveal how much time your system takes to load the kernel and how much time it takes to load the graphical desktop environment, plus the overall system startup time.
    Execute the commandline

    Code: Select all

    systemd-analyze
    Mark the complete text output which systemd-analyze will display with your mouse. Press <Ctrl><Shift>C in order to copy the marked text into the clibpboard. Paste it into your next reply.
    .
  • the output of the commandline systemd-analyze blame It will reveal how much time systemd spends on loading every single service and may help identify services which waste too much time (for whichever reason).
    Execute the commandline

    Code: Select all

    systemd-analyze blame
    Mark the complete text output which systemd-analyze will display with your mouse. Press <Ctrl><Shift>C in order to copy the marked text into the clibpboard. Paste it into your next reply.
Best regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

arty
Level 1
Level 1
Posts: 3
Joined: Tue Oct 16, 2018 4:04 pm

Re: Mint 19.1 Slow boot up

Post by arty » Wed Feb 20, 2019 3:45 pm

Had the same trouble (btrfs scanning ... UUID). For me it was a stale entry in /etc/fstab
On installation, linuxmint automatically adds all swap partitions found in /dev/sdx
Removing the drive later leaves /dev/fstab with a bad entry

User avatar
karlchen
Level 20
Level 20
Posts: 11427
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Mint 19.1 Slow boot up

Post by karlchen » Thu Feb 21, 2019 6:34 am

Hello, pinnerite.

Any news from your side perhaps?

Regards,
Karl
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Hatori
Level 1
Level 1
Posts: 5
Joined: Sat Sep 14, 2019 12:48 pm

Re: Mint 19.1 Slow boot up

Post by Hatori » Sat Sep 14, 2019 12:58 pm

I'm getting the same issue. My steps are:

1. Installed cinnamon 19.2 onto PCI hosted m2 ssd = boot time less than 10 seconds
2. Shutdown pc and disconnected my mechanical HDD, only drive is m2 card which remains
3. Rebooted the PC = Boot time is now well over 1 minute

User avatar
AndyMH
Level 9
Level 9
Posts: 2640
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Mint 19.1 Slow boot up

Post by AndyMH » Sat Sep 14, 2019 5:35 pm

3. Rebooted the PC = Boot time is now well over 1 minute
Which suggests that there is a partition on the HDD that mint is trying to mount on boot. Check your fstab file.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate

User avatar
Larry78723
Level 7
Level 7
Posts: 1549
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Mint 19.1 Slow boot up

Post by Larry78723 » Sat Sep 14, 2019 5:52 pm

Please post the following reports. Here is how to generate and post them :

Open a terminal window (Ctrl-Alt-t). Make it fullscreen to avoid unneeded linebreaks or chopped lines. Execute the commands

Code: Select all

 blkid 

Code: Select all

cat /etc/fstab


Mark the complete text output which each command will display with your mouse.
Press the keyboard shortcut <Shift><Ctrl>C to copy the marked text into the clipboard.
Enclose the results between the code markers by selecting </> from the mini toolbar above the textbox where you type your reply then paste <Ctrl>V them in your reply between the code markers.

The results will help us to help you.

Larry
Image

Hatori
Level 1
Level 1
Posts: 5
Joined: Sat Sep 14, 2019 12:48 pm

Re: Mint 19.1 Slow boot up

Post by Hatori » Sun Sep 15, 2019 4:38 am

blkid

Code: Select all

/dev/sda1: LABEL="SDD" UUID="fe51ce6c-735f-4913-8bff-9f3c74f14d7f" TYPE="ext4" PARTUUID="5b81ab01-1484-43c8-913e-200cd030a370"
/dev/sdb1: UUID="b0c3adf9-2317-4800-a626-7ff719be8a0b" TYPE="ext2" PARTUUID="4c7e73ca-01"
cat /etc/fstab

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc1 during installation
UUID=b0c3adf9-2317-4800-a626-7ff719be8a0b /               ext2    errors=remount-ro 0       1
# swap was on /dev/sdb6 during installation
UUID=72d18a2b-d03a-43d7-b083-652c5745e3fa none            swap    sw              0       0
/dev/disk/by-uuid/fe51ce6c-735f-4913-8bff-9f3c74f14d7f /mnt/fe51ce6c-735f-4913-8bff-9f3c74f14d7f auto nosuid,nodev,nofail,x-gvfs-show 0 0

User avatar
AndyMH
Level 9
Level 9
Posts: 2640
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Mint 19.1 Slow boot up

Post by AndyMH » Sun Sep 15, 2019 5:48 am

Looks like your SSD is sdb and your HDD is sda as the root partition is on sdb1.

The culprit is in your fstab file:

Code: Select all

/dev/disk/by-uuid/fe51ce6c-735f-4913-8bff-9f3c74f14d7f /mnt/fe51ce6c-735f-4913-8bff-9f3c74f14d7f auto nosuid,nodev,nofail,x-gvfs-show 0 0
Did you use the disks utility to mount this partition?
Comment out the line by putting a # at the start of the line. You will need to edit fstab as root to do this*, save and then reboot. This will stop mint trying to mount sda1 on boot.

The nofail option in the fstab entry should have stopped mint repeatedly searching for the partition when it first couldn't find it, but I suspect the lack of a comma between auto nosuid (should be auto,nosuid) might be the problem.

Why have you formatted your root partition (/) ext2?

* In your file manager navigate to /, then scroll down to the folder /etc and right click and select 'open as root', then scroll down to the fstab file and double click to open and edit it.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate

Hatori
Level 1
Level 1
Posts: 5
Joined: Sat Sep 14, 2019 12:48 pm

Re: Mint 19.1 Slow boot up

Post by Hatori » Sun Sep 15, 2019 5:57 am

I'll try to follow this instruction. I would have chosen to use ext2 because using a linux only format would not be a good idea in the event of a hdd recovery where want any PC to be able to access the drive, eg a windows PC

Can you advise as to how to get root access and perform the # edit?

User avatar
Larry78723
Level 7
Level 7
Posts: 1549
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Mint 19.1 Slow boot up

Post by Larry78723 » Sun Sep 15, 2019 7:44 am

Use the following command to edit your fstab:

Code: Select all

sudoedit /etc/fstab
Place a # before the line /dev/disk/by-uuid/fe51ce6c-735f-4913-8bff-9f3c74f14d7f /mnt/fe51ce6c-735f-4913-8bff-9f3c74f14d7f auto nosuid,nodev,nofail,x-gvfs-show 0 0
Press Ctrl-O then Enter to save
Press Ctrl-X to exit
Reboot and check boot time
Image

Hatori
Level 1
Level 1
Posts: 5
Joined: Sat Sep 14, 2019 12:48 pm

Re: Mint 19.1 Slow boot up

Post by Hatori » Sun Sep 15, 2019 8:51 am

I successfully changed that line to a comment and saved

Result:
a) Confirmed the file with edited comment on reboot
b) Boot time is sill excessive (no change)
c) I observed that the SDD drive that is still connected to the PC has not mounted at start up. The line you asked me to #comment is the drive that is still connected to the PC and one that i DO want mounted.
d) This issue happened after i disconnected the mechanical HDD from the PC after the mint installation, i think this is the drive that linux may be looking for.

Just to clarify:
My physical drive list at installation was as follows:
1. Kingston SHPM2280P2H/480G on the PCI bus (this is the one i installed mint onto)
2. The mechanical HDD i disconnected after the install
3. Samsung SSD 840 PRO Series. This is still connected and appears to be the one we #commented out

What now?

User avatar
Larry78723
Level 7
Level 7
Posts: 1549
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Mint 19.1 Slow boot up

Post by Larry78723 » Sun Sep 15, 2019 9:15 am

OK, it seems that the comments in your fstab are screwed up. Undo the change you made to fstab following the previous instructions and removing the #. Then follow the instructions AndyMH gave a few posts back.
Image

Hatori
Level 1
Level 1
Posts: 5
Joined: Sat Sep 14, 2019 12:48 pm

Re: Mint 19.1 Slow boot up

Post by Hatori » Mon Sep 16, 2019 10:08 am

I tried adding the comma between the auto,nosuid

After a reboot this put my PC into the emergency state. The screen was scrambled with a mix of some kind of menu with options and the terminal text. Once i saw the terminal show up i typed in the sudo comment

Code: Select all

sudoedit /etc/fstab
to get access to editing the file again. I removed the comma which reversed this emergency mode issue.

The edit screen of the text editor was still scrambled/mixed with the text editor and menu options. Once hitting the right key a few times it righted itself and i removed the comma, saved and rebooted with some kind of option for systemcntl reboot or similar.

I cant spend time production testing my own machine here. There has to be a better way to solve these issues.

Withdrawing my issue. Sorry it didnt work out.

Post Reply

Return to “Installation & Boot”