(Solved) Very Slow Boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
User avatar
kevin987
Level 4
Level 4
Posts: 346
Joined: Fri Dec 11, 2015 12:35 pm

Re: Very Slow Boot

Post by kevin987 » Thu Mar 07, 2019 2:51 pm

dvanman wrote:
Thu Mar 07, 2019 11:50 am
Computer is Dell D830 laptop with 32-bit, COR2 Duo processor,4gig RAM, 120G Hard Drive.
MINT 17.3 booted up in under 2-minutes.
I did a complete reformat on the hard drive, a fresh install of MINT-19.1 and now boot time is now nearly 7-minutes. Once up it runs fine but boot time is not acceptable so I need a "fix" or will have to reload old MINt-17.3 or find a different LINUX.
I also tried booting directly from the DVD and it also took nearly 7-minutes
Hi dwanman,

You could also try Mint 18.3 to see how that works, or LMDE 3.

Since your computer is capable of running 64 bit you should go with that. Your choice of web browsers, for instance, are drastically reduced using the 32 bit version.

32 bit software is not being maintained much anymore.
Linux Mint 19.1 (Cinnamon)
LMDE 3 (Cinnamon)
GeckoLinux 150 (Cinnamon)

War Horse
Level 2
Level 2
Posts: 99
Joined: Fri Feb 22, 2019 12:47 pm
Location: Florida

Re: Very Slow Boot

Post by War Horse » Thu Mar 07, 2019 3:08 pm

kevin987 wrote:
Thu Mar 07, 2019 2:51 pm
War Horse wrote:
Thu Mar 07, 2019 8:07 am
Kevin, what I'm going to do today is, clean the HD and reinstall windows 7 just to see if it will operate as it did before. If it doesn't, I'll know there's a hardware problem internally. If it does, then I'll do a native install of LMDE Cindy first, and then try the rest. Thak you for the list of OS to try. :)
Hi War Horse,

It's not that your hardware is failing. It's that Linux Mint 19.1 doesn't function properly with your hardware. The older your computer is, the more likely that at some point, more modern distros will not function properly with that old computer.
Kevin, I found that out today. I reinstalled Windows 7, and it's fast as can be.
Do you think that the guys at Lunux will do a cure for this? It sure would be nice to have all of my computers running on Mint 19.1, especially since this is the computer I take with me going out, and I sure would like to show people the system to get them off of Windows.
I have a 18" Acer laptop, but that thing is a little big to take on a motorcycle, and it's rather flimsy compared to this Latitude D630.
Using Mint 19.1 , 64 bit

User avatar
kevin987
Level 4
Level 4
Posts: 346
Joined: Fri Dec 11, 2015 12:35 pm

Re: Very Slow Boot

Post by kevin987 » Thu Mar 07, 2019 3:42 pm

War Horse wrote:
Thu Mar 07, 2019 3:08 pm
Do you think that the guys at Lunux will do a cure for this?
I'm afraid not. The laptop is becoming obsolete. Your thoughts on changing the motherboard have merit to extend its life, but I can't help much in that regard, especially when it comes to a laptop.
Linux Mint 19.1 (Cinnamon)
LMDE 3 (Cinnamon)
GeckoLinux 150 (Cinnamon)

War Horse
Level 2
Level 2
Posts: 99
Joined: Fri Feb 22, 2019 12:47 pm
Location: Florida

Re: Very Slow Boot

Post by War Horse » Thu Mar 07, 2019 3:53 pm

kevin987 wrote:
Thu Mar 07, 2019 3:42 pm
War Horse wrote:
Thu Mar 07, 2019 3:08 pm
Do you think that the guys at Lunux will do a cure for this?
I'm afraid not. The laptop is becoming obsolete. Your thoughts on changing the motherboard have merit to extend its life, but I can't help much in that regard, especially when it comes to a laptop.
That's ok Kevin, i appreciated all the help. I'll just keep Windows 7 on this unit for as long as possible. I know Windows is stopping support for it next year, but that's just updates. I have one PC that's been running win7 for years and haven't done one update on it, and it's the best PC running windows that I have.
I think the hardware in the old Dell laptop is fine for this, and the upgraded SSD and RAM really helped any way.
Sometime down the road I'll find another newer bullet proof little laptop for cheap that I can bounce around. At that point I'll install Mint on it. :D
Using Mint 19.1 , 64 bit

User avatar
kevin987
Level 4
Level 4
Posts: 346
Joined: Fri Dec 11, 2015 12:35 pm

Re: Very Slow Boot

Post by kevin987 » Thu Mar 07, 2019 4:00 pm

War Horse wrote:
Thu Mar 07, 2019 3:53 pm
That's ok Kevin, i appreciated all the help. I'll just keep Windows 7 on this unit for as long as possible. I know Windows is stopping support for it next year, but that's just updates. I have one PC that's been running win7 for years and haven't done one update on it, and it's the best PC running windows that I have.
I think the hardware in the old Dell laptop is fine for this, and the upgraded SSD and RAM really helped any way.
Sometime down the road I'll find another newer bullet proof little laptop for cheap that I can bounce around. At that point I'll install Mint on it. :D
You can still try to set up a dual boot by installing one of the operating systems mentioned earlier, installing it alongside Win 7. A lot of people are doing that.
Linux Mint 19.1 (Cinnamon)
LMDE 3 (Cinnamon)
GeckoLinux 150 (Cinnamon)

User avatar
smurphos
Level 13
Level 13
Posts: 4547
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Very Slow Boot

Post by smurphos » Thu Mar 07, 2019 4:01 pm

The solution to the problem has already been posted in this thread.

It's a known bug with your graphics chipset and the DRM support in current kernels. There is a workaround though via booting with a video=SVIDEO-1:d kernel parameter which requires you to edit the file /etc/default/grub with root privileges

The workaround using nano a terminal based text editor

Open a terminal and run this command to open the file in nano.

Code: Select all

sudo nano /etc/default/grub
Navigate using the arrow keys to the line that reads

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"
Then press Ctrl-O to save and Ctrl-X to exit

Then in the terminal run

Code: Select all

sudo update-grub
Then reboot.

Alternatively.....

The workaround using Xed a GUI based text editor

Open a terminal and run this command to open the file in Xed.

Code: Select all

xed admin:///etc/default/grub
In Xed navigate to the line.

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it to

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"
Save the file and exit Xed,

Then in a terminal run

Code: Select all

sudo update-grub
Then reboot.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

War Horse
Level 2
Level 2
Posts: 99
Joined: Fri Feb 22, 2019 12:47 pm
Location: Florida

Re: Very Slow Boot

Post by War Horse » Thu Mar 07, 2019 4:20 pm

smurphos, I did all that to no avail . I may try the dual boot idea and give it another shot with LMDE "Cindy", as that seemed to boot a tad faster.

I need a break from this for a few days, get a new outlook on things. In the meantime, all my other PC's are running great with Mint 19.1. :)
Using Mint 19.1 , 64 bit

User avatar
smurphos
Level 13
Level 13
Posts: 4547
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Very Slow Boot

Post by smurphos » Thu Mar 07, 2019 4:22 pm

With all due respect in your first attempt to do that you failed to correctly follow the instructions. I've attempted to lay them out in a step by step fashion for you.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

War Horse
Level 2
Level 2
Posts: 99
Joined: Fri Feb 22, 2019 12:47 pm
Location: Florida

Re: Very Slow Boot

Post by War Horse » Thu Mar 07, 2019 4:45 pm

smurphos wrote:
Thu Mar 07, 2019 4:22 pm
With all due respect in your first attempt to do that you failed to correctly follow the instructions. I've attempted to lay them out in a step by step fashion for you.
True, but I did get it right when someone else told me the mistake I made. You need to understand that I've only been involved with this Linux thing for about a month. The way you just spelled it out was perfect for a dummy like me to follow, and will do so when I get the dual boot going.
I do appreciate the effort you went too, to spell it out like that. Thank you.
Using Mint 19.1 , 64 bit

User avatar
smurphos
Level 13
Level 13
Posts: 4547
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Very Slow Boot

Post by smurphos » Thu Mar 07, 2019 4:50 pm

No worries - the other option is to try Mint 18 or 18.1 (with both ship with a 4.4 kernel) The bug postdates this kernel so both these editions should boot faster with no additional workaround. You can still do an in-place upgrade to Mint 18.3 whilst sticking with the 4.4 kernel.

If you want Mint 19.x though the workaround is the only real option.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

War Horse
Level 2
Level 2
Posts: 99
Joined: Fri Feb 22, 2019 12:47 pm
Location: Florida

Re: Very Slow Boot

Post by War Horse » Thu Mar 07, 2019 5:22 pm

smurphos wrote:
Thu Mar 07, 2019 4:50 pm
No worries - the other option is to try Mint 18 or 18.1 (with both ship with a 4.4 kernel) The bug postdates this kernel so both these editions should boot faster with no additional workaround. You can still do an in-place upgrade to Mint 18.3 whilst sticking with the 4.4 kernel.

If you want Mint 19.x though the workaround is the only real option.
Thanks for the options, I'll look into it and report back.
Using Mint 19.1 , 64 bit

far
Level 1
Level 1
Posts: 2
Joined: Fri Mar 08, 2019 5:16 am

Re: Very Slow Boot

Post by far » Fri Mar 08, 2019 6:17 am

Hi, I just installed Mint on a 2007 Apple Macbook Air, 2GB - clean install.
Runs fine (-wifi) but extremely slow boot.
The "quiet splash" tip posted by smurphos cut boot from 5 mins to 2 mins. Thanks! :D

rjmoses
Level 1
Level 1
Posts: 6
Joined: Thu Feb 21, 2019 12:50 pm

Re: Very Slow Boot

Post by rjmoses » Fri Mar 08, 2019 8:54 am

After resizing my disk on Virtualbox, I had a boot time exceeding 90 seconds. I isolated it to two problems:

1. The boot process was executing a btrfs scan even though I do not use btrfs--this accounted for about 30 seconds.
2. During the resize process, I had to delete and recreate my swap partition. The swap partition UUID in /etc/fstab was not updated. The system was attempting to scan/mount the non-existent swap partition and took about 60 seconds.

To correct, I:

1) Removed btrfs: (reference reply #4 -- https://unix.stackexchange.com/question ... t-start-up)
sudo apt-get purge btrfs-tools
sudo update-initramfs -ukall
sudo update-grub

2) Corrected the swap partition UUID (reference reply #29 -- https://askubuntu.com/questions/711016/ ... ev-disk-by)
sudo blkid (display UUID for all drives)
edit /etc/fstab
---replace swap UUID with UUID from blkid
---save
reboot.

Boot time is now 9-10 seconds from menu selection to splash screen, 9-10 seconds from splash screen to login running 19.1 guest on virtualbox hosted on Windows 10 system. Both Windows and Linux systems are running on SSDs.

This worked for me. Hope it helps others.

War Horse
Level 2
Level 2
Posts: 99
Joined: Fri Feb 22, 2019 12:47 pm
Location: Florida

Re: Very Slow Boot

Post by War Horse » Fri Mar 08, 2019 2:30 pm

Yipee ! I used smurphos instruction for dummies and it worked great. Boot time is really fast now. Thank you very much.

Using the ctrl commands is what I didn't do the original second time around... beers are on me. :D
Using Mint 19.1 , 64 bit

User avatar
smurphos
Level 13
Level 13
Posts: 4547
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Very Slow Boot

Post by smurphos » Sat Mar 09, 2019 12:38 am

far wrote:
Fri Mar 08, 2019 6:17 am
Hi, I just installed Mint on a 2007 Apple Macbook Air, 2GB - clean install.
Runs fine (-wifi) but extremely slow boot.
The "quiet splash" tip posted by smurphos cut boot from 5 mins to 2 mins. Thanks! :D
Glad it helped - yes the vintage Macbooks seem to normally have the same processor + integrated graphics as war horse's old Dell.

Basically if you've got Intel Mobile GM965/GL960 Integrated Graphics and want to use a Kernel 4.8 or later you need the video=SVIDEO-1:d workaround.

A couple of many bug reports -
https://bugs.launchpad.net/ubuntu/+sour ... ug/1685442
https://bugs.launchpad.net/ubuntu/+sour ... ug/1774845
War Horse wrote:
Fri Mar 08, 2019 2:30 pm
Yipee ! I used smurphos instruction for dummies and it worked great. Boot time is really fast now. Thank you very much.

Using the ctrl commands is what I didn't do the original second time around... beers are on me. :D
Got there in the end! Glad it worked :)
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

SIPTalk
Level 1
Level 1
Posts: 1
Joined: Sat Mar 16, 2019 7:46 am

Re: (Solved) Very Slow Boot

Post by SIPTalk » Sat Mar 16, 2019 8:02 am

I just wanted to thank smurphos for the post on this. I have been struggling with this on both of my D830's since 19, then moving to 19.1 with no avail. I even installed an SSD on one hoping it would correct the problem and it did not. By following smurphos instructions both of my D830's boot quickly again. The one with the HDD in about 90 seconds and the one with the SSD in 20 seconds. Thanks!

PhillyIdol
Level 1
Level 1
Posts: 1
Joined: Wed Mar 20, 2019 5:41 pm

Re: (Solved) Very Slow Boot

Post by PhillyIdol » Thu Mar 21, 2019 12:32 pm

Okay,

First off - not new to Linux, but new to Mint (used Ubuntu), so know that these forums are worth their weight on gold. Just had to post this to give a huge kudos to thx-1138 for that gem of a fix. Had a Dell D630 that was at a 5-6min boot time, ran the 'xed' fix - and holy $#!# - it's now at less than a min for boot.

Love Linux guru's :D

amdi
Level 1
Level 1
Posts: 1
Joined: Sat Sep 21, 2019 5:46 pm

Re: Very Slow Boot

Post by amdi » Sat Sep 21, 2019 6:21 pm

smurphos wrote:
Thu Mar 07, 2019 4:01 pm
The solution to the problem has already been posted in this thread.
It's a known bug with your graphics chipset and the DRM support in current kernels. There is a workaround though via booting with a video=SVIDEO-1:d kernel parameter which requires you to edit the file /etc/default/grub with root privileges [...]
I am preparing to donate an old laptop (Acer Aspire 7720-6208) which has the Mobile Intel GM965 Express chipset. After installing Linux Mint 19.2, I noticed very long boot times - approx 4 minutes. I found this solution from smurphos which made reference to a different make of laptop with the same specifications. I tried the fix and it remedied the problem. Boot time is now ONE MINUTE. Almost unbelievable! Thank you very much for the solution and for the detailed instructions for applying the fix. The wonderful work performed by you and your colleagues is greatly appreciated. Thank you.

Amdi.

Post Reply

Return to “Installation & Boot”