[Solved] Windows 7 not starting after installing Linux mint

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
salek
Level 1
Level 1
Posts: 5
Joined: Sat Sep 07, 2019 1:05 pm

[Solved] Windows 7 not starting after installing Linux mint

Post by salek » Sat Sep 07, 2019 1:32 pm

I have install linux mint 19.2 cinnamon 64-bit on free space of same hard disk. I had Windows 7 32 bit in my Hp Pavillion g6 (core i5, 500gb hard disk, 2gb ram) laptop. At the time of linux mint installation, have created root 15 gb, 4 gb swap area , 18 gb /home. When reboot, it shows linux and windows 7 listed. But when I choose windows 7 it shows another screen. Not starting windows 7.
Photo link: Windows 7 not starting after installing Linux mint https://imgur.com/gallery/rxRhBDf
Last edited by salek on Tue Sep 10, 2019 10:13 am, edited 2 times in total.

User avatar
Larry78723
Level 6
Level 6
Posts: 1172
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Windows 7 not starting after installing Linux mint

Post by Larry78723 » Sat Sep 07, 2019 2:29 pm

Please take a screenshot of what you're getting when you select win7 and upload it to a picture sharing site (I recommend imgur.com) then post a link to it.
Image

User avatar
Spearmint2
Level 16
Level 16
Posts: 6284
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Windows 7 not starting after installing Linux mint

Post by Spearmint2 » Sat Sep 07, 2019 6:21 pm

Have you run update-grub yet?
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

athi
Level 6
Level 6
Posts: 1292
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: Windows 7 not starting after installing Linux mint

Post by athi » Sat Sep 07, 2019 6:47 pm

Are you selecting Win7 from BIOS boot list or GRUB boot menu (black screen with listing of bootable O/S and tools)?
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

salek
Level 1
Level 1
Posts: 5
Joined: Sat Sep 07, 2019 1:05 pm

Re: [Solved] Windows 7 not starting after installing Linux mint

Post by salek » Tue Sep 10, 2019 9:49 am

I have selected windows 7 from grub boot menu.
I have run update-grub. This did not solve the issue.

I have use Boot repair disk and the problem solved now. Thank you.

salek
Level 1
Level 1
Posts: 5
Joined: Sat Sep 07, 2019 1:05 pm

Re: Windows 7 not starting after installing Linux mint

Post by salek » Tue Sep 10, 2019 10:20 am

Larry78723 wrote:
Sat Sep 07, 2019 2:29 pm
Please take a screenshot of what you're getting when you select win7 and upload it to a picture sharing site (I recommend imgur.com) then post a link to it.
https://imgur.com/gallery/rxRhBDf

salek
Level 1
Level 1
Posts: 5
Joined: Sat Sep 07, 2019 1:05 pm

Re: Windows 7 not starting after installing Linux mint

Post by salek » Tue Sep 10, 2019 10:20 am

Spearmint2 wrote:
Sat Sep 07, 2019 6:21 pm
Have you run update-grub yet?
I have run update-grub. This did not solve the issue.

salek
Level 1
Level 1
Posts: 5
Joined: Sat Sep 07, 2019 1:05 pm

Re: Windows 7 not starting after installing Linux mint

Post by salek » Tue Sep 10, 2019 10:21 am

athi wrote:
Sat Sep 07, 2019 6:47 pm
Are you selecting Win7 from BIOS boot list or GRUB boot menu (black screen with listing of bootable O/S and tools)?
I have selected windows 7 from grub boot menu.

athi
Level 6
Level 6
Posts: 1292
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: Windows 7 not starting after installing Linux mint

Post by athi » Tue Sep 10, 2019 10:32 am

salek wrote:
Tue Sep 10, 2019 10:21 am
athi wrote:
Sat Sep 07, 2019 6:47 pm
Are you selecting Win7 from BIOS boot list or GRUB boot menu (black screen with listing of bootable O/S and tools)?
I have selected windows 7 from grub boot menu.
So GRUB is working, just cannot boot Win7. Either Win7 boot manager is damaged or is inaccessible. Please run below command in Terminal (ctrl+alt+t) to output partitions layout and post results.

Code: Select all

sudo parted -l
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

pbear
Level 7
Level 7
Posts: 1835
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: [Solved] Windows 7 not starting after installing Linux mint

Post by pbear » Tue Sep 10, 2019 1:04 pm

salek wrote:
Sat Sep 07, 2019 1:32 pm
At the time of linux mint installation, have created root 15 gb, 4 gb swap area , 18 gb /home.
Congratulations on solving the immediate problem. I will mention, though, that this is not a good partition scheme for your system. I assume you saw it recommended somewhere. Or adapted it from something you saw recommended somewhere. Your root partition is much too small and you don't need a swap partition in Mint 19.2. Meanwhile, separate home is useful in some ways, but not needed.

Given how little space you have available, the best solution would be a single root partition. In fact, I would recommend you reinstall now, but you'll probably demur. At least keep this in mind if you find yourself having to reinstall in future. Like, when your root partition fills up. :(
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

Post Reply

Return to “Installation & Boot”