[Solved] Fresh Mint xfce install - Still boots Windows 10

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
FrankB616
Level 2
Level 2
Posts: 77
Joined: Wed Mar 27, 2019 1:50 pm

[Solved] Fresh Mint xfce install - Still boots Windows 10

Post by FrankB616 » Wed Sep 11, 2019 7:26 pm

Just tried to install Mint 19.1 on a recent Lenovo slimline desktop. This machine has 2 physical drives, a mechanical drive with Win10 factory installed (sda), and now a Samsung 850 250 GB SSD (sdb). It has already had an installation of Kubuntu 14.04 on it on sdb, and I suspect that the grub bootloader ended up on the mechanical Win10 drive.

Before starting this install, I followed the blog at

https://easylinuxtipsproject.blogspot.c ... ws-10.html

SATA is set to AHCI, and I have included a picture of the Primary Boot sequence taken from the BIOS. Secure boot is turned off.

SATA1 has a triangle beside it, and it appears that it wants to boot from there regardless of the boot order selected. I have no idea what the triangle indicates, and I see no way to remove it, or change it.

In any case, when the machine boots, it goes to Windows, basically ignoring the boot order selected in BIOS.

I can interrupt the boot sequence and choose a one-time boot to Linux The the menu selection on the one-time boot shows 'ubuntu' not 'mint', however it does boot to mint when manually selected this way. But that is the only way I can get it to go to Linux. Annoying as this machine is intended to be a Linux box primarily. In fact, I am getting tempted to just pull the Win10 disk out altogether.

Is there a way to make this boot to Linux as the primary OS, or has Lenovo locked Win10 in at the hardware level? Or, did I get the grub bootloader on the Win10 disk during the Kubuntu install by mistake? If so, then there might be 2 copies of grub on this machine -- one on each disk.

FWIW, I had the same issue with Kubuntu 14.04. Could only boot it if I interrupted the boot order and chose a one-time boot to Linux.

So, I am grasping at straws. Yeah, it works, but not the way I want it to. It is a pain to manually select the OS I want each time a reboot is needed.

Thanks.

Frank.
Attachments
20190911_163815-small.jpg
Last edited by FrankB616 on Thu Sep 12, 2019 11:56 am, edited 1 time in total.

User avatar
Larry78723
Level 7
Level 7
Posts: 1660
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Fresh Mint xfce install - Still boots Windows 10

Post by Larry78723 » Wed Sep 11, 2019 7:48 pm

Frank, on that BIOS screen use the down arrow and go to the Ubuntu entry then hit the + until it is ahead of Windows Boot Manager. Hopefully, this will force Mint to boot ahead of Windows.
Image

athi
Level 6
Level 6
Posts: 1461
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: Fresh Mint xfce install - Still boots Windows 10

Post by athi » Wed Sep 11, 2019 8:35 pm

From the picture, there is 2 different boot loaders on SATA1 with Windows boot manager before Ubuntu. If you run GParted, you should see an EFI partition on SATA1 (should be /dev/sda), not sure if you will see EFI partition on SATA3 but right now the machine is booting from SATA1. As Larry78723 stated, you need to move Ubuntu before Windows boot manager. That should boot GRUB with Ubuntu and Win10 as options, Not sure if Ubuntu is Mint or Kubuntu or you may get both Mint and Kubuntu, that is a problem with dual booting multiple Ubuntu based distributions. Guess you will find out when you get GRUB going.

Also, I would move SATA1 before SATA3 to shorten the boot time.
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

FrankB616
Level 2
Level 2
Posts: 77
Joined: Wed Mar 27, 2019 1:50 pm

Re: Fresh Mint xfce install - Still boots Windows 10

Post by FrankB616 » Wed Sep 11, 2019 8:52 pm

Larry 78723:

I moved the ubuntu loader ahead of Windows, then pressed F10 to save and exit. Windows booted. I went back to the BIOS, and the Windows loader was again shown ahead of ubuntu. I tried again. Same story. BIOS allows me to make the edit, but it won't 'stick'.

athi:

I don't have multiple distros on this machine. I wiped Kubuntu 14.04 when I installed Mint 19.1. Mint 19.1 is the sole installation on the 250 GB SSD, and Windows is the sole OS on the mechanical drive.

I moved SATA3 to the head of the list as that is where Mint is located, and where GRUB should be located as well. If it is on SATA1 as well, then how can I get rid of it?

I'll have a look at the partitions with gparted and take some more pictures.

Thanks.

Frank.

User avatar
pbear
Level 9
Level 9
Posts: 2656
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Fresh Mint xfce install - Still boots Windows 10

Post by pbear » Wed Sep 11, 2019 9:17 pm

Important to know. In a UEFI install, the installer will put the bootloader on the first EFI partition it finds regardless of what you specify. I'd call it a bug. Unfortunately, I'm told, Mint isn't in a position to fix the installer, which originally comes from Ubuntu.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

athi
Level 6
Level 6
Posts: 1461
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: Fresh Mint xfce install - Still boots Windows 10

Post by athi » Wed Sep 11, 2019 10:09 pm

FrankB616, please boot into Mint live USB, copy and run below commands in Terminal (ctrl+alt+t) to output system information and post results. Should be simpler than taking and posting pictures.

Code: Select all

sudo parted -l

Code: Select all

efibootmgr -v
That is SUDO PARTED -L and EFIBOOTMGR -V all lower case if you are typing.
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

FrankB616
Level 2
Level 2
Posts: 77
Joined: Wed Mar 27, 2019 1:50 pm

Re: Fresh Mint xfce install - Still boots Windows 10

Post by FrankB616 » Wed Sep 11, 2019 10:30 pm

Great idea! Thanks!

Code: Select all

mint@mint:~$ sudo parted -l
Model: ATA WDC WD5000AZLX-0 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  274MB  273MB   fat32        EFI system partition          boot, hidden, esp
 2      274MB   408MB  134MB                Microsoft reserved partition  msftres
 3      408MB   466GB  466GB   ntfs         Basic data partition          msftdata
 4      466GB   467GB  1049MB  ntfs         Basic data partition          hidden, diag
 5      467GB   500GB  32.2GB  ntfs         Basic data partition          hidden, diag
 6      500GB   500GB  524MB   fat32        Basic data partition          hidden


Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sdb: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name                  Flags
 1      1049kB  538MB  537MB  fat32        EFI System Partition  boot, esp
 2      538MB   250GB  250GB  ext4


Model: SanDisk U3 Contour (scsi)
Disk /dev/sdc: 8221MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      31.7kB  8220MB  8220MB  primary  fat32        boot, lba


mint@mint:~$ efibootmgr -v
BootCurrent: 0009
Timeout: 1 seconds
BootOrder: 0009,0000,0001,0007,0008,0005,0006
Boot0000* Windows Boot Manager	HD(1,GPT,d5c74a07-4f64-426f-bdde-6021699b79d0,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...C................
Boot0001* ubuntu	HD(1,GPT,d5c74a07-4f64-426f-bdde-6021699b79d0,0x800,0x82000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0005* Generic Usb Device	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0006* CD/DVD Device	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0007  UEFI: IP4 Realtek PCIe GBE Family Controller	PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(1c666d97f589,0)/IPv4(0.0.0.00.0.0.0,0,0)..BO
Boot0008  UEFI: IP6 Realtek PCIe GBE Family Controller	PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(1c666d97f589,0)/IPv6([::]:<->[::]:,0,0)..BO
Boot0009* UEFI: SanDisk U3 Contour 4.04, Partition 1	PciRoot(0x0)/Pci(0x14,0x0)/USB(5,0)/HD(1,MBR,0x57cea,0x3e,0xf4f7c2)..BO
mint@mint:~$ 

athi
Level 6
Level 6
Posts: 1461
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: Fresh Mint xfce install - Still boots Windows 10

Post by athi » Wed Sep 11, 2019 11:31 pm

sudo parted -l shows both drives are GPT and both has EFI partition (/dev/sda1 and /dev/sdb1) but efibootmgr -v only show Windows boot manager and Ubuntu boot loader from the same drive (Windows drive). Looks like the last installation of Mint on the 250GB SSD created the EFI partition and installed boot loader on the 250GB SSD but for some reason this boot loader is not picked up by UEFI.

I would just reinstall Mint on sdb: boot into Mint live USB, reinstall Mint using the "Something Else" option, use the - icon to delete both partitions on sdb, use the + icon to create ext4 partition on sdb and set to /, and install boot loader to /dev/sda1 at bottom of installation screen.
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

FrankB616
Level 2
Level 2
Posts: 77
Joined: Wed Mar 27, 2019 1:50 pm

Re: Fresh Mint xfce install - Still boots Windows 10

Post by FrankB616 » Wed Sep 11, 2019 11:46 pm

athi:
Looks like the last installation of Mint on the 250GB SSD created the EFI partition and installed boot loader on the 250GB SSD but for some reason this boot loader is not picked up by UEFI.
Yeah. Weird.

Any chance that swapping plugs on the motherboard would do anything? This machine seems to be ignoring the selected boot order, and insists on booting from sda. I suspect that I can make the SSD show up as sda by swapping plugs.

Can the Ubuntu bootloader be removed from the Win10 disk? I imagine that it is pointing at the new Mint install, even though it was probably Kubuntu 14.04 that put it there.

Finally, I may just unplug the Win10 drive, leaving the SSD as the only drive, and then install again to that. That ought to fix its little red wagon. :-)

Anyway, it is getting late here now (at least for an old guy like me), so I'll tackle this again tomorrow.

Thanks.

Frank.

FrankB616
Level 2
Level 2
Posts: 77
Joined: Wed Mar 27, 2019 1:50 pm

Re: Fresh Mint xfce install - Still boots Windows 10

Post by FrankB616 » Thu Sep 12, 2019 11:55 am

Solution: If it is a Lenovo machine, remove the Win10 drive.

The UEFI firmware in this machine must be getting in the way. I understand that Lenovo machines do not always place nice with Linux, so I assume that this is an example.

I unplugged the Win10 drive, and put the Samsung SSD in the SATA1 slot, and then did another fresh install of Mint 19.1 xfce. All went to plan. I did a full update, and it completed successfully. Machine now boots to Linux because it has to.

Just out of curiosity, I reconnected the Win10 drive in the SATA3 slot, and rebooted -- straight to Windows. And this despite the fact that the Win10 disk is LAST on the Automatic Boot Sequence list. Trying to adjust that list did not stop Windows from booting, but it did trigger Win10's automatic repair utility, at which point I shut the machine down and unplugged the Win10 disk permanently.

FWIW, when this machine was new a couple of years ago, I did manage to get Linux to boot as default. However, after a Win10 update, I could never get it to do that again. I notice also that the UEFI firmware is set to receive updates. I can only assume that either Windows or Lenovo or both have messed with the guts of this machine to prevent it from booting anything other than Windows by default.

It can be FORCED to boot Linux when both drives are connected, and it will run just fine that way. However, this has to be selected manually each time it is booted. Yeah, I'm not willing to do that. We never use Windows anyway, and only have it on this machine because it came that way.

I know another Windows HDD that is going to be sitting on my shelf downstairs, waiting till the day that I sell this machine.... :-)

Frank.

athi
Level 6
Level 6
Posts: 1461
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: [Solved] Fresh Mint xfce install - Still boots Windows 10

Post by athi » Sat Sep 14, 2019 4:30 pm

Definitely sounds like some change to Win10 or Lenovo UEFI caused Mint EFI boot loader to be ignored if Win10 EFI boot manager is present. Things to check are if UEFI settings are still as before and if Win10 Fast Startup is disabled.

There were cases where even with secure boot disabled, machine would not boot to GRUB on a dual boot machine. One of the work around is to import "shimx64.efi" or "grubx64.efi" from /EFI/Ubuntu directory in the EFI partition into secure boot allowable key database.
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

FrankB616
Level 2
Level 2
Posts: 77
Joined: Wed Mar 27, 2019 1:50 pm

Re: [Solved] Fresh Mint xfce install - Still boots Windows 10

Post by FrankB616 » Sat Sep 14, 2019 4:39 pm

Thanks for your interest, but removing Win10 solved everything. :D

User avatar
kato181
Level 4
Level 4
Posts: 461
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: [Solved] Fresh Mint xfce install - Still boots Windows 10

Post by kato181 » Wed Sep 18, 2019 2:48 am

You could also check in the bios in the boot section to see which hard drive is selected as main boot. Push the SSD drive to either 2nd boot after (either dvd, or USB) and the windows drive as the last..see if that works.

Post Reply

Return to “Installation & Boot”