Page 1 of 1

HELP! Linux Mint 19.2 running as Virtual Machine, errors

Posted: Fri Sep 13, 2019 12:37 am
by Lmintuser1
Hi all. I'm new to Linux and to this forum. I have a old (but good) Precision 690 workstation running windows 10 pro 64bit, 32gb ram, Nvidia 970, 3 SSD 240gb drives with 3 Cheeta drives in Raid 5.
I'm trying to install the latest LinuxMint (19.2) as a virtual machine using VirtualBox (with the VB add-on extensions). This would be installed on a dedicated SSD drive with 16gb of ram dedicated to running Linux in VB. Attached is a screenshot of my settings in VirtualBox for LinuxMint.
VirtualBox setup screenshot.png

Here are the following problems I'm running into during install:
    30 seconds after clicking the VB START arrow, I get a blank screen saying [drm:vmw_host_log [vmwgfx]] *ERROR* Failed to send log" (I attached a snapshot of this error screen).
    Screenshot_2.png
      The Error screen lasts for 5 seconds then a loading Linux prompt appears, but hangs for a while...then a black screen of death for 5 minutes, then a "Virtual Guru Mediation" critical error prompt shows that ends the attempted install.

      I've tried numerous configurations in VirtualBox but nothing seems to fix this critical error. I even downloaded LinuxMint 19.2 from another server, thinking it may have been a corrupted download initially, but the problem still exists.
      I attached a copy of the entire release log file if that helps.
      Error Log file, LinuxMint19.2.64.zip
      (186.01 KiB) Downloaded 30 times
      Appreciate any and all help you folks can give.
      Thanks in advance!

      Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

      Posted: Fri Sep 13, 2019 6:55 am
      by coffee412
      For your video driver in settings/display it looks like your using the VMSVGA driver?. I use the VBoxSVGA driver with 3d acceleration.

      I think I saw in your logs that the expansion pack is not installed either?

      Code: Select all

      00:00:05.674190 Installed Extension Packs:
      00:00:05.674249   None installed!


      coffee

      Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

      Posted: Fri Sep 13, 2019 11:37 am
      by Lmintuser1
      Hi Coffee! TY for your reply.
        Regarding the video setting in VBox...yes, i was using VMSVGA setting but I also tried the other ones (including VBoxSVGA). Here is the error screen I receive after 10 minutes
        9.13.19 LinuxMint error screen.png
          Regarding the expansion pack...i apologize...the first log sheet I posted was before I did the extension pack...i installed the extension pack and was getting the same error messages. Here is the current log sheet as of 9/13/19.
          LinuxMint log, 19.2-2019-09-13-11-28-17.zip
          (183.75 KiB) Downloaded 37 times
          Here is the screenshot of my VBox set up, using the VBoxSVGA too.
          9.13.19 LinuxMint screenshot VBoxSVGA.png
          Ty in advance for anyone's help!

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Fri Sep 13, 2019 12:08 pm
          by ajgringo619
          What version of VB are you running? If it's v6.0.10, I'd either downgrade to 08 or upgrade to 12.

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Fri Sep 13, 2019 12:39 pm
          by pbear
          Per the VBox manual, VBoxSVGA is intended for Windows guests. VMSVGA is the intended driver for Linux guests. And I have all three current versions of Mint running in VBox using that driver, on both Windows and Mint as hosts.

          Bear in mind, 3D acceleration won't work until you've installed guest additions and you can't do that until you've completed installation and rebooted.

          Anyhoo, I'm envious. I've never had a Guru Mediation and had to look up what it means. FWIW, this smells like a host issue to me. Have you tried searching on the VBox Forum?

          ETA: Took a glance myself (not an exhaustive search). Found a couple threads (here and here) with your error message, but no resolution. From another, found a command which suggests how this is supposed to look. Running that on my Cinn 19.2 VM (which works) produces this output:

          Code: Select all

          pbear@vbox-cinn-19-2:~$ lsmod | grep vbox
          vboxsf                 77824  1
          vboxvideo              36864  0
          vboxguest             335872  6 vboxsf
          ttm                   106496  2 vmwgfx,vboxvideo
          drm_kms_helper        172032  2 vmwgfx,vboxvideo
          drm                   401408  9 vmwgfx,drm_kms_helper,vboxvideo,ttm
          Not sure that helps, but thought I'd pass along just in case.

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sat Sep 14, 2019 1:45 am
          by Lmintuser1
          ajgringo619 wrote:
          Fri Sep 13, 2019 12:08 pm
          What version of VB are you running? If it's v6.0.10, I'd either downgrade to 08 or upgrade to 12.
          I'm running VB, Version 6.0.12 r133076 (Qt5.6.2). I may resort to your suggestion to downgrade to 08 as a last resort, but i'm still trying to make 6.0.12 work.
          ty for the suggestion!

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sat Sep 14, 2019 1:53 am
          by Spearmint2
          why are you assigning your entire RAM to a virtual system? Or do you have MORE than 16GB RAM?

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sat Sep 14, 2019 10:20 am
          by Lmintuser1
          Spearmint2 wrote:
          Sat Sep 14, 2019 1:53 am
          why are you assigning your entire RAM to a virtual system? Or do you have MORE than 16GB RAM?
          I have 32gb ram and will have 48 shortly. In the end, i'll be dedicating 16gb ram to the virtual system and keeping 32gb for my host.

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sat Sep 14, 2019 11:49 am
          by pbear
          By the way, if you decide to submit this on the VBox Forum, I'm pretty sure they'll want you to use the Linux-as-guest subforum rather than Windows as host. The as-host forums seem to be focused on installing VBox itself, whereas guest installation issues go there. As mentioned, I think your problem is host related, so it's a hybrid, but I think you're still supposed to use Linux-as-guest. In any event, pick one (don't cross-post). Also, review their submission guidelines before posting. Based on your OP here, you'll have no trouble complying. Just a head's up. Good luck.

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sat Sep 14, 2019 1:20 pm
          by Lmintuser1
          pbear wrote:
          Sat Sep 14, 2019 11:49 am
          By the way, if you decide to submit this on the VBox Forum, I'm pretty sure they'll want you to use the Linux-as-guest subforum rather than Windows as host. The as-host forums seem to be focused on installing VBox itself, whereas guest installation issues go there. As mentioned, I think your problem is host related, so it's a hybrid, but I think you're still supposed to use Linux-as-guest. In any event, pick one (don't cross-post). Also, review their submission guidelines before posting. Based on your OP here, you'll have no trouble complying. Just a head's up. Good luck.
          Thank you pbear for your help! I read your first reply about how you did some searching and found some info but nothing concrete in terms of fixing the issue i'm having. I appreciate you doing that. I've been trying everything since and nothing seems to be working....still same error codes and no VM booting, even while using VMSVGA as you suggested with and without 3D acceleration. I think it's a host issue too, i just don't have a clue what it could be. I enabled the Virtual ability in BIOS so it can't be that. There is certainly enough ram, cores, and hd space, so those are ruled out too. I'll look into VBox forum and see what i find.

          Your last reply post mentioned i should post this in the Linux-as-guest subforum. I can't find that thread. Can you please give me the link to that thread and I'll just post there instead of here. Thanks!

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sat Sep 14, 2019 5:51 pm
          by Spearmint2
          Which bit version of Linux used? 32 bit or 64? Xeon processors are x86 I believe. What Xeon processors used?

          https://www.dell.com/downloads/global/p ... 690_en.pdf

          according to this your Xeon supports 64 bit systems. Is this accurate?
          Dual-core Intel® Xeon® 5100 series processors with up to 1333MHz front side bus and 4MB shared cache; Quad-core Intel Xeon 5300 series processors with up to 1333MHz front side bus and 2 x 4MB shared cache; All processors are 64-bit, XD and VT capable

          I notice for example, that RedHat doesn't support a lot of Xeon processors.

          https://access.redhat.com/support/policy/intel

          graphics use with Xeon, this may or not apply here.

          viewtopic.php?t=252024

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sat Sep 14, 2019 10:42 pm
          by Lmintuser1
          Spearmint2 wrote:
          Sat Sep 14, 2019 5:51 pm
          Which bit version of Linux used? 32 bit or 64? Xeon processors are x86 I believe. What Xeon processors used?

          https://www.dell.com/downloads/global/p ... 690_en.pdf

          according to this your Xeon supports 64 bit systems. Is this accurate?
          Dual-core Intel® Xeon® 5100 series processors with up to 1333MHz front side bus and 4MB shared cache; Quad-core Intel Xeon 5300 series processors with up to 1333MHz front side bus and 2 x 4MB shared cache; All processors are 64-bit, XD and VT capable

          I notice for example, that RedHat doesn't support a lot of Xeon processors.

          https://access.redhat.com/support/policy/intel

          graphics use with Xeon, this may or not apply here.

          viewtopic.php?t=252024
          Hello Spearmint. You are correct, i am using a Dell 690 Precision 64bit Quad-core Intel Xeon 5130 Woodcrest 65nm Technology at 2.00ghz each. I believe it has 1333MHz front side buss at 2 x 4MB shared cache. Here is a snapshot of them.
          CPU info snapshot.png
          I checked that link you sent for non-supported Xeon processors but i didn't see 5100 or 5300 series in the list.
          Yeah, i use a Nvidia 960 card, so i don't think the Xeon GPU (if it has one built in) relates at this point...but i could be wrong.

          I recently changed my allocated processor core usage within VBox from 4 down to 2. I started up Linux and it gave me the same error messages but then somehow it got to the Linux home desktop screen. But, within 5 seconds i got a Guru Meditation error prompt. Here's a screenshot of it.
          9.14.19 LinuxMint Guru error screen (1).png
          . The options were either to close out or Ignore...i tried Ignore and then my mouse and keyboard didn't work within the Linux desktop. I think it put me in a debug mode or something. I since tried every other core (1,3,4) to see what happens but they didn't get me as far as using 2 cores.

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sat Sep 14, 2019 11:17 pm
          by Spearmint2
          But it works OK if using just one core?!

          I'm going to assume it works in Linux, based on it used with Fedora 5 in this several pages article.

          https://www.phoronix.com/scan.php?page= ... =521&num=1

          Did you ever check that vbox log it mentioned in the error msg? May need to change some vbox setting. Seems the answer to this is with vbox alone.

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sat Sep 14, 2019 11:29 pm
          by pbear
          Lmintuser1 wrote:
          Sat Sep 14, 2019 1:20 pm
          Your last reply post mentioned i should post this in the Linux-as-guest subforum. I can't find that thread. Can you please give me the link to that thread and I'll just post there instead of here. Thanks!
          It's a subforum at VBox Forums, not here. By the way, if you find the answer, please let us know what it turns out to be. Thanks.

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sat Sep 14, 2019 11:35 pm
          by catweazel
          Lmintuser1 wrote:
          Sat Sep 14, 2019 1:20 pm
          I think it's a host issue too...
          It is. Your Xeon processor doesn't support VT-x all that well. It's unlikely that you'll get it working properly, if at all, except perhaps on a single core. About the only thing you can do is try posting about your issue on https://forums.virtualbox.org where there is specialised knowledge available.

          Re: HELP! Linux Mint 19.2 running as Virtual Machine, errors

          Posted: Sun Sep 15, 2019 2:44 am
          by Lmintuser1
          catweazel wrote:
          Sat Sep 14, 2019 11:35 pm
          Lmintuser1 wrote:
          Sat Sep 14, 2019 1:20 pm
          I think it's a host issue too...
          It is. Your Xeon processor doesn't support VT-x all that well. It's unlikely that you'll get it working properly, if at all, except perhaps on a single core. About the only thing you can do is try posting about your issue on https://forums.virtualbox.org where there is specialised knowledge available.
          Hi catweazel. That's a downer if the Xeon doesn't support VT-x that good...but then why would it have an option to turn on virtualization in the Bios, which i did? What you said about cores though seems to be true because I've been trying other version of Mint...so far this is what i'm finding:
          I tried Mint 19.2 MATE on 4 cores with VboxSVGA. No errors showed but it took FOREVER to finally get to the home screen. Everything seemed ok...but moving at a snails pace. Could this be because i haven't done the final step yet of mounting the ISO file after i load up Linux? I logged out and changed my cores to 2 and MATE loaded up faster and Linux desktop was more manageable, but still sluggish. I'm hoping that once mounting is done then it will be faster. Once I do that i'll retest the 4 cores and see how it performs. If still sluggish, i'll resort to 2 cores. I'll post back when i do all this. Now that i know MATE somewhat works on 19.2, i'll be putting it on a dedicated SSD which is on the way to me. It may be a little bit of time till i post the update on this thread again. I also posted on the VB site you gave...i'm waiting till tomorrow because they won't let me post till i'm a day old. LOL. smh. Thanks catweazel!