Unable to update system package grub-efi-amd64-signed [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
josefg
Level 2
Level 2
Posts: 85
Joined: Sun Jun 12, 2011 7:07 pm

Unable to update system package grub-efi-amd64-signed [SOLVED]

Post by josefg » Sat Sep 14, 2019 7:11 am

Hi,

I just did a clean install on a new laptop, by installing Linux Mint 19 Main Edition, Cinnamon, and then upgrading it to Mint 19.2. Then, I wanted to apply all pending system updates, but I am coming across a problem with the package grub-efi-amd64-signed. Here is my output from the terminal:

Code: Select all

myuser@pc:~$ sudo dpkg --configure -a
[sudo] password for myuser:          
Setting up grub-efi-amd64 (2.02-2ubuntu8.13) ...
dpkg: error processing package grub-efi-amd64 (--configure):
 installed grub-efi-amd64 package post-installation script subprocess returned error exit status 255
dpkg: dependency problems prevent configuration of grub-efi-amd64-signed:
 grub-efi-amd64-signed depends on grub-efi-amd64 | grub-pc; however:
  Package grub-efi-amd64 is not configured yet.
  Package grub-pc is not installed.

dpkg: error processing package grub-efi-amd64-signed (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 grub-efi-amd64
 grub-efi-amd64-signed
I also tried the following:

Code: Select all

myuser@pc:~$ sudo dpkg --configure grub-efi-amd64
[sudo] password for myuser:          
Setting up grub-efi-amd64 (2.02-2ubuntu8.13) ...
dpkg: error processing package grub-efi-amd64 (--configure):
 installed grub-efi-amd64 package post-installation script subprocess returned error exit status 255
Errors were encountered while processing:
 grub-efi-amd64
Any advice available?

Thanks in advance.
Last edited by josefg on Sun Sep 15, 2019 3:29 pm, edited 1 time in total.

User avatar
blueocean
Level 5
Level 5
Posts: 768
Joined: Sun Jul 08, 2018 11:50 pm

Re: Unable to update system package grub-efi-amd64-signed

Post by blueocean » Sat Sep 14, 2019 11:13 pm

Try going to the update manager and click edit>software sources>maintenance>click on the first 3 in the list one at a time. Then try refreshing the updates.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

josefg
Level 2
Level 2
Posts: 85
Joined: Sun Jun 12, 2011 7:07 pm

Re: Unable to update system package grub-efi-amd64-signed

Post by josefg » Sun Sep 15, 2019 3:28 pm

Thanks for the advice. I did so, and then ran the updates from the terminal (sudo mintupdate-cli upgrade), and it worked!

Post Reply

Return to “Installation & Boot”