Page 1 of 1

[SOLVED] grub on wrong partition

Posted: Wed Sep 18, 2019 10:18 am
by shmu
I have a multiboot setup
1 Windows 10
2 MX Linux
3 Linux Mint

In my firmware I see boot entries for all 3, but one of them does not actually work, and that is #3, Linux Mint.
I can boot into Mint from the MX grub menu, but not from the (non-existent) Mint grub menu, which I used to have. :?
So how can I get it back? I tried running sudo update-grub from inside Mint, but to no avail.
Is there a way to do it without booting from a Mint flash drive? ATM I have only a MX flash drive. :(

Re: grub on wrong partition

Posted: Wed Sep 18, 2019 10:23 am
by Flemur
shmu wrote:
Wed Sep 18, 2019 10:18 am
I have a multiboot setup
1 Windows 10
2 MX Linux
3 Linux Mint

In my firmware I see boot entries for all 3, but one of them does not actually work, and that is #3, Linux Mint.
I can boot into Mint from the MX grub menu, but not from the (non-existent) Mint grub menu, which I used to have. :?
So how can I get it back? I tried running sudo update-grub from inside Mint, but to no avail.
Is there a way to do it without booting from a Mint flash drive? ATM I have only a MX flash drive. :(
Boot mint and then run

Code: Select all

sudo grub-install /dev/sda
sudo update-grub
The first cmd makes grub get its menu from the mint install, and the second updates that menu.
If /dev/sda is not correct, use the correct value...

Re: grub on wrong partition

Posted: Wed Sep 18, 2019 10:37 am
by shmu
Flemur wrote:
Wed Sep 18, 2019 10:23 am
Boot mint and then run

Code: Select all

sudo grub-install /dev/sda
sudo update-grub
The first cmd makes grub get its menu from the mint install, and the second updates that menu.
If /dev/sda is not correct, use the correct value...
Thanks!
I ran that command, only adding the exact partition number to make sure grub will know where to go
sudo grub-install /dev/sda6
and it worked like a charm.

Re: [SOLVED] grub on wrong partition

Posted: Fri Sep 20, 2019 12:57 am
by ricardogroetaers
shmu,
Thanks for this topic.

Could inform me:
1- Is your machine BIOS or UEFI?
2- Is your disk partitioning MBR or GPT?

Re: [SOLVED] grub on wrong partition

Posted: Fri Sep 20, 2019 1:10 am
by shmu
EFI and GPT