xorg.conf keeps reverting!

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Mon Aug 03, 2009 6:04 am

xorg.conf keeps reverting!

Postby ms2k » Mon Aug 03, 2009 6:19 am

I have a new Linux Mint 7 install on an older model Dell Inspiron 1100 laptop.

The default install doesn't recognize the internal video, and is limited to 800x600 with no option for changes.

As a result, I've been attempting to modify the "/etc/X11/xorg.conf" file for compatibility with the hardware. I've modified the file many times as sudo and saved it, and then restarted Linux.

However, after each restart, the xorg.conf file reverts to this simple text:

Code: Select all

Section "ServerFlags"
   Option   "DontZap"   "False"

Obviously, that's not much of a configuration. Does anybody know why this file keeps reverting to this "unconfigured" state following each restart? It doesn't seem to matter what code i use to modify the file, whether it's just a small change or the addition of many sections. In all cases, once I save and restart, it reverts back to the above unconfigured state.

Level 8
Level 8
Posts: 2158
Joined: Thu Feb 26, 2009 8:58 pm

Re: xorg.conf keeps reverting!

Postby emorrp1 » Mon Aug 03, 2009 7:55 am

Well I don't know why it's reverting, as mine is fine, but there is one thing I know that could (but shouldn't) affect it: mint's auto-enabling of dontzap You can disable it by editing /etc/linuxmint/mintSystem.conf and changing True to False in the ctrl-alt-backspace line. Other than that, I'm not sure (but you might want to lookup "bullet-proof X"), anyone else know what's going on?
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com

Return to “Installation & Boot”