Page 1 of 1

Mint 19.3 Grub issue

Posted: Sat Dec 21, 2019 2:54 am
by praveenp
I've updated one of my Linux mint (Lenovo ideapad 100) netbook. But after updating, grub doesn't work as expected with new mint theme. Menu highlighting for selected item doesn't work in new grub menu. I am able to switch item by counting and pressing up arrow or down arrow and then press enter, but no visible hint is available. I decided to switch to default grub version (which worked without any problem all these years), so I have commented

Code: Select all

# GRUB_THEME=
from

Code: Select all

/etc/default/grub
and tried to update grub. But nothing really changed. I also tried to remove mint theme by

Code: Select all

apt remove grub2-theme-mint 
, but it also failed to update grub by the error
Generating grub configuration file …
/usr/sbin/grub-probe: error: failed to get canonical path of `/boot/grub/fonts/UbuntuMono32.pf2′.
Any help.

Re: Mint 19.3 Grub issue

Posted: Sat Dec 21, 2019 9:52 am
by praveenp
After some failed attempts, and reading the grub-update error :wink: , I am able to uninstall Mint's grub theme and update grub. I just edited 60_mint-theme.cfg using

Code: Select all

sudo xed /etc/default/grub.d60_mint-theme.cfg
and replaced the line "GRUB_FONT="/boot/grub/fonts/UbuntuMono32.pf2"" by "GRUB_FONT="/boot/grub/unicode.pf2""
I have also commented theme part as '#GRUB_THEME="/boot/grub/themes/linuxmint/theme.txt"'

Grub got good old appearance, and works perfectly.