Error with gnome-keyring-daemon

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
thomas.raines
Level 1
Level 1
Posts: 43
Joined: Mon Feb 11, 2013 12:03 am

Error with gnome-keyring-daemon

Post by thomas.raines »

Hi all. I hope this is the right seciton to post this in. If not, let me know...
So, I recently reconfigured my system setup. I separated sda into 2 partions. On sda1 is my "system" partition, and sda2 is my "home" partition. I don't feel the reasons behind this is important, so I'll spare you the details. However, after doing this, I started having issues of my 5ghz wifi taking a while to connect at start up. Somethimes it would only take a few seconds, other times a few minutes. I deleted the connection and then created a new connection. But it still takes a bit to connect after start up. My 2.5ghz is connected as soon as the desktop pops up. I took a look at my .Xsession.erros log and found this:

Code: Select all

** Message: 19:46:00.261: couldn't access control socket: /run/user/1000/keyring/control: No such file or directory
I have seen this error before, and the fix was to add a few bits to my .bashrc:

Code: Select all

eval $(/usr/bin/gnome-keyring-daemon --start --components=gpg,pkcs11,secrets,ssh)
export $(gnome-keyring-daemon --start --components=pkcs11,secrets,ssh,gpg)
dbus-update-activation
And then run in terminal:

Code: Select all

sudo setcap cap_ipc_lock=+ep `which gnome-keyring-daemon`-environment --systemd DISPLAY
But, I already had that code in my .bashrc. So I started searching the web. I came up with several different solutions that included adding the code above to /etc/X11/xinit/xinputrc, adding code to /etc/pam.d/login:

Code: Select all

session    optional     pam_gnome_keyring.so        auto_start
auth       optional     pam_gnome_keyring.so
and add some code to /etc/pam.d/passwd:

Code: Select all

password	optional	pam_gnome_keyring.so
But still, the error persisits, and I couldn't connect to wifi. The file does exist and when I run

Code: Select all

file /run/user/1000/control
I get

Code: Select all

 /run/user/1000/keyring/control: socket
I flushed all my passphrases from gnome-keyring with

Code: Select all

gnome-keyring-daemon -r -d
And I even deleted my entire keyring and started over. But alas, the error still persists. At some point, I was led to run im-config and set it to empty. Amonst doing all this, I some how went from having only 1 instance of the above error, to now three entries in my .Xsession-erros log. So, I disabled auto login, rebooted and checked the .Xsession-errors log and the error was no longer present, and my 5ghz wifi connected right away.
Being that this is a home computer and only 1 account on it, my family and I like the auto log in.

I am on Linux Mint 19.1
kernel 4.17.0-lz+2 ( My custom built kernel)
Network controller: Broadcom Inc. and subsidiaries BCM4352 802.11ac Wireless Network Adapter (rev 03)

I have read that seahorse does not have this issue, but am reluctant to install it. I was going to perform a fresh install of Mint 19.3, but when I started the live session, I checked .Xsession-error and the error was there as well. So I created a persistant usb of Mint 19.3, created a new user account and logged into it (after reboot) with a password. Again, no gnome-keyring-daemon error. My wireless card doesn't work until I install the proprietary drivers, so I did that, rebooted, and logged in with password. Again, no error and wireless connected right away. So I enabled auto login with new user account, rebooted and the error has returned.

I feel this could be a bug with either lightdm or auto login... or both?
Is this error related to the delay on wifi connection, or could the wifi issue be something completely different?
Any ideas for a fix would be greatly welcomed.
Post Reply

Return to “Installation & Boot”