Can't Boot from Cruzer Micro? (SOLVED)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
User avatar
Level 14
Level 14
Posts: 5126
Joined: Mon Dec 01, 2008 11:21 am

Can't Boot from Cruzer Micro? (SOLVED)

Postby viking777 » Tue Aug 11, 2009 9:14 am

This is not a question it is an answer. It is a very hard won answer as it has taken me months to figure it out, and yet it is also a very simple answer. I thought I would share it with you in case anyone else has the same problem - I have never seen this answer written down before (that doesn't mean to say that it hasn't been, just that it is not easy to find!)

We all know (well most of us) that in order to boot from USB devices you have to have a boot order something like:

2 CD
3 HD

Mine has been set like that since I bought this machine. I have three perfectly workable USB pen drives containing things like parted magic and clonezilla/systemrescue and Puppy linux. I decided I wanted another containing Super Grub Disk. I purchased a SanDisk Cruzer Micro 2Gb and proceeded to put SGD onto it - it wouldn't boot. On and off over the course of several months I have tried again and again to make this work with every conceivable variation of file system, partition size, installation method, even distro. The result was always the same.

Today I decided that I would try SGD on one of the other pen drives I have. I used unetbootin to install, and it worked straight away. I then decided to try again with a different distro on the Cruzer (DSL) - It wouldn't boot.

So this is where the embarassing part comes. I booted again with the Cruzer plugged in and this time hit F2 to enter setup. Scrolled along to the boot section and sure enough the boot order was exactly as above with one exception. Coming in at #4 was a new entry called "San Disk Cruzer HDD"! This was a surprise to me as it was never there before. Obviously what happens with this particular device (on my bios anyway) is that it creates a completely new bios entry for the device that is not covered by the default 'USB' entry and since it was positioned after the 'HD' entry it would never boot.

I moved it up to the #2 position in the boot order, rebooted and DSL Linux came up straight away. Months of frustrating puzzlement over!

Maybe I am the only person in the world that didn't know this, but I doubt it.

Anyway I know it now - and if you have read this far then so do you!
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

Level 8
Level 8
Posts: 2158
Joined: Thu Feb 26, 2009 8:58 pm

Re: Can't Boot from Cruzer Micro? (SOLVED)

Postby emorrp1 » Tue Aug 11, 2009 11:36 am

Strange, perhaps it's not a normal USB drive. Either way, thanks for writing this up, hopefully it'll save other people months of frustration.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term

Return to “Installation & Boot”

Who is online

Users browsing this forum: No registered users and 8 guests