Shutdown problems - Failed to wait for process: Protocol error

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
codifex
Level 1
Level 1
Posts: 2
Joined: Fri Feb 14, 2020 11:46 am

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by codifex »

Same problem on my PC, the error message is shown instead of the the graphical "washing machine" shutdown screen before the PC turns off.

Tests revealed that the problem also occurs in a Linux Mint VirtualBox VM running on this PC. However, the error message is not shown in the virtual machine unless you press the Esc key while shutting down in order to show the status messages. The error messages are the last messages shown before the virtual machine turns off (the window closes).

Possibly more/all (?) systems are affected by the problem, but for some reason the error message might be covered by the graphical shutdown animation.
ericj
Level 2
Level 2
Posts: 57
Joined: Tue Jan 01, 2019 1:42 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by ericj »

Maybe you aren't running Mint, I never see any graphic such as a "washing machine" ... these messages don't seem to affect anything else.
codifex
Level 1
Level 1
Posts: 2
Joined: Fri Feb 14, 2020 11:46 am

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by codifex »

I am running Linux Mint 19.3 "Tricia" (Cinnamon edition), which includes an animated Plymouth splash/shutdown screen (animated Mint logo, "Washing Machine", see https://linuxmint.com/rel_tricia_cinnamon_whatsnew.php for details).

Prior to the casper/finalrd update the animated shutdown screen was shown until the machine turned off. After the update, during shutdown the error message is shown instead of the animated shutdown screen on the PC. In the virtual machine, the animated shutdown screen is still shown. By pressing the Esc key, it's possible to switch between the graphical shutdown screen and the status messages. In the status messages the error message is shown.
ericj
Level 2
Level 2
Posts: 57
Joined: Tue Jan 01, 2019 1:42 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by ericj »

Oh, OK ... I didn't think it was that you were referring to, was about to stuff some laundry into my USB drive :lol:

Seems this error text thing is a non-issue that should be resolved eventually.
shockedquartz
Level 1
Level 1
Posts: 25
Joined: Tue Dec 17, 2019 3:31 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by shockedquartz »

Also having the same problem.
At shutdown or reboot:

Code: Select all

shutdown[1] Failed to wait for process: Protocol error 
shutdown[1] Failed to wait for process: Protocol error 
shutdown[1] Failed to wait for process: Protocol error 
shutdown[1] Failed to wait for process: Protocol error 
shutdown[1] Failed to wait for process: Protocol error 
shutdown[1] Failed to wait for process: Protocol error 
I checked my apt history and casper and finalrd were updated around the same time it showed up.

Code: Select all

/var/log/apt# egrep -i -B5 -A5 'casper|final' *
history.log-Start-Date: 2020-02-02  16:27:37
history.log-Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id o -o Synaptic::closeZvt=true --set-selections-file /tmp/tmpl89dsnf6
history.log-Requested-By: 
history.log:Install: ...... finalrd:amd64 .... casper:amd64 ........
history.log-End-Date: 2020-02-02  16:30:09
Are they safe to remove or downgrade??
HAWR
Level 6
Level 6
Posts: 1299
Joined: Thu Jun 06, 2019 1:15 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by HAWR »

Hello shockedquartz,

you can remove casper and finalrd (best in the synaptic package manager), but since the systems are still stable, you can also just ignore the messages and wait until it will be solved by an update .
ericj
Level 2
Level 2
Posts: 57
Joined: Tue Jan 01, 2019 1:42 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by ericj »

I've now noticed another minor issue which may or may not be connected to this (which is still happening).

When I shut down or reboot it takes forever (as in 20-30 seconds) before anything happens ... tone or desktop disappearing. First couple times this happened I actually clicked the Restart again thinking maybe I didn't fully click it but it wasn't that.

Anyone else in this thread noticing this?
meco
Level 1
Level 1
Posts: 4
Joined: Mon Nov 19, 2018 7:38 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by meco »

Have the same issue as TS and it started around the same period. When I reboot or shutdown my PC this message shows a split second on the screen. The system does not hang.

I have searched online and found some topics, but could not find an actual bug report or something. Does anyone know if this bug is confirmed by the developers of the related software or OS?

Image
alderny
Level 1
Level 1
Posts: 4
Joined: Sun Feb 25, 2018 8:58 am
Location: Bournemouth, UK
Contact:

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by alderny »

Just to add my voice to this thread to say that I also get exactly this problem in 19.3. I don't look at this forum very often, but picked this up on a Google search.
Leminway
Level 2
Level 2
Posts: 89
Joined: Wed Jan 22, 2020 12:27 pm
Location: France

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by Leminway »

Hi,
I also have a problem with Mint shutdown on my two notebook with 32 bits. Mint only shutdowns when you insist on pressing the power key. So far, no explanation. Could be annoying...
User avatar
karlchen
Level 21
Level 21
Posts: 13547
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by karlchen »

Hello, folks.

Until a few days ago, I had not seen the reported behaviour on any of my Linux Mint 19.x systems: [1], [2], [3], [4]

But after having installed the most recent system software updates on my LM 19.3 xfce system, I have seen the reported behaviour on several shutdowns and reboots in a row.
I will neither speculate, nor discuss the question which of the following updated components can be rightly blamed for being the culprit:
+ mesa 19.2.8-0ubuntu0~18.04.3
+ linux-firmware 1.173.15
+ linux kernel 4.15.0.88
Reason:
To me it looks as if it may be a timing issue really. Very likely one or more shutdown steps take a little bit more time than before, thus triggering the reported behaviour.

Workaround / solution:
By default, Linux Mint 19.3 will reduce the systemd parameter DefaultTimeoutStopSec from 90s to 10s.
File: /etc/systemd/system.conf.d/50_linuxmint.conf

As my LM 19.3 xfce machine is really slow, 10s was much too short for my liking. So I did as suggested in the comment lines in file 50_linuxmint.conf and created a file overriding the 10s with 45s.
File: /etc/systemd/system.conf.d/55_custom.conf
Parameter: DefaultTimeoutStopSec=45s
This timeout applies to system processes as well as user processes, unless a different timeout is specified for user processes.

This is what has been done here.
File: /etc/systemd/user.conf.d/60_custom.conf
Parameter: DefaultTimeoutStopSec=30s

Since during shutdown / reboot, systemd grants user processes up to 30 seconds to terminate themselves and grants system processes up to 45 seconds to terminate themselves, before killing them forcefully, I have not experienced the reported problem again.

I assume that the appropriate timeout values will be different for different machines. The faster the machine is, the shorter the timeouts may be. So it is a bit of trial and error.

Hope this will help other affected users as well.

Best regards,
Karl

---Appendix---
  • Details on configuring timeouts for system processes and user processes: man 5 systemd-system.conf, comment lines in the files system.conf and user.conf
  • Location of system wide configuration files: /etc/systemd/system.conf.d
    Location of user configuration files: /etc/systemd/user.conf.d
    In case either of the 2 subdirectories should not exist, create it with root permissions:
    sudo mkdir /etc/systemd/system.conf.d # on LM 19.3 it will exist
    sudo mkdir /etc/systemd/userconf.d # this sub-directory will not exist be default
  • Content of the LM 19.3 provided file /etc/systemd/system.conf.d/50_linuxmint.conf

    Code: Select all

    # To override these values, create your own file in /etc/systemd/systemd.conf.d/60_custom.conf.
    # Reload configuration with "sudo systemctl daemon-reload"
    # Test with "systemctl show"
    [Manager]
    # Reduce shutdown timeout from 90s to 10s.
    # If you rely on important tasks to successfully finish during the shutdown sequence, set the timeout to something greater than 90s.
    DefaultTimeoutStopSec=10s
    # trailing explanation dropped, read the file
  • Overriding systemwide file /etc/systemd/system.conf.d/55_custom.conf
    Create it using the commandline sudoedit /etc/systemd/system.conf.d/55_custom.conf
    Content:

    Code: Select all

    [Manager]
    DefaultTimeoutStopSec=45s
    Make systemd use the changed timeout immediately, without rebooting: sudo systemctl daemon-reload
  • Overriding user file /etc/systemd/user.conf.d/60_custom.conf
    Create it using the commandline sudoedit /etc/systemd/user.conf.d/60_custom.conf
    Content:

    Code: Select all

    [Manager]
    DefaultTimeoutStopSec=30s
    Make systemd use the changed timeout immediately, without rebooting: systemctl --user daemon-reload
  • Check the changes have taken effect:
    - systemwide: systemctl show
    - user: systemctl --user show
My LM 19.3 xfce system overview:

Code: Select all

karl@unimatrix0:~$ inxi -Fx3z
System:    Host: unimatrix0 Kernel: 4.15.0-88-generic i686 bits: 32 compiler: gcc v: 7.4.0 Desktop: Xfce 4.14.1 
           tk: Gtk 3.22.30 info: xfce4-panel wm: xfwm4 dm: LightDM 1.26.0 Distro: Linux Mint 19.3 Tricia 
           base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop Mobo: N/A model: N/A serial: <filter> BIOS: American Megatrends v: 080015 date: 10/09/2009 
CPU:       Topology: Dual Core model: Intel Atom 330 bits: 64 type: MT MCP arch: Bonnell rev: 2 L2 cache: 512 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 12799 
           Speed: 1600 MHz min/max: N/A Core speeds (MHz): 1: 1600 2: 1600 3: 1600 4: 1600 
Graphics:  Device-1: NVIDIA C79 [ION] vendor: ZOTAC driver: nouveau v: kernel bus ID: 03:00.0 chip ID: 10de:087d 
           Display: x11 server: X.Org 1.19.6 driver: nouveau unloaded: fbdev,modesetting,vesa compositor: compton 
           v: 0.1~beta2+20150922 resolution: 1280x1024~60Hz 
           OpenGL: renderer: NVAC v: 3.3 Mesa 19.2.8 direct render: Yes 
Audio:     Device-1: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:08.0 chip ID: 10de:0ac0 
           Sound Server: ALSA v: k4.15.0-88-generic 
Network:   Device-1: NVIDIA MCP79 Ethernet vendor: ZOTAC driver: forcedeth v: kernel port: d080 bus ID: 00:0a.0 
           chip ID: 10de:0ab0 
           IF: enp0s10 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR9285 Wireless Network Adapter vendor: AzureWave AW-NE785 / AW-NE785H 802.11bgn 
           driver: ath9k v: kernel port: ec00 bus ID: 04:00.0 chip ID: 168c:002b 
           IF: wlp4s0 state: up mac: <filter> 
Drives:    Local Storage: total: 164.00 GiB used: 12.31 GiB (7.5%) 
           ID-1: /dev/sda vendor: Samsung model: HM160HI size: 149.05 GiB speed: 1.5 Gb/s serial: <filter> rev: 0-08 
           scheme: MBR 
           ID-2: /dev/sdb type: USB vendor: Transcend model: JetFlash Transcend 16GB size: 14.95 GiB speed: 1.5 Gb/s 
           serial: <filter> rev: 8.07 scheme: MBR 
Partition: ID-1: / size: 47.12 GiB used: 12.29 GiB (26.1%) fs: ext4 dev: /dev/sda6 
           ID-2: swap-1 size: 5.05 GiB used: 17.2 MiB (0.3%) fs: swap dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 86.0 C mobo: N/A gpu: nouveau temp: 62 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 189 Uptime: 1h 37m Memory: 1.65 GiB used: 833.9 MiB (49.3%) Init: systemd v: 237 runlevel: 5 Compilers: 
           gcc: 7.4.0 alt: 7 Shell: bash v: 4.4.20 running in: xfce4-terminal inxi: 3.0.37
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)
HAWR
Level 6
Level 6
Posts: 1299
Joined: Thu Jun 06, 2019 1:15 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by HAWR »

Hello karlchen,

I've read in the german linux forum, that removing casper and finalrd (which was new installed with last casper version) packages let the error messages disappear.
ZFR
Level 2
Level 2
Posts: 80
Joined: Sat Jan 11, 2020 8:23 am

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by ZFR »

karlchen wrote:
Sat Mar 07, 2020 12:31 pm


Hope this will help other affected users as well.

Hi,

Thanks for your help, but unfortunately this didn't help me. I created a systemwide file in /etc/systemd/system.conf.d/60_custom.conf. Tried going even as high as 90s, but I still get same behaviour: those messages appear and the system shuts down very quickly.
jaakoppi71
Level 1
Level 1
Posts: 26
Joined: Sat Mar 23, 2019 10:51 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by jaakoppi71 »

solved
Last edited by jaakoppi71 on Mon Jun 29, 2020 1:54 am, edited 2 times in total.
User avatar
honolulu
Level 1
Level 1
Posts: 19
Joined: Wed Mar 25, 2020 6:54 am

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by honolulu »

I'm having the same problem, latest Nvidia drivers.
Do you guys have encrypted drives? Solutions I have found online are very outdated.
missmoondog
Level 5
Level 5
Posts: 549
Joined: Wed Nov 07, 2018 9:17 am

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by missmoondog »

noticed this same error on one of my computers some time ago. been going to post asking about it since but never caught the full error message. not positive but do know for sure it shows up on at least 2 machines but maybe 3. all 3 are running mint 19.3 xfce 64bit. don't think the laptop i'm on right now gets that message so not going to try the command to see what i get but will probably tomorrow when i can get on a machine that i know gets it.

bookmarking topic now and will follow up.
Handy7000
Level 1
Level 1
Posts: 10
Joined: Wed Apr 01, 2020 5:08 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by Handy7000 »

I have this same problem too.

The difference in my case is that in shutting down, either through the GUI or through the terminal, the system invokes a reboot instead. My system is an old Asus laptop UX21E. After playing around with a few options, I noticed that this behaviour only occurred when the laptop was connected to the charger. When the laptop was removed from the charger and operated only on battery, it shutdown correctly and did not reboot.

I have since booted with older kernels that were already installed on my system and the same problem is evident with 4.15.0-91, 4.15.0-76, 4.15.0-74 and 4.15.0-72. The oldest kernel I have have however works with no problem at all - 4.15.0-20.

So I'm thinking this might be a kernel bug or acpi issue
Last edited by karlchen on Wed Apr 01, 2020 5:57 pm, edited 1 time in total.
Reason: corrected to read all the 14.15.0-xx kernels to be 4.15.0-xx instead.
naqer
Level 1
Level 1
Posts: 1
Joined: Wed Apr 01, 2020 8:37 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by naqer »

I just purchased a lenovo c940 and installed a fresh copy of mint 19.3 and had the samed issue.

After lots of digging around I turned off swap "swapoff -a" and issued a shutdown and it worked, perfectly.

I then booted it up again, commented out the swap entry in the fstab (its a file on my system not a partition FYI) and issued "swapoff -a" again.

Reboot results: working.

powered off result: working.

Hope this can help those of you who can disable swap, I can.
missmoondog
Level 5
Level 5
Posts: 549
Joined: Wed Nov 07, 2018 9:17 am

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by missmoondog »

HAWR wrote:
Sat Mar 07, 2020 12:59 pm
Hello karlchen,

I've read in the german linux forum, that removing casper and finalrd (which was new installed with last casper version) packages let the error messages disappear.
i have seen this mentioned a couple times in this topic, but haven't done it yet, so i guess my question would be, if this works, why would that message only show up on a few machines and not everyone's, or, as in my case, that shut down message shows up on only 2 out of 6 mint 19.3 xfce machines? message might show up on 3 out of 6 here, but haven't been on that one odd ball machine in a while.

the 2 machines i know it shows up on do have nvidia cards but the other one that i can't remember if it shows up on doesn't. haven't really worried about this issue much as it doesn't effect how long it takes to shut down at all.
ericj
Level 2
Level 2
Posts: 57
Joined: Tue Jan 01, 2019 1:42 pm

Re: Shutdown problems - Failed to wait for process: Protocol error

Post by ericj »

Yeah mine is still doing this, I don't really want to go deleting things, kinda thought by now with updates it would have been fixed. :(
Post Reply

Return to “Installation & Boot”