[SOLVED] Grub won't start anymore

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
User avatar
isyourfridgerunning
Level 1
Level 1
Posts: 15
Joined: Sat Feb 01, 2020 7:55 pm

[SOLVED] Grub won't start anymore

Post by isyourfridgerunning »

I solved this myself by re-selecting grub as an UEFI file trusted for executing.

Yesterday, when I installed Linux Mint 19.3 Cinnamon 64bit, everything was working fine. I restarted about 20 times, every time it was like it should be. But, today when I started my computer, it didn't start. It said:

Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\BOOT\mmx64.efi: Not Found
Failed to start MokManager: Not Found
Something has gone seriously wrong: import_mok_state failed
: Not Found

I thought I could fix it myself by just copying and pasting mmx64.efi into \EFI\BOOT\, but I don't know how and where to find it. I don't even know if what I'm trying to do is the correct way of fixing it. Please help me.

My computer is an Acer Aspire E5-575G.

I'm sorry if I'm slow to respond.
Last edited by isyourfridgerunning on Mon Feb 03, 2020 4:56 pm, edited 3 times in total.
You thought it was isyourfridgerunning, but it was I, DIO who uses arch btw

deepakdeshp
Level 17
Level 17
Posts: 7537
Joined: Sun Aug 09, 2015 10:00 am

Re: Grub won't start anymore

Post by deepakdeshp »

Boot from live USB and run
sudo fdisk -l
On the partition with around 250 mb space run
sudo fsck -y /dev/sdax replace x in the command with the number given by above fdisk command for the 250 mb partition number, it all be like sda1 etc.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
isyourfridgerunning
Level 1
Level 1
Posts: 15
Joined: Sat Feb 01, 2020 7:55 pm

Re: [SOLVED] Grub won't start anymore

Post by isyourfridgerunning »

Hey deepakdeshp, sorry for wasting your time. I managed to fix it myself (although with a different method, I'll add to the main post it after I post this reply) but I had to go so I couldn't edit it in. Although, if my method turns out to stop working again I'll try what you said. Again, I'm sorry for wasting your time.
You thought it was isyourfridgerunning, but it was I, DIO who uses arch btw

deepakdeshp
Level 17
Level 17
Posts: 7537
Joined: Sun Aug 09, 2015 10:00 am

Re: [SOLVED] Grub won't start anymore

Post by deepakdeshp »

Good to know that you fixed it. Please post the solution here.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
isyourfridgerunning
Level 1
Level 1
Posts: 15
Joined: Sat Feb 01, 2020 7:55 pm

Re: [SOLVED] Grub won't start anymore

Post by isyourfridgerunning »

I put the solution at the start of the first post.
You thought it was isyourfridgerunning, but it was I, DIO who uses arch btw

Post Reply

Return to “Installation & Boot”