Grub hangs while loading stage 1.5

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 3
Joined: Fri Aug 14, 2009 9:11 am

Grub hangs while loading stage 1.5

Post by chris19802 » Fri Aug 14, 2009 9:20 am

Hi Guys,

I'm fairly new to Linux, although I've been running Ubuntu for a few months, and I'm completely new to Linux Mint. I wonder whether anyone can help me with a problem I'm having when trying to get Grub to boot Linux Mint from a USB key?

The USB key has three primary partitions:
1. A FAT32 partition at the beginning of the disk so that I can still use the USB key as regular data storage.
2. An EXT3 partition which is set as bootable and has a fresh installation of Linux Mint on it. This is also the partition that contains Grub.
3. A small swap partition.

When I boot into the usb key I get a message as normal saying, "Grub loading stage 1.5", but at this point it just hangs and will not proceed any further. I've tried booting into the live cd and through a terminal re-running the grub setup against the partition. I've also tried deleting the stage 1.5 file and re-running the setup, but nothing seems to be making a difference.

Can anybody offer any advice on this?

Thanks in advance,

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Grub hangs while loading stage 1.5

Post by Husse » Sun Aug 16, 2009 7:59 am

Probably because of gfxgrub - this wiki helps
Don't fix it if it ain't broken, don't break it if you can't fix it

Post Reply

Return to “Installation & Boot”