ssd raid not detected as ssd

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
MintyFresh22
Level 1
Level 1
Posts: 10
Joined: Fri Jan 17, 2020 9:50 am

ssd raid not detected as ssd

Post by MintyFresh22 »

Hi,

I have 19.3 Mate freshly installed on a pair of ssd drives (RAID 1) connected to an adaptec 6405 raid card, there's only one partition and it is btrfs. btrfs looks at sys/block/DEV/queue/rotational to decide whether a device is solid state in order to enable optimisations if it finds 0. On my system, probably due to the raid controller getting in the way, that file contains 1.

I think I can force it to mount with the ssd options by changing
UUID=<snip> / btrfs noatime,defaults,subvol=@ 0 1
to
UUID=<snip> / btrfs ssd,noatime,defaults,subvol=@ 0 1
Is that correct?

Does anything else rely on sys/block/DEV/queue/rotational and should I try to fix that instead? I'm assuming it would just get written over if i changed it myself.

Thanks

User avatar
Kadaitcha Man
Level 8
Level 8
Posts: 2187
Joined: Mon Aug 27, 2012 10:17 pm

Re: ssd raid not detected as ssd

Post by Kadaitcha Man »

MintyFresh22 wrote:
Sat Apr 04, 2020 7:55 am
I think I can force it to mount with the ssd options by changing
UUID=<snip> / btrfs noatime,defaults,subvol=@ 0 1
to
UUID=<snip> / btrfs ssd,noatime,defaults,subvol=@ 0 1
Is that correct?
According to this: https://btrfs.wiki.kernel.org/index.php ... e/btrfs(5)

Yes. The behaviour you describe is expected because the card is primarily used with spinning rust disks. The card's kernel isn't smart enough to know that it should report that SSDs are connected.
It's pronounced kad-eye-cha, not kada-itcha.

Post Reply

Return to “Installation & Boot”