Page 1 of 1

[SOLVED!]19.3 dual-boot install on Win 10 - weird boot problem

Posted: Sun Apr 12, 2020 10:30 pm
by pstrbrc
Lenovo Thinkcentre M78, reconditioned but new to me.
I've been Windoze-free since Ubuntu 8.04, but I've been back into a corner and am required to use a Win OS occasionally, so went with a dual boot. Have been using Mint since 17.1, and had 19.3 on my last to end-of-life computers. OK. I'm familiar with the drill. Used a live USB drive. But there's no brief dos message about getting to the dos menu, so I first tryed [F2] during boot. Didn't faze Win 10 for a second. Tryed [F12], and got a boot menu, chose [usb], and continued on to a dual-boot set-up. The next time I booted, No boot-loader menu, just straight to Win10. So when I boot to Mint, I have to use [F12] to get to the boot menu, where I have an [Ubuntu boot] option. So, where's my GRUB boot-loader? What am I missing?

Re: [SOLVED!]19.3 dual-boot install on Win 10 - weird boot problem

Posted: Sun Apr 12, 2020 10:51 pm
by thomas.raines
You marked this as solved, but where is the resolution?

Re: [SOLVED!]19.3 dual-boot install on Win 10 - weird boot problem

Posted: Sun Apr 12, 2020 10:52 pm
by pstrbrc
Boy, I feel like a newb! I finally found the path to the bios menu (F1) and started rummaging through the options. First, disabled "Quick boot." Nope. Then disabled "Secure boot." Ditto. But then I looked at the boot order list. "Windows boot manager", and two different lines just titled "Ubuntu."
I picked one of them, set it as the top of the boot order, closed to bios menu, and Shazam!! See Mr. GRUB menu!!
Is this just with IBM/Lenovo machines? I vaguely remember this with an old T61 ThinkPad. Anyway, Happy Trails.

Re: [SOLVED!]19.3 dual-boot install on Win 10 - weird boot problem

Posted: Sun Apr 12, 2020 11:25 pm
by thomas.raines
I'm glad you found the fix, and thank you for posting it for others. I'm not sure if it's limited to IBM devices as I had this issue on an older ASUS laptop on mint 15, and my last custom pc which was an ASUS mobo. But on my latest build, I booted to bios first and prioritized my boot drives. My guess, would be it's windblows and the fact that most manufacturers tailor to windblows.