Plymouth splash not showing when booting from nvme

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
thomas.raines
Level 1
Level 1
Posts: 43
Joined: Mon Feb 11, 2013 12:03 am

Plymouth splash not showing when booting from nvme

Post by thomas.raines »

So, I recently built a new rig. I used an m.2 nvme device to install Linux Mint 19.3 to. With everything I read, in order to boot from an nvme device, I had to install mint in efi mode. Not a problem. I successfully installed and booted with the m.2 device. No major issues. But, on my previous installation, I had winblows 10 on a separate drive in efi. I had mint 19.3 install on another drive (both ssd's) with it's own separate efi partition. I had done this for testing purposes only. When I installed mint to the m.2 device, I left the windblows ssd plugged in (for testing I unplugged it so linux would have it's own efi), and now linux shares the efi with winblows. To my understanding, this is how it is suppose to be done. When I was testing efi mode on linux, I could to boot windblows from grub. So, enough with the long intro, and on to the problem...
Since installing mint 19.3 to the nvme device with efi, I no longer get my boot splash. Instead, I get my bios boot logo. I have an Asus ROG Strix x399-E Gaming mobo, and I ge thte ROG bios boot logo. When I boot to windblows, I get the same bios boot logo. When booting in to mint, I hit the "esc" key, but instead of getting the text scrolling across the screen, I get ^[ in the upper left hand corner, then I see the login text like I would see in tty1, and the system boots. I have tried booting with 3 older kernels, reinstalling grub-efi-amd64-signed and all it's dependencies, ran update-alternatives --config default.plymouth to esure my boot splash is selected, rebuiding intiramfs, and ensured quiet splash is in grub command line. Secure boot is enabled in my bios by default and no way to change it. But I do have CSM enabled and other OS selected for secure boot. I did change quiet splash to just splash, update grub and rebooted. I then got the expected text roaring across my screen.
I'm not completely sure, but this does seem like an efi related issue. But how do I fix it? I'm not sue what system information is needed, but I already stated my mobo/boot drive, and my gpu is an EVGA Geforce GTX 1060 3gb. Oh, I'm not sure if this matters, but windblows is still on it's own ssd.

So, I did some hacking and experminting and found that it isn't bios or efi. It's NVIDIA drivers. There are several threads out there that seem to point to a fix as this appears to be an old issue, but none of those suggestion fix the issue I'm experiencing. Is there any kind of logs I can look at to see what is causing my bootsplash to not show?
Post Reply

Return to “Installation & Boot”