Anyone else having issues Kernel 5.3.0-53.109?

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
sanjeep
Level 1
Level 1
Posts: 6
Joined: Mon Oct 14, 2019 10:56 am

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by sanjeep »

LanceM wrote:
Mon May 25, 2020 1:49 pm
Sometimes it's the ESC key. That's what mine are.
Mine as well - just did my roll-back to .51 and uninstalled .53. Couldn't power off even through the terminal.

User avatar
OveS
Level 3
Level 3
Posts: 156
Joined: Fri Jan 01, 2016 3:26 pm
Location: France

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by OveS »

I had also rolled back to .51 and removed .53

Today I noticed that 5.4.0-31 appeared in Kernel Manager, maybe because I have canonical-kernel-team PPA enabled. I installed it, rebooted and it seems to work well. I rebooted again to test if Restart works and yes, it does.
--
Ideapad 530S-14ARR - Linux Mint 19.3 Cinnamon, Thinkpad X240 - Linux Mint 19.3 Cinnamon,
iMac 20" (early-2008), Raspberry Pi 3 and 4

User avatar
LanceM
Level 9
Level 9
Posts: 2595
Joined: Sun Jul 08, 2018 11:50 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by LanceM »

OveS wrote:
Tue May 26, 2020 10:16 am
I had also rolled back to .51 and removed .53

Today I noticed that 5.4.0-31 appeared in Kernel Manager, maybe because I have canonical-kernel-team PPA enabled. I installed it, rebooted and it seems to work well. I rebooted again to test if Restart works and yes, it does.
Yes, fixed apparently. That was quick.
Edit: It did not fix it. It booted, but wouldn't shutdown sometimes.
Last edited by LanceM on Mon Jun 15, 2020 11:20 pm, edited 1 time in total.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php

freshmaker
Level 1
Level 1
Posts: 3
Joined: Fri May 22, 2020 9:30 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by freshmaker »

Has the issue been fixed in the 5.3.0.53.110 kernel? My update manager just suggested it to me but I figured it's best to ask more experienced users.

User avatar
karlchen
Level 21
Level 21
Posts: 12726
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by karlchen »

Hello, freshmaker.

I would be amazed if kernel packages 5.3.0-53.110 would bring any improvement at all with respect to the problems reported here, affecting mainly machines with Ryzen CPUs and AMD graphics chips.

The actual kernel, which 5.3.0-53.110 brings along is the same, which we had received with 5.3.0-53.109 already.

Why then is there an update labelled 5.3.0-53.110?
(to be learned from the changelog)
An incorrect dependency had been specified in the meta packages version 5.3.0.53.109. This error only affected those users, who used a specific virtualization package.
If your system does not use the corresponding package, then kernel 5.3.0-53.109 had installed without problems, inspite of the incorrect dependency, and your system only installs the corrected meta packages, nothing else.
All those, who have already installed kernel 5.3.0.53-109 without issues, only get the following (corrected) meta packages:

Code: Select all

linux-generic-hwe-18.04 (5.3.0.53.109) to 5.3.0.53.110
linux-headers-generic-hwe-18.04 (5.3.0.53.109) to 5.3.0.53.110
linux-image-generic-hwe-18.04 (5.3.0.53.109) to 5.3.0.53.110
Best regards,
Karl
Image
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

User avatar
LanceM
Level 9
Level 9
Posts: 2595
Joined: Sun Jul 08, 2018 11:50 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by LanceM »

freshmaker wrote:
Tue May 26, 2020 11:29 am
Has the issue been fixed in the 5.3.0.53.110 kernel? My update manager just suggested it to me but I figured it's best to ask more experienced users.
Today's patch 5.3.0-53.110 fixed a 3400G system that wouldn't boot to 5.3.0-53.109.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php

Demmers
Level 1
Level 1
Posts: 10
Joined: Fri Aug 16, 2019 7:37 am

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by Demmers »

Yep, can confirm latest .110 patch now works with my 3400G system also. Successful restart straight after update.

User avatar
NewWorldHero
Level 1
Level 1
Posts: 5
Joined: Mon Mar 12, 2018 9:50 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by NewWorldHero »

No. Not. Notta. No change what so ever using 5.3.0-53.110 on my Ryzen 5 3400G on a Asus B450 Pro motherboard machine. 110 did not fix the no shut off problem. Had to yet again roll back to 5.3.0-51 to merely get it to power off. Don't know what verification or proof you guys have that state 110 fixed the issue. It did not.
Home and personal use technology is an expense, not an investment..

User avatar
MrEen
Level 20
Level 20
Posts: 10680
Joined: Mon Jun 12, 2017 8:39 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by MrEen »

NewWorldHero wrote:
Tue May 26, 2020 9:32 pm
Don't know what verification or proof you guys have that state 110 fixed the issue. It did not.
From reading the replies, I'd hazard a guess they installed it, rebooted, and found their systems worked. That's proof enough for them, I'm sure.

Maybe the next kernel update will get the rest of the bugs out so your system also works. You may want to add to the bug report though.

EDIT: Kind of odd though, the 2 that reported it fixed their issue each had opposite issues originally. One couldn't boot, the other couldn't shut down. Oops, I misread Demmers post history and may not have been a shutdown issue after all.

Demmers
Level 1
Level 1
Posts: 10
Joined: Fri Aug 16, 2019 7:37 am

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by Demmers »

My bad guys, my original issue was not being able to both restart and shutdown.
After I installed .110, I had a successful restart, which I never had before on the previous update. However, for reasons I can't figure out, I am now unable to not only shutdown but restart again as well, so I am back to square one.
I will add that I use this computer for folding (folding@home) so don't always shut it down regularly enough to notice issues like these. I will look to revert back to .51.

kostas
Level 1
Level 1
Posts: 3
Joined: Thu May 28, 2020 5:29 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by kostas »

I had the same problem with AMD graphic card and kernel 5.3.0-53.109 when shutting down. I reverted to 5.3.0-51 and the problem was solved.

vinnievegas
Level 1
Level 1
Posts: 31
Joined: Sun Jan 10, 2010 2:55 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by vinnievegas »

Demmers wrote:
Wed May 27, 2020 11:40 am
My bad guys, my original issue was not being able to both restart and shutdown.
After I installed .110, I had a successful restart, which I never had before on the previous update. However, for reasons I can't figure out, I am now unable to not only shutdown but restart again as well, so I am back to square one.
I will add that I use this computer for folding (folding@home) so don't always shut it down regularly enough to notice issues like these. I will look to revert back to .51.
Just so I can understand this better I would like to walk with you on your what appears to have been your two attempts of two newer Kernel updates.
  • Originally you were on a kernel version that worked just fine.
  • You were able to reboot and shutdown with no issues.
  • Then the .109 update was released and you updated to that and then you could not reboot and or shut down properly.
  • At this point you revert back to the Kernel that did allow you to reboot and shutdown properly.
  • Then the .110 update is released so you update to that Kernel and again you're not able to reboot or shutdown properly.
  • So you revert back to the working kernel before .109.
If this was how your scenario played out then I would assume the reason you had a one time successful restart after the .110 update is due to having the working kernel active before rebooting. The .110 kernel wouldn't be active until the reboot is completed. I'm saying all this to hopefully make you understand why you had a one time successful restart.

Demmers
Level 1
Level 1
Posts: 10
Joined: Fri Aug 16, 2019 7:37 am

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by Demmers »

vinnievegas wrote:
Sun May 31, 2020 9:27 am
Thanks for that, yes that makes sense. Lesson learnt :)
Last edited by karlchen on Thu Jun 04, 2020 1:42 pm, edited 1 time in total.
Reason: No need to quote the full post right above yours. Full quote removed.

Rance Petersen
Level 1
Level 1
Posts: 7
Joined: Wed Oct 11, 2017 5:49 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by Rance Petersen »

I'm having this issue as well, on my uncle's computer. I rolled back to a previous kernel and blocked the update to .53 but it somehow came back again. I gotta go to his house yet again to solve this.

This is the third time Mint has broken things on his computer in a time span of just a few months.

This is unacceptable for a system in which its defenders love to boast how much "better, stable and secure" it is compared to Windows, specially when it comes to updates.

User avatar
LanceM
Level 9
Level 9
Posts: 2595
Joined: Sun Jul 08, 2018 11:50 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by LanceM »

I gotta go to his house yet again to solve this.
Once you get back to 51, you uninstall 53. Run the updater again and blacklist that kernel. To do that highlight it and choose "ignore the..."
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php

Rance Petersen
Level 1
Level 1
Posts: 7
Joined: Wed Oct 11, 2017 5:49 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by Rance Petersen »

LanceM wrote:
Fri Jun 05, 2020 2:28 pm
Once you get back to 51, you uninstall 53. Run the updater again and blacklist that kernel. To do that highlight it and choose "ignore the..."
I did that and still came back. Maybe there was another update to the 53 this past week since I specifically blacklisted the 109, I don't know.

By the way, in prior versions of Mint, when you ran the updater for the first time, it asked you what sort of updates you wanted to get, one of the options was to only get stable ones(I guess it skipped new kernel versions). I didn't get that with this new install.

Where can I find that option again?

User avatar
LanceM
Level 9
Level 9
Posts: 2595
Joined: Sun Jul 08, 2018 11:50 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by LanceM »

Yes, 110 was a small update to 53. It should not of hosed his system. Can you post his system configuration?
Where can I find that option again?
Gone the way of the dinosaurs.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php

Rance Petersen
Level 1
Level 1
Posts: 7
Joined: Wed Oct 11, 2017 5:49 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by Rance Petersen »

LanceM wrote:
Fri Jun 05, 2020 3:09 pm
Yes, 110 was a small update to 53. It should not of hosed his system. Can you post his system configuration?
OS: Mint 19.3 Cinnamon x64
CPU: AMD Ryzen 3 3200G
GPU: Onboard ( Radeon Vega 8 )
MOBO: ASRock A320M-HD ( BIOS ver 6.10 )
RAM: G.Skill Aegis 8GB ( 1x8 ) DDR4 2800Mh
Storage: SSD Pichau 256GB PG256X

User avatar
LanceM
Level 9
Level 9
Posts: 2595
Joined: Sun Jul 08, 2018 11:50 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by LanceM »

Well it meets the criteria for the issue. Only thing I can suggest is to see if 110 got installed and if so revert to 51 again and blacklist again.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php

User avatar
LanceM
Level 9
Level 9
Posts: 2595
Joined: Sun Jul 08, 2018 11:50 pm

Re: Anyone else having issues Kernel 5.3.0-53.109?

Post by LanceM »

A new kernel is available in the Update Manager 5.3.0-59 Hopefully will fix the issue for this.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php

Post Reply

Return to “Installation & Boot”