[ SOLVED ] Windows not showing up in Grub

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
jarp53
Level 3
Level 3
Posts: 138
Joined: Mon Jun 01, 2015 11:54 am

[ SOLVED ] Windows not showing up in Grub

Post by jarp53 »

I have Mint (xfce) - LMDE4 - and windows all in separated drives; when I do update -grub on mint and lmde, they both see windows, but when I start or restart nether one will show windows in their grub menus , the only way I can turn windows is by the bios menu . any way I can fix this problem .
Last edited by jarp53 on Sun Jun 14, 2020 8:50 am, edited 1 time in total.
rene
Level 16
Level 16
Posts: 6613
Joined: Sun Mar 27, 2016 6:58 pm

Re: Windows not showing up in Grub

Post by rene »

This would seem to only be possible if the BIOS isn't in fact booting from the drive that a by both Mint and LMDE used Grub is on. I.e., make sure that the BIOS boots from whichever drive the by e.g. Mint controlled Grub is in fact on if you want Mint to control Grub in this case (and note, then, that the mere fact that LMDE is on a second drive does not mean that its bootloader is).
jarp53
Level 3
Level 3
Posts: 138
Joined: Mon Jun 01, 2015 11:54 am

Re: Windows not showing up in Grub

Post by jarp53 »

both Mint and LMDE see each other at the boot loader , I can start with either one but again nether of the booth loaders see windows , when I install I always unplug the other drives that are not being use , and in the past I never had a problem like this , but is just that start it to use Mint again that this is happening
I
rene
Level 16
Level 16
Posts: 6613
Joined: Sun Mar 27, 2016 6:58 pm

Re: Windows not showing up in Grub

Post by rene »

Seems to make little sense but let us just reinstall Grub. Assuming /dev/sda is the Mint disk and that Mint is to control Grub, boot into it and run sudo grub-install /dev/sda. Rebooting from that disk should now definitely show all entries that the sudo update-grub from within Mint detected.
jarp53
Level 3
Level 3
Posts: 138
Joined: Mon Jun 01, 2015 11:54 am

Re: Windows not showing up in Grub

Post by jarp53 »

unfortunately this did not work but there was some info on reinstalling grub from the installation drive , so I try that and LMDE is working properly, but Mint while still boots and sees windows and LMDE on grub-update , it does not show windows in the boot menu ; so I set LMDE to boot first that way I have all my options and I'm not worry because if I ever need it Mint will boot normal .
Post Reply

Return to “Installation & Boot”