DualBoot / Wrong Time in Win10?

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Rapid1898
Level 1
Level 1
Posts: 33
Joined: Mon Jun 01, 2020 3:16 pm

DualBoot / Wrong Time in Win10?

Post by Rapid1898 »

Hello,

my dual boot system is up and running and more or less fine -

But is still have the wrong time in Win10 (3 hours earlier at every boot).

I found something to solve this problem but it did not work for me:
https://www.howtogeek.com/323390/how-to ... l-booting/

I changed the time for linux to local TZ:

Code: Select all

rapid1898@rapid1898-B85-HD3:~$ timedatectl
                      Local time: Mo 2020-06-15 09:51:01 CEST
                  Universal time: Mo 2020-06-15 07:51:01 UTC
                        RTC time: Mo 2020-06-15 06:20:36
                       Time zone: Europe/Vienna (CEST, +0200)
       System clock synchronized: no
systemd-timesyncd.service active: yes
                 RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
         This mode can not be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.
And in Win10 the registry entry RealTimeIsUniversal is not in the registry at all

Why the time is still incorrect in Win10?
Is it necessary to do anything else with timedatectl?
User avatar
Kadaitcha Man
Level 9
Level 9
Posts: 2597
Joined: Mon Aug 27, 2012 10:17 pm

Re: DualBoot / Wrong Time in Win10?

Post by Kadaitcha Man »

Rapid1898 wrote:
Mon Jun 15, 2020 3:54 am
And in Win10 the registry entry RealTimeIsUniversal is not in the registry at all
That's because you need to add it.

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
     "RealTimeIsUniversal"=hex(b):01,00,00,00,00,00,00,00

Paste that into a text file on Windows, rename it to have a .reg extension and run it. The change will cause Windows to use the hardware clock in the same way that Linux uses it.
It's pronounced kad-eye-cha, not kada-itcha.
Rapid1898
Level 1
Level 1
Posts: 33
Joined: Mon Jun 01, 2020 3:16 pm

Re: DualBoot / Wrong Time in Win10?

Post by Rapid1898 »

I changed the RealTimeIsUniversal back to value 1
(using your code and also checked it afterwards in regedit)

But the time in Win10 is still wrong...

Is the timedatectl output below fully ok?
User avatar
erginemr
Level 4
Level 4
Posts: 315
Joined: Thu Jun 11, 2020 11:19 pm
Location: Istanbul, TR

Re: DualBoot / Wrong Time in Win10?

Post by erginemr »

As a dual boot user, I had the same issue. The problem arises from the fact that in Linux Mint time is set by UTC and changing local computer time accordingly, whereas in Windows 10 it is taken from the local computer.

The following command (that you used) solved my problems. (Ref. viewtopic.php?t=226779)

Code: Select all

timedatectl set-local-rtc 1


You basically need to either drag Linux to use local time, or drag Windows to use UTC, but not both.

The suggestion above is for the Windows part, and is correct, but should be applied only when you do not mess with the Linux UTC setting.

So, what I suggest for you to take it back in Windows, adjust the time from within Windows, reboot in Linux, and then reboot in Windows to re-check the time.
Free as in free speech...
Rapid1898
Level 1
Level 1
Posts: 33
Joined: Mon Jun 01, 2020 3:16 pm

Re: DualBoot / Wrong Time in Win10?

Post by Rapid1898 »

Ok - so this was my initial posting -
(changed the thing in linux and don´t do anything in win10)

So again - timedatectl looks like that in linux

Code: Select all

rapid1898@rapid1898-B85-HD3:~$ timedatectl
                      Local time: Mo 2020-06-15 09:51:01 CEST
                  Universal time: Mo 2020-06-15 07:51:01 UTC
                        RTC time: Mo 2020-06-15 06:20:36
                       Time zone: Europe/Vienna (CEST, +0200)
       System clock synchronized: no
systemd-timesyncd.service active: yes
                 RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
         This mode can not be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.


And there is no more entry in regedit Win10 regarding RealTimeIsUniversal.

But still in windows it shows me 6:25 when its 14:55...
User avatar
erginemr
Level 4
Level 4
Posts: 315
Joined: Thu Jun 11, 2020 11:19 pm
Location: Istanbul, TR

Re: DualBoot / Wrong Time in Win10?

Post by erginemr »

Linux part is OK. You need to manually adjust Windows clock once. (Or let it auto-update from the time server.)
Free as in free speech...
Rapid1898
Level 1
Level 1
Posts: 33
Joined: Mon Jun 01, 2020 3:16 pm

Re: DualBoot / Wrong Time in Win10?

Post by Rapid1898 »

It is still not working...

When i boot the Win10-system it has the same time when i did the last sync / upate of the time...
User avatar
erginemr
Level 4
Level 4
Posts: 315
Joined: Thu Jun 11, 2020 11:19 pm
Location: Istanbul, TR

Re: DualBoot / Wrong Time in Win10?

Post by erginemr »

Hi, have you made any progress?
Free as in free speech...
Rapid1898
Level 1
Level 1
Posts: 33
Joined: Mon Jun 01, 2020 3:16 pm

Re: DualBoot / Wrong Time in Win10?

Post by Rapid1898 »

No - it is still not working - when shut down the pc - and start it later - the time is allways false.

Wrote a small bat-file and put it on the desktop:
W32tm /resync /force
(when i click that the time get synched)

Tried also to but this bat-file to the autostart (so this would be a workaround for me).
But i am not able to start the bat-file from autostart so far...
User avatar
erginemr
Level 4
Level 4
Posts: 315
Joined: Thu Jun 11, 2020 11:19 pm
Location: Istanbul, TR

Re: DualBoot / Wrong Time in Win10?

Post by erginemr »

Sorry to hear that. I had exactly the same problem and could solve it this way. But to each their own, I guess.

For Windows, you should be able to add this batch file to the startup folder in the Windows menu.
Free as in free speech...
Rapid1898
Level 1
Level 1
Posts: 33
Joined: Mon Jun 01, 2020 3:16 pm

Re: DualBoot / Wrong Time in Win10?

Post by Rapid1898 »

Put the batch file to the autostart - but it is still not excecuting...
Post Reply

Return to “Installation & Boot”