Page 1 of 4

[SOLVED] initramfs unpacking failed: Decoding failed

Posted: Mon Jun 29, 2020 3:29 am
by CyrilFR
Hello :)
it seems to be a common bug but I get this error message during boot time
initramfs unpacking failed: Decoding failed
this message what not here with LM19.3
my setup : https://termbin.com/8gci :shock:

Re: initramfs unpacking failed: Decoding failed

Posted: Mon Jun 29, 2020 3:35 am
by Kadaitcha Man
CyrilFR wrote:
Mon Jun 29, 2020 3:29 am

Code: Select all

initramfs unpacking failed: Decoding failed
Paste this into a terminal:

Code: Select all

xed admin:///etc/initramfs-tools/initramfs.conf
Change COMPRESS=lz4 to COMPRESS=gzip

Save the changes then:

Code: Select all

sudo update-initramfs -u
and reboot.

Re: initramfs unpacking failed: Decoding failed

Posted: Mon Jun 29, 2020 8:18 am
by Aryanprince
I had the same issue on LM 20, and the suggestion fixed the problem. However can someone tell us more about it, what the problem was, and what this fix actually did? Thanks.

Re: initramfs unpacking failed: Decoding failed

Posted: Mon Jun 29, 2020 12:18 pm
by janne6767
I am getting [0.5910114] Initramfs unpacking failed: Decoding failed when trying to boot from Linux Mint 20 installation media (DVD or USB drive, both fails).

Linux Mint 19.3 works fine on the same desktop computer.

Janne

Re: initramfs unpacking failed: Decoding failed

Posted: Mon Jun 29, 2020 1:11 pm
by CyrilFR
I had solved the problem by install the initramfs packet with the update manager :|

Re: initramfs unpacking failed: Decoding failed

Posted: Mon Jun 29, 2020 1:17 pm
by smurphos

Re: initramfs unpacking failed: Decoding failed

Posted: Mon Jun 29, 2020 5:24 pm
by mint-me
For now, I guess its ok to ignore the warning?

Wait for a kernel update?

Re: initramfs unpacking failed: Decoding failed

Posted: Tue Jun 30, 2020 2:17 am
by janne6767
janne6767 wrote:
Mon Jun 29, 2020 12:18 pm
I am getting [0.5910114] Initramfs unpacking failed: Decoding failed when trying to boot from Linux Mint 20 installation media (DVD or USB drive, both fails).

Linux Mint 19.3 works fine on the same desktop computer.

Janne
Still no success.

Mint 19.3 installation media boots from usb ok. LM 20 installation media boot fails to the error message (Initramfs unpacking failed: Decoding failed)

I have verified LM20 iso against sha256 sum.

Hardware info
https://jainkila.kapsi.fi/temp/lshw.txt

Janne

Re: initramfs unpacking failed: Decoding failed

Posted: Tue Jun 30, 2020 3:04 am
by smurphos
janne - report this as a bug at https://github.com/linuxmint/linuxmint/issues

This error was raised in the beta, but not as an issue preventing the live iso from booting at all.

I've just doublechecked booting the stable live ISO on both my machines and it boots fine albeit the error does show in journalctl output when run just after booting the live session.

It might be worth you experimenting with a different USB stick or using different USB ports.

Re: initramfs unpacking failed: Decoding failed

Posted: Tue Jun 30, 2020 3:13 am
by smurphos
mint-me wrote:
Mon Jun 29, 2020 5:24 pm
For now, I guess its ok to ignore the warning?

Wait for a kernel update?
Well there doesn't seem to be a huge amount developer interest in the upstream bug as yet and it was introduced over 6 months ago. If it's not preventing you booting then I guess don't worry about it. Or apply the tweak outlined in the bug report or as described by Kadaitcha Man a few posts above which returns the compression method to what is was for Mint 19.x, Ubuntu 18.04.

Re: initramfs unpacking failed: Decoding failed

Posted: Tue Jun 30, 2020 7:36 am
by mint-me
thanks for confirmation smurphos :wink:

my bootup is fine, so will leave it as is.

Re: initramfs unpacking failed: Decoding failed

Posted: Mon Jul 13, 2020 2:16 am
by cool_montes
Hello everybody, in my case I just opened synaptics, looked for lz4, and installed everything it seems to be related to it for me.
Sorry about my English :)

Re: initramfs unpacking failed: Decoding failed

Posted: Tue Jul 14, 2020 8:28 am
by thorsen
janne6767 wrote:
Tue Jun 30, 2020 2:17 am
janne6767 wrote:
Mon Jun 29, 2020 12:18 pm
I am getting [0.5910114] Initramfs unpacking failed: Decoding failed when trying to boot from Linux Mint 20 installation media (DVD or USB drive, both fails).

Linux Mint 19.3 works fine on the same desktop computer.

Janne
Still no success.

Mint 19.3 installation media boots from usb ok. LM 20 installation media boot fails to the error message (Initramfs unpacking failed: Decoding failed)

I have verified LM20 iso against sha256 sum.

Hardware info
https://jainkila.kapsi.fi/temp/lshw.txt

Janne
Any advance with that? I have the exact same problem. Thought was something related to hardware so I have updated BIOS but, even so, installation is not running.
I've tried same USB with other laptop and no problem at all

Re: initramfs unpacking failed: Decoding failed

Posted: Tue Jul 14, 2020 10:47 pm
by S3NTYN3L
Kadaitcha Man wrote:
Mon Jun 29, 2020 3:35 am
Change COMPRESS=lz4 to COMPRESS=gzip
Thank you!

Re: initramfs unpacking failed: Decoding failed

Posted: Tue Jul 14, 2020 11:19 pm
by Kadaitcha Man
S3NTYN3L wrote:
Tue Jul 14, 2020 10:47 pm
Kadaitcha Man wrote:
Mon Jun 29, 2020 3:35 am
Change COMPRESS=lz4 to COMPRESS=gzip
Thank you!
No worries. Glad it helped.

Re: initramfs unpacking failed: Decoding failed

Posted: Wed Jul 15, 2020 1:18 am
by smurphos
Interestingly I don't get this bug on my hardware with the new default lz4. No idea why not, I'd assumed it was universal given the number of people who'd noted it.

Re: initramfs unpacking failed: Decoding failed

Posted: Fri Jul 17, 2020 4:24 am
by N0HAM
Mint 20 on a Mac Air, upgraded from latest Mint 19 version a week ago, Running as Mint 20 only, removed Mac OS years ago.

This morning laptop started acting wanky in the browser and links would not execute on clicks and was asking me to log into things that should have already been signed into.

Decided to do a reboot and..... initramfs unpacking failed

I tried everything mentioned in this post. I could get to grub and a few other very limited command/menu areas, but calls were very limited. No matter what I did, after a reboot everything was back to the way before I made the changes.

Wound up booting from Mint 20 install USB. Tried to make the changes and after reboot, same thing, no matter what I did, no change were actually written to the drive just like before booting from USB.

The question I have to ask, is Mint 20 Stable?

Should I still change the compression method for initramfs?

When the laptop boots, the first few screens flash quickly with garbage on them, as it did before the crash. In Mint 19 the screen were readable but too fast for me to read them.

Re: initramfs unpacking failed: Decoding failed

Posted: Fri Jul 17, 2020 8:10 am
by mandoman
Instructions to correct problem by Kadaitcha Man worked for my Inspiron.

Re: initramfs unpacking failed: Decoding failed

Posted: Fri Jul 17, 2020 8:10 pm
by guythp
Kadaitcha Man wrote:
Mon Jun 29, 2020 3:35 am
CyrilFR wrote:
Mon Jun 29, 2020 3:29 am

Code: Select all

initramfs unpacking failed: Decoding failed
Paste this into a terminal:

Code: Select all

xed admin:///etc/initramfs-tools/initramfs.conf
Change COMPRESS=lz4 to COMPRESS=gzip

Save the changes then:

Code: Select all

sudo update-initramfs -u
and reboot.
Thank you; I noticed this error message popping up after I recently upgraded my laptop from 19.3 to 20. I don't know what the error meant but the fact that there was one irritated me even though there seemed to be no effect from it other than the error message. So thank you again. :)

(and thanks to the OP for allowing my search to find this post)

Re: initramfs unpacking failed: Decoding failed

Posted: Sat Jul 18, 2020 12:28 am
by Cenuel
Does this specific error message come up twice during boot for anyone else? I got the error message immediately at the beginning of the boot process, and then it would proceed a bit and flash an error (possibly the identical error, possibly something else) so quickly I can't quite read what it's saying closer to the end of the boot process. I followed the instructions given by Kadaitcha Man in post two, and the initial message is gone but I still see a flash of illegible error message at the second point it displayed. I am not noticing any issues beyond the display of the message in and of itself so far.