Page 1 of 1

Installation of LM 20, 19.3, ...

Posted: Mon Jun 29, 2020 3:39 pm
by Ctulhu
I have been unable to install LM 20 on an EightVirtues laptop and the company has not responded to email contact (even though I am only 1.5 years in a 4-year warranty). The problems are multiple and unfortunately very diffuse:

- sometimes the system boots up (but only after a long time and then sometimes with the "initramfs unpacking failed: Decoding failed error" discussed elsewhere (I applied the fix discussed elsewhere, changing to gzip)
- IF the system boots up, it may freeze after 1-2 minutes or will DEF freeze if one tries to do the first round of updates, namely when it tries to update systemmd to 245.4.4ubuntu3.1)
- also, one can't really shut down without a bunch of error messages:
<https://drive.google.com/file/d/1owpikR ... sp=sharing>

I have tried so far is multiple installation attempts including:
- letting Mint's setup do everything fully automatically;
- completely reformatting the harddrive (with the Disks utility booted from USB drive) and then generating my own partition table with
-- an EFI partition
-- a / partition (ext4)
-- a /home partition (ext4)
-- a swap area
- playing around with the location of the bootloader (sda1 or the EFI partition).

I tried both Linux Mint 20 (which I set up successfully on an old laptop), Linux 19.3 (which was on the problem laptop before) - nothing works, and POP OS or Linux Mint Debian wouldn't even try and install, which really makes me think this is some SecureBoot / UEFI madness. Here is a screenshot of the current disk setup
<https://drive.google.com/file/d/1qgeC71 ... sp=sharing>
which is one where Iet the Mint Installer just 'take over'; this one sometimes boots, sometimes doesn't ... I have been using (K)Ubuntu/Mint since 2009, but I've' never had any problems like this,any input would be much appreciated ...